Sign in to follow this  
wigwam

Filestation: Please Install the latest Java suitable for you

Recommended Posts

This is driving me mildly crazy.

I'm on DSM 5.2-5592 Update 4

 

Doesn't matter which machine I access Xpenolgy from I keep getting the message to install the latest Java and that my Java security settings have blocked an application every time I click on file station.

 

BUT Java is up to date on every laptop or PC I am using to access the server.

 

Any clues please why it is saying this and how to resolve?

 

Thanks

Share this post


Link to post
Share on other sites

I think java is used to access local drives to see them appear in filestation tree

if you turn off that option it should stop asking for it

Share this post


Link to post
Share on other sites

But that still doesn't explain why it keeps asking for it even though Java is up to date?

Share this post


Link to post
Share on other sites

Does your browser automatically disable the Java plugin? FF for example blocks Java because it has vulnerabilities and you have the option to fully block it or ask for you to allow it on demand.

Share this post


Link to post
Share on other sites

Here are some images using Firefox to access local drives from within the DSM file manager.

 

xpenology_browser_java_issue_07.jpg

Check your plugin setting

 

xpenology_browser_java_issue_01.jpg

Blocked

 

xpenology_browser_java_issue_02.jpg

Temporarily allowed

 

xpenology_browser_java_issue_03.jpg

 

xpenology_browser_java_issue_04.jpg

 

xpenology_browser_java_issue_05.jpg

After allowing each popup the page will refresh

 

xpenology_browser_java_issue_06.jpg

Now you can access your local drives from the DSM file manager

Share this post


Link to post
Share on other sites

HI

Thanks for this helpful reply

I have tried it on IE, FF, Edge all with the same result

Java isn't blocked on IT or Edge AFAIK but I will check

Share this post


Link to post
Share on other sites

Just turn off in file station settings->general->browse local files, if you dont need it of course.

Share this post


Link to post
Share on other sites
HI

Thanks for this helpful reply

I have tried it on IE, FF, Edge all with the same result

Java isn't blocked on IT or Edge AFAIK but I will check

 

Maybe there is a difference between 32 and 64 bit versions of the browsers? The screen shots I took were from FF 32 bit.

Share this post


Link to post
Share on other sites
Sign in to follow this