How to tell if iGPU is been used for HW transcoding DS918+ (Esxi)


Recommended Posts

I have passed a DS918+ VM in Esxi , I have passed the iGPU (Intel 630 UHD) integrated in the Cpu to the VM . 

I see the /dev/dri folders, 

Video station is set to HW transcode and appear to be doing so . 

Any way to check I'm actually using the i915 / iGPU , rather than cpu ? 

 

Link to post
Share on other sites

I have managed to validate this , to update - I installed Jellyfin in docker , and was able to observe that HW transcoding is been used , using the iGPU passed through from ESXi (Intel 630 UHD, on i5-8500T ) 

Good news ! a separate Graphics card is not needed for HW transcoding ! 

 

In Jellyfin I can select HW transcoding , which does not spike the CPU , (with HW transcoding disabled I see 90% cpu) 

 

 

Link to post
Share on other sites

I did the same but HW transcoding does not work. How die you setup the docker file? /dev/dri:/dev/dri

 

Thank you.

 

Context @ 0x56337b535b00] libva: /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so has no function __vaDriverInit_1_0
[AVHWDeviceContext @ 0x56337b535b00] Failed to initialise VAAPI connection: -1 (unknown libva error).
Error creating a QSV device
qsv hwaccel requested for input stream #0:0, but cannot be initialized.
[hevc_qsv @ 0x56337b549880] Error initializing the MFX video decoder: invalid handle (-6)
Error while decoding stream #0:0: Invalid argument

Link to post
Share on other sites
14 minutes ago, tdse13 said:

I did the same but HW transcoding does not work. How die you setup the docker file? /dev/dri:/dev/dri

 

I added the following under devices in the docker json file . (Iv'e now also done this with plex , and that is also HW transcoding with Plex Pass) 

 

   "devices" : [
      {
         "CgroupPermissions" : "rwm",
         "PathInContainer" : "/dev/dri",
         "PathOnHost" : "/dev/dri"
      }
   ],

 

I also chmod 666 /dev/dri/ (not Sure if this was necessary . I added my docker user to the video group ) 

 

Link to post
Share on other sites

Oh I also changed out the extra.lmza and extra2.lmza from Juns loader for 

 

extra.lzma/extra2.lzma for loader 1.04b ds918+ DSM 6.2.3 v0.13.3 , in this post 

I believe this replaces the i915.ko for the stock versions . 

 

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.