Sign in to follow this  
xeresa77

Recupérations de fichiers sur les Hdd de mon ancien Serveur

Recommended Posts

Bonjour à Tous

 

J'ai un souci asser contrariant, je vais essayé d'être le plus clair possible !!

 

J'avais créé un Xpenology à partir d'un pc qui était asser vieux ma foi ! Il a rendu l'âme le mois dernier!

 

Et j'avais dessus 10 Hdd de 2To chacun le hic c'est que je n'ai pu récupéré les fichiers qui sont dessus!

 

J'ai suivi comme indiquer par Synology ce tuto : https://www.synology.com/fr-fr/knowledgebase/faq/579

 

mais mon problème sont les droit sur les fichiers!! Je les vois bien mais au moment de les copier- coller Ereur sur entrée/sortie !!

 

J'ai essayé de changer les droits sur le dossier et le Hdd mais il me met toujours le messages à la fin de chaque lignes "EN LECTURE SEULE"

 

Est ce qu'une personne charitable pourrais m'aider ?

 

Merci en tout cas a vous tous !!

Share this post


Link to post
Share on other sites

Bonjoru,

 

Ton erreur entrée/sortie (a mon avis) n'a rien a voir avec une histoire de droit. A partir du moment ou tu es en ROOT sur le Ubuntu, tu devrais pouvoir tout faire.

 

A voir d autres avis

Share this post


Link to post
Share on other sites

Je suis d'accord avec lilobzh pour moi aussi ce n'est pas un pb de droits.

 

Pourquoi ne pas essayer de réinstaller un xpenology sur une VM ou en natif sur un autre pc et faire pointer tes disques dessus ?- en faisant bien attention à ce qu'il ne recrée pas un volume de zéro bien sur

Share this post


Link to post
Share on other sites

Salut

 

J'ai déjà essayé la vm rien ni fait et en plus je pourrais pas les remontés sur le nouveau serveur vu que celui ci est totalement différent et équiper d'une carte PERC6I!!

 

J'ai déjà perdu un des HDD pour réinstaller justement Xpenology !!

 

 

Et ce qui est bizar c'est que même si je lancer en lecture un des fichiers video cela me met la même erreur !!

 

et de tout manière il m'est impossible de changer les droit même en mode graphique je planche dessus encore :oops:

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai essayé de changer les droits sur le dossier et le Hdd mais il me met toujours le messages à la fin de chaque lignes "EN LECTURE SEULE"

 

Si c'est à chaque fois que tu veux copier le fichier, c'est peut-être plutôt sur le support vers lequel tu copies que tu n'as pas le droit en écriture.

La machine que tu utilises pour accéder aux disques récupérés est-elle sous linux d'habitude, ou est-ce une machine Windows que tu as utilisée comme PC avec un live-Cd pour accéder à tes disques ?

Si c'est le cas, il faut que le disque dur sur lequel tu veux copier tes données soit autorisé en écriture.

Si tu utilises Ubuntu, tu es par défaut connecté en tant qu'utilisateur de base, et le montage du disque (si c'est du NTFS) est peut être fait soit avec une appartenance à root, soit en mode lecture seule. Il faut passer les options rw à la commande mount, ou à ntfs-3g si c'st le programme utilisé pour monter le disque cible.

Un "ls -ld" sur le nom du répertoire de montage de ton raid synology et sur le point de montage de ton disque vers lequel tu veux copier les données devrait te renseigner, pour avoir les droits en écriture sur la cible, il faut soit affecter le point de montage (sous root) à l'utilisateur qui utilise l'interface graphique par la commande chown, soit mettre le répertoire en lecture/écriture pour tout le monde (chmod 777 /chemin/vers/point/de/montage).

 

Bon courage

Jacques

Share this post


Link to post
Share on other sites

Merci Jacques

 

Je viens de tester et c'est un pc sous ubuntu que j'utilise et je suis bien en SU mais rien !!

 

J'ai testé de prendre des fichiers de ma freebox a mon pc sans souci par contre de mes hdd SYNO vers mon pc impossible !!

 

et quand je fais le ls -l les droit je les ai bien sur mon poste, mais sur les Hdd non et je peux même pas être propriétaire du Hdd !! tout est grisé impossible de changer en mode graphique et impossible avec les commandes "chown et chmod"

 

cela vient peut être d'une commande manquante sur "mdadm" je vais creuser voir !!

Share this post


Link to post
Share on other sites

Bonjour,

 

Comment sont montés les disques ? connectés directement à ton PC sous Ubuntu ?

Normalement, lorsque tu les montes, tu as une information sur l'option de montage effective, genre Device machin est en lecture seule, => montage en RO et non RW.

Tu peux voir l'état du montage avec la commande mount (en root) ou dans le pseudo fichier /etc/mtab.

Il est possible que ton raid soit endommagé, et que tu ne puisses pas accéder aux données mais seulement au contenu des répertoires... dans ce cas c'est via mdadm que tu pourras avoir des infos plus précises.

 

Bonne journée

Jacques

Share this post


Link to post
Share on other sites
Sign in to follow this