Sign in to follow this  
jack.tsang

[SOLVED]reset Google 2 Step Authentication?

Recommended Posts

Basically, I am screwed.

 

2 Steps verification used to work like a charm until today I could not login the UI with my Google Authenticator on my phone, 6 digits code just don't match with the DSM, is there any parameter to cancel the 2 Step Authentication just like people trying to reset the admin password?

 

I am with 5.2.5592-Updated 4, XPEnoboot, N54L.

 

Thanks. :cry::cry::cry::cry:

 

 

SOLVED - Please read member 30624700 comment on page 2

Edited by Guest

Share this post


Link to post
Share on other sites

Can't you plug a monitor/keyboard into the N54L and login direct on the console ? Then make the changes specified in that thread.

Share this post


Link to post
Share on other sites
Can't you plug a monitor/keyboard into the N54L and login direct on the console ? Then make the changes specified in that thread.

I can hook up monitor and keyboard, but there is only a tons of Linux based parameters pop-up.

 

- I am able to login into a guest account, smb/nfs/ftp, are these going to help?

Share this post


Link to post
Share on other sites

There should be a login prompt at the end of all the Linux text. Try pressing the enter key if you don't see a login: prompt.

Share this post


Link to post
Share on other sites

it returns

login: can't chdir to home directory /var/services/homes/myusername

login: can't run /sbin/nologin: No such file or directory

Share this post


Link to post
Share on other sites

just did, and I am calling out the built-in command, it returns

 

. : [ [ [ alias break cd chdir continue eval exec exit export false getopts hash help let local printf pwd read readonly return set shift source test times trap true type unlimit umask unalias unset wait

 

thanks for your help

Share this post


Link to post
Share on other sites

Just found this command, it may work without reinstall

 

 

 

rm /usr/syno/etc/preference/admin/google_authenticator

Share this post


Link to post
Share on other sites
Just found this command, it may work without reinstall

 

 

 

rm /usr/syno/etc/preference/admin/google_authenticator

OMG, it works, a very big thank you for all of you, and I hope this thread will also helping those who get stuck by 2 step like I did.

 

Thank You. :grin::grin::grin::grin:

Share this post


Link to post
Share on other sites

Glad to hear it !

 

BTW pls check your server's bios time, date, and the OS time zone.

I believe the time has been changed or slower, whatever.

This may affect how the one time key is generating.

Share this post


Link to post
Share on other sites
Sign in to follow this