DSM 6.2 on NUC D34010WYK


Recommended Posts

I'm trying to install DSM 6.2.3 on an Intel NUC D34010WYK and can't get it to work for a few days already.

 

 Installing 6.1.7 on the NUC was a breeze. I simply took the loader for 3615xs (without additional drivers) and everything was working out of the box.

 

- Installation of 6.2.3 (same for 6.2 or 6.2.2) always fails at 56% with Error 13.

- VID, PID and serial number are 100% correct. 

- Tried UEFI and legacy boot

- Tried 3615xs, 3617xs and 918+ loaders

- Tried adding additional drivers

- NUC bios is up to date

- deactivated unnecessary onboard hardware 

 

It always stops at 56% with Error 13.

 

Which leads me to believe that it fails because I'm try to install it on a mSATA SSD disk. Isn't mSATA supported in 6.2 anymore?

Edited by Noter2017
Link to post
Share on other sites
On 3/25/2021 at 12:55 PM, Noter2017 said:

Which leads me to believe that it fails because I'm try to install it on a mSATA SSD disk. Isn't mSATA supported in 6.2 anymore?

no difference when it comes to signal and how the system see's the drive, its just a sata drive

 

On 3/25/2021 at 12:55 PM, Noter2017 said:

It always stops at 56% with Error 13.

that is not entirely correct, the 1.03b loader cant boot in uefi mode so it will at least be: it does not seem to boot or it stops qt xx% with error yy

if you remove - from your point of view - non relevant information, it will be harder to track down problems, its just a example to show its better to present raw data if possible (like whole log files or the recorded outcome for all scenarios)

if its 1.04b/918+ does not boot then there is something wrong as the 4th gen cpu in you nuc should be able to boot 1.04b/918+

 

you could also try to update the working 6.1 to 6.2 though the webgui, you would start 6.1, remove the old usb with the 6.1 loader and put in the prepared 6.2 loader and then start the update process, that way the 6.2 loader is in place (will be mounted in the update process) and gets the new kernel files, reboot should work and you can see if the outcome is better that way

 

another method can be to install on a different system and then transfer disk and usb to the system that had problems (difficult in your case as mSATA we be hard to find in most households, some older notebook might have this one or you need some special adapter to connect it to normal sata)

if you wand to get creative to try that you could install 6.2 on a normal sata disk on the other system and then connect that drive with a usb adapter to the nuc, boot a rescue linux and use dd copy the first 5GB from the sata drive (usb connected) to the mSATA drive (dsm creates 2 partitions at the start of the disk one for system and one swap)

 

On 3/25/2021 at 12:55 PM, Noter2017 said:

- Tried adding additional drivers

how? intel spec shows only one internal drive supported and usb drives can't be used for installing

also make sure the drive you try to install to has no partitions from other installs or attempts), there can be problems with that (not i most cases bur as you have problems try to clean up by booting a rescue linux and delete the partitions)

Link to post
Share on other sites
3 hours ago, IG-88 said:

that is not entirely correct, the 1.03b loader cant boot in uefi mode so it will at least be: it does not seem to boot or it stops qt xx% with error yy

First of all, thank you for your answer.

 

You are right. I started from scratch and installed DSM 6.1.7 (15284) with Loader 1.02b as 3615xs in UEFI mode and updated it to 6.1.7-15284-3.

 

Loader 1.03b doesn't start in UEFI mode, so I took the DSM 6.2 Loader (with MBR partition Table) and booted it in legacy mode. NUC started up and was reachable under the same IP address (I didn't give it a fixed IP). In Synology Web Assistant I tried to migrate to DSM6.2-23739 which failed at 56% with Error 13 and clean install to 6.2.3-25426 which also failed at 56% with Error 13.

 

Quote

if its 1.04b/918+ does not boot then there is something wrong as the 4th gen cpu in you nuc should be able to boot 1.04b/918+

 Loader 1.04b boots up in UEFI mode as 918+ but installing 6.2.3-25426 fails at 56% with Error 13.

 

Quote

another method can be to install on a different system and then transfer disk and usb to the system that had problems (difficult in your case as mSATA we be hard to find in most households, some older notebook might have this one or you need some special adapter to connect it to normal sata)

I don't have a different system with mSata at home. The idea was to install Xpenology on a 128GB mSata drive of the NUC. The NUC has a another unused SATA port (data and power) and that's where I plan to connect another 2.5" drive with 4 or 5 TB. I just wanted have DSM 6.2.3 up and running before I buy the disk.

 

Quote

(like whole log files or the recorded outcome for all scenarios)

From my understanding, log files can only be created using a serial cable which the NUC doesn't have. 

Link to post
Share on other sites
38 minutes ago, Noter2017 said:

The idea was to install Xpenology on a 128GB mSata drive of the NUC. The NUC has a another unused SATA port (data and power) and that's where I plan to connect another 2.5" drive with 4 or 5 TB. I just wanted have DSM 6.2.3 up and running before I buy the disk.

thats not how dsm works, bootloader on usb (just grub and kernel) and the system is on EVERY disk as raid1

 

49 minutes ago, Noter2017 said:

From my understanding, log files can only be created using a serial cable which the NUC doesn't have. 

the log was just an example because sometime people just throw in some lines of log, but es we are on the logs now

as long as the system in installed do disk (like when having 6.1 running) there will be a log written disk and a failed update to 6.2 will leave a log and even if the system can't be found in network anymore, as long as it writes to the log an disk you would be able to mount the system partition witch a rescue linux and extract the logs in /var/log/

dmesg and messages are the most common but there are more and some synology specifics, so there might be a special file for updates (i've never checked as i never had a unexpected broken update)

 

1 hour ago, Noter2017 said:

Loader 1.04b boots up in UEFI mode as 918+ but installing 6.2.3-25426 fails at 56% with Error 13.

did you re-use the same usb from 6.1 for 6.2,if its a different then try the one thats working for 6.1 also for 6.2 in theory its possible to have problems on installing when writing the kernel to usb in the process of installing (u guess if you managed to adjust the usb vid/pid for 6.1 you will know how to handle this as its the same for 6.2)

 

Link to post
Share on other sites
On 3/27/2021 at 6:04 PM, IG-88 said:

did you re-use the same usb from 6.1 for 6.2,if its a different then try the one thats working for 6.1 also for 6.2 in theory its possible to have problems on installing when writing the kernel to usb in the process of installing (u guess if you managed to adjust the usb vid/pid for 6.1 you will know how to handle this as its the same for 6.2)

 

No luck. I tried it with 2 different sticks. Both can install DSM 6.1 and both fail updating to DSM 6.2 (56%, Error 13)

 

Fresh install of DSM 6.2 as 918+ with different sticks also fails (56%, Error 13)

 

I will try to get the logs this week,

Link to post
Share on other sites
3 hours ago, Noter2017 said:

Fresh install of DSM 6.2 as 918+ with different sticks also fails (56%, Error 13)

 

I will try to get the logs this week,

just to make szre, please post the grub.cfg you used

Link to post
Share on other sites
11 hours ago, IG-88 said:

just to make szre, please post the grub.cfg you used

 

 

 

Here are the grub files. VID and PID are correct, serial numbers as well. 

 

The only strange thing I noticed is that DSM ignores the "set mac1" address and boots with the original mac address of the NUC

918_grub.cfg 3615_grub.cfg

Link to post
Share on other sites
17 hours ago, deadmorozz said:

Very same thing on Asus n3150i-c, but on 57%. This happens after downloading the installation package to HDD, at the time the installation starts.

There are many success reports with that mainboard.

 

You can use Loader v1.03b DS3617xs

 

https://xpenology.com/forum/topic/12591-%D1%81%D0%BF%D0%B8%D1%81%D0%BE%D0%BA-%D1%81%D0%BE%D0%B2%D0%BC%D0%B5%D1%81%D1%82%D0%B8%D0%BC%D0%BE%D1%81%D1%82%D0

 

Or  Loader v1.04b - DS918+ 

 

https://xpenology.com/forum/topic/37652-dsm-623-25426-update-3/?do=findComment&comment=186388

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.