Hax4dayz

NAS won't show up on network after update

Recommended Posts

I updated my nas (DS3615xs) yesterday but forgot to update the loader aswell. Tried to update the loader to 1.3B (jun's loader) but still no luck, the NAS just won't show up anywhere in synology anymore. Is there a way to downgrade to keep my previous firmware (which was DSM 6.1.7-15284)? I did get the NAS to show up as "recoverable" but nothing happened when that processes I'm guessing that it updates the NAS while recovering.

 

I'm running this on bare metal and the pc is a prebuild (with some things taken out)

Its a Dell Inspiron 620

Intel Core i5 (2nd Gen) 2310 / 2.9 GHz

8GB DDR3 1333 MHz

The main hard drive in there is now a 8TB Western digital drive.

Here is the link to the full specs sheet if needed

Share this post


Link to post
Share on other sites

one specialty with 1.03b/6.2.x is that you cant boot in uefi mode, needs to be legacy and also the usb boot device from the list needs to be ckecked if its legacy (often csm/legacy is just a added option and you see uefi and legacy usb devices)

the network driver seems to be a normal realtek, 2nd gen cpu also means no 1.04b/918+

if its just one disk you could also boot a recovery linux and delete the 1st partition (2GB) and the start installing your old dsm version with the old loader, the installer should ask if you want to keep the data when installing dsm

i theory you could also use the recovery linux to reset the version file of dsm to a lower version as you had before, then the dsm installer would do a update to your 6.1 version and you would keep your data

without raid (just one disk) its nothing special like assembling the system parturition's raid1 from all disks

Share this post


Link to post
Share on other sites

Hey thanks for the info. I tried removing partition 1 and then reinstalling DSM only it prompts me with an error that its gonna delete all data that's on the hard drive. Is there any way around that? Or would I have to manually back everything up and then put it all back once the system is installed again? I'm at this point happy that I can even get DSM installed back onto the system, took me a while previously.

Share this post


Link to post
Share on other sites

I'm not sure what exactly I did but i'm back into DSM on my original version, all my users / settings are back too. The only problem being that if I plug the original drives back into the system they come up as uninitialized. Anything I can do about that?

Share this post


Link to post
Share on other sites

IG-88 is the guru as his signature says. I was going to suggest that you mount the "original drives" under a recovery linux and see what data they had on them.

But I am a bit confused. Which disks? I thought you had just one 8TB disk.

Share this post


Link to post
Share on other sites
26 minutes ago, billat29 said:

Which disks? I thought you had just one 8TB disk.

i was about to ask the same, anyway even if its more the one disk  as long as only the 1st partition was deleted the data raid set over all disks is still there

before doing anything further plug in all disks and check if you data volume is there, dont change or initialize anything before the situations is clear

the initialize just means that the system partition is not found but might also indicate it does not find a raid data volume either

we would need to check the state of the raid's from the command line to see whats going on, also a screenshot or two from dsm disk manager might be good

 

 

Share this post


Link to post
Share on other sites

Ah yeah sorry about that. I've got one 8tb main hard drive that houses all my data and sutch then on top of that I have two hard drives in raid 0 that house a ubuntu VM. Tbh theres not any important stuff on there, just two Minecraft servers.

 

I'm pulling all the data off of the main 8TB hdd now thru Ubuntu, then I'll just store the data somewhere else for the time being while I remake my Synology NAS. After that's done I'll just keep it on the firmware it's one.

 

At this point I'm just happy that I can even get to the data

Share this post


Link to post
Share on other sites

as i dont know what exactly you've done i can only assume from the information i can read

in general, there is no main drive from the (dsm) systems point of view, every disk gets a system ans swap partition when integrated in dsm (initialized), these system and swap are raid1 volumes over all disks in the system, even if only one disk is still working your system will com up

so my guess is you had one 8TB with a basic volume and added two more later with a raid0 volume

for the system (its linux mdadm) its two raid1 volumes over 3 disks (system and swap) one basic volume on one disk and one raid0 volume over two disks

 

for the update you removed the 2 added disks updated to dsm 6.2 and reported one disk in the 1st post

at least that would explain why 6.1 is back when you removed the system partition from the 1st disk, re-added the old two disks an rebooted

 

one missing part is the usb in that scenario, if you updated to 6.2 the new kernel (zImage and rd.gz) would have been copied to the usb loader (still 1.02b) rendering the loader to a non working state, to get dsm 6.1 back running from the two remaining system partitions of the two old disks (raid1 with 2 of 3 working) you would have needed to reset the 1.02b loader from scratch (or a old copy) or restore the kernel files back to 6.1 state

 

having a backup is good

 

best way was 1st on my answer, use loader 1.03b and make it work, if you would have done this and get it working by using csm/legacy mode from bios the system would have just finished the update to 6.2.3 and you would have been on them latest dsm version

if you still want to use 6.2.3 then disconnect all drives, try loader 1.03b (csm/legacy in bios) and see of you can find it in network, if you get this working you passed the hurdle for using 6.2.3, if that does not work out you still can use your old 1.02b usb to install 6.1

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.