Sign in to follow this  
frostiex

Acer aspire h340 esata port multiplier

Recommended Posts

hi all,

I am at a lost here and hoping someone can help me out.

I have a H340 Box running 5.0-4825 Update 2.

I also have a external 4 Bay JOBD enclosure (Mediasonic Probox HF2-SU3S2 non-raid)

 

This box is connected to my H340 via eSata on a Startech PEXESATA2 Card (Which I know it supports PMP (port Multiplier)). I also used to run a 8 bay RAID using windows 2008 R2 using the same HW.

 

The only problem I am having problem with is that DSM can only see one of my drive from the external box.

 

Can comeone please shed some light on this?

 

Thank You so much!!

 

=====

HW Links

====

Enclosure: http://www.mediasonic.ca/product.php?id=1357290977

Raid Card: http://ca.startech.com/Cards-Adapters/H ... ~PEXESATA2

Share this post


Link to post
Share on other sites

I tried a couple of port multipliers when I was building a bare metal 12 bay unit. None would work and only the first drive attached to the multiplier was shown in DSM, same as you see.

 

I think this is because the Nanoboot drivers are limited to standard ones for the various popular sata controllers and do not include 'exotic' drivers for port multipliers.

Share this post


Link to post
Share on other sites

well that kinda sucks...what does everyone think about this?

 

Install this http://www.sybausa.com/productInfo.php?iid=1433 and this http://www.memoryexpress.com/Products/MX51935

 

I know this is suppose to be installed in 5.2 bays, but It looks like it might be alright stand alone as well.

 

also, any way we can request nanobo creator to include some drivers?

Share this post


Link to post
Share on other sites

I have the same problem with my setup frostiex, even though port multiplier is enable it only sees one drive.

 

Your idea with the SATA Card may work but it just depends if the Marvell 88SE9705 chipset is supported which I would have no idea.

Share this post


Link to post
Share on other sites

there is a driver request thread here

 

viewtopic.php?f=2&t=1361

 

But remember that the guys that have developed this are doing it as and when so dont hold your breath.

 

I took the reverse and easier route and found expansion cards based on chipsets that has drivers already in nanoboot (Silicon Image for example), and built from there.

Share this post


Link to post
Share on other sites

there may be some threads which describe the drivers that are part of nanoboot, the 3132 set may be included, that I dont know, you might just need to trial and error this, maybe get a cheap second hand card to test

Share this post


Link to post
Share on other sites

I ran into a similar problem with an external JBOD unit that said it would work if the chipset would work with a port multiplier. The USB 3.0 interface was faster, so I focused on that. Especially after I could not get my box to even recognize a single drive.

 

I used Syno's method to turn the 4 external drives into a raid array. I got it working... Sort of..

The syno box kept trying to mount the USB drives, even after I dismounted them and created the raid. This caused corruption in the volume and I couldn't find a way around the problem.

 

I also couldn't figure out how to get the syno to recognize the drive and make it usable to the syno apps (FIle Manager, for example). I could mount it to the root as /volume2 using that method, but it was useless for any syno apps. Mounting it somewhere under /volume1 worked to give the syno access, but then it counted any data stored against the storage for volume1, which I suspected could lead to problems.

 

I finally gave up and picked up a Buffalo LS441DE. It turned them into a raid for me, but now I have to connect via a much slower ethernet connection and backup with rsync. Since the hardware and processor on it are the same as other actual syno boxes, I may try hacking it into a syno box, after I find a better external raid USB enclosure that is cheap and fast (USB3)

 

Please keep us posted if you try the method Frostiex suggested.

Share this post


Link to post
Share on other sites
Sign in to follow this