Jump to content
XPEnology Community

grub.cfg settings for a HP ML350 G6 server


Recommended Posts

Hello everyone,

I have a problem and after hours of trying to solve it myself I am posting this cause I am stuck. First of all , my detailed setup and explaining the problem. I have been successful for some years in setting up  Supermicro servers with 1.03 and DS3615x in the past, all work fine, no problems in the setup, all drives detected and working. So I have some experience at this stage on how it all works.


HP Proliant ML350 G6 server with Xeon E5606, 36Gb RAM

 - 8x SAS 600Gb 15K disks in a backplane with 2 SAS cables

 - 2 Embedded Storage controllers with each 4 ports SATA (not used for disks)

 - 1 Embedded Storage RAID controller P410 on the motherboard with 2 SAS ports

 - 1 PCI-E Storage RAID controller with a LSI1064 chip with 1 SAS port on PCI slot 3 (if I look in BIOS) THIS IS ONLY PLACED THERE FOR TESTING, I WOULD LIKE TO HAVE THE EMBEDDED P410 WORKING

 - (optional) 1 PCIE storage RAID controller with a LSI1068 chip with 2 SAS ports on PCI slot 6 (ALSO ONLY PLACEd FOR TESTING)


I am testing with DS3615X loader 1.03b. I do the adjustments in the grub.cfg file for SM, mac, VID, PID,... so all that is OK.

Server boots with the stick but on all controllers listed above, when I connect the HD's it is not recognising any drives and I see the error in the webgui "Place hard drives"

However, when i see in the compatible list of storage controllers, all the ones I have tried and tested with are suppose to work.

If I disable all controllers  EXEPT the LSI1064, and connect 4 HD's to it (only has 1 SAS port) then I see the 4 drives and I can install the 6.2 patfile version 23739

I guess that is by accident cause I don't know the exact settings of this line in grub.cfg


set sata_args='sata_uid=1 sata_pcislot=5 synoboot_satadom=1 DiskIdxMap=0C SataPortMap=1 SasIdxMap=0'


Any tips would be welcome if anybody would have the same server running with the same P410 embedded controller and all 8 disks are recoginised and be able to work in RAID5 softraid.

Or if I am doing something wrong or forgetting something, please advise me also.






Link to comment
Share on other sites

  • 4 weeks later...

Hi, I just started to trying install DSM 6.* on the same Proliant ML350 Gen6 (2x300SAS drives).
Did you get any result on your system?

Main question: BARE METAL or ESXi?


Stay very waiting for the answer

Link to comment
Share on other sites

Some Q's:


In regards to HP P410 / P410i, did you read the FAQ?

Do you have a list over the PCI ID's of the controllers you was not able to use?

Did you configure them as RAID or AHCI?

And did you check if any of the other controllers could work with extra drivers? (those are to be used with Jun's 1.02b/DSM 6.1.x, but gives an idea).


Link to comment
Share on other sites

there was no problem with P410i durin ESXi 6.7 installation and RAID1 array is fully accessible for VMs.



The only problem I faced just after DSM installed.
The initialization itself gone fine, DS3617xs was found by WebAssistant, and I did "manual install" just like in this manual:


But after successful installation DS was restarted (10 minutes screen) and then lost in my network. I can't see it not by IPScan, not by WebAssistant, no way...


I assume the latest .pat from synology.com is not suitable for this hacked DS.


Maybe some help from you, friends.

Edited by vollz
Link to comment
Share on other sites


I'm reporting of success installation of ESXi 6.7 + bootimage for DS3617xs without any modification + DSM_DS3617xs_23739.pat on my HP Proliant ML350 G6 server !!!

Everything gone without any problem, like in previous time, with difference that I choose not latest .pam file but 23739.

Initialization gone correctly, Web Assistant found fresh-made DS3617 very quickly. And after restart NIC was not lost and I got Welcome screen of fresh DS.

Once again, everything was made by this tutorial with exception of version .pam.

I din't change MAC address inside the grub.cfg.

Even after restart I was able to add 2 more HDD on the same SATA controller and it's working too!!!




Thank you all !!!


Link to comment
Share on other sites

  • 1 year later...

A little bit off but you think this solution will work with HP PROLIANT ML350 G5 ?
I installed junes loader 1.03b and ds3615 6.2.2-24922
I installed second Nettwork card Intell based wich I edited in grub.cfg as MAC2:XXXXXXXXXXXX
The onboard set as MAC1:XXXXXXXXXXXXX
Starts up and appears quickly in find.synology.com, but it cant find HDD . I have HDD in 4bays
I have tried in the 1 sata port as well, no luck

Edited by GizmoPower
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...