kaku

Members
  • Content Count

    27
  • Joined

  • Last visited

Community Reputation

0 Neutral

About kaku

  • Rank
    Junior Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. UPDATE: THANK YOU @flyride!!! I AM SAVED. I have copied out my data to another HDD!!!!! I made another storage pool and volume. and copied date off to it. 3TB. I think data is good. How can I check which files were corrupted or not fully restored? Now that Data is back. Should I try repairing the original Volume?
  2. Ok found the issue, some how grub got changed From Loadlinux 3617 usb To Loadlinux 3617 sata Now able to boot . I will report back what i find Sent from my SM-G998B using Tapatalk
  3. Ok. Before i did that. I could see that DSM stopped loading(no HDD connected error on webpage) . Also on a different local ip then i specified. But they are shown correct in live ubuntu envoinment. I loaded md0 as you suggested. Cleared /root but DSM ISSUE till their. I think its best I do the remaing stuff in ubuntu. As mdstat us exactly same as it showed in DSM. ANY other way boot into DSM. Ssh now shows refused. Sent from my SM-G998B using Tapatalk
  4. It just says access denied. On ssh. Now DSM is also not showing. I booted into ubuntu live. I can see md2,3,4,5 and vg1000 , same as in DSM (mdadm -Asf && vgchange -ay). I think i can do tree root stuff from here too. But I cant see md0 to correct /root. How can i rebuild md0? Sent from my SM-G998B using Tapatalk
  5. OK Another old post I found which could load me into root is here . Not able to get this to work in grub.cfg Should i just add line in cfg like so? Or do it the way mentioned above? linux $img/$zImage $common_args $bootdev_args $extra_args $@ rw init=/bin/bash
  6. @Orphée I did. It says access denied on SSH and the above error on DSM The closest I caan see with my issue is this old post . Reinstall of DSM in out of question for me(due to recovery). I have dug a pretty deep hole for myself.
  7. A roadbock. WARNING for a stupid thing I did. I ran the script posted their to find out the best tree root to get. It did show my folder structures intact! But That script ran too long, I inspeected why and sure, it was filling /root dir in GBs! I didnt comprehend that it will fill /root so fast. I should have ran on a USB stick . And now I cant login to DSM or SSH because storage is full!! Is their a Grub/boot loader script i can run to clear the /root folder at startup? Specially the 333* files generated from the script their.
  8. I checked . volume1 not mounted. So /volume1 is just a folder. All packages are in "error" mode so, i think its old crons which ran at the time. (doesnt containt anything) i will try this tommorow and post back.
  9. Thanksfor stikcing with me!! Oh no I found out that volume1 is mounted but with "blank data". Is this overwritten? on the other hand, Could not find volume1 current mount in cat /etc/mtab (attached) root@ANAND-NAS:/volume1$ ls -lr total 32 -rw-rw---- 1 system log 19621 Aug 28 22:08 @SynoFinder-log drwxr-xr-x 3 root root 4096 Aug 28 22:07 @SynoFinder-LocalShadow drwxr-xr-x 3 root root 4096 Aug 28 22:07 Plex drwxrwxrwx 14 root root 4096 Aug 28 22:07 @eaDir So still good to go ? I did the following and got same error . sudo mount /dev/vg100
  10. Correct. Drive 4 is just another storage pool with volume2 with no RAID which contains non important data. We can ignore it. I did mdadm --misc -o /dev/md2 from your comment here . I think i did it on md2 . but does this carry over after a reboot? Didnt want to keep NAS runnig to avoid more damage to disks. Well, volume1 was accessible in degraded mode even after Drive 2 was kicked out due to bad sectors. Its when Drive1 "crashed"(Its a relatively new drive), then volume crashed. There is also loss of config for shared folders. then my brother installed photosha
  11. root@ANAND-NAS:~# vgdisplay --- Volume group --- VG Name vg1000 System ID Format lvm2 Metadata Areas 3 Metadata Sequence No 10 VG Access read/write VG Status resizable MAX LV 0 Cur LV 1 Open LV 0 Max PV 0 Cur PV 3 Act PV 3 VG Size 5.45 TiB PE Size 4.00 MiB Total PE 1428427 Alloc PE / Size 1428427 / 5.45 TiB Free PE / Size 0 / 0 VG UUID Mke5
  12. OK @flyride here you go. cat /etc/fstab root@ANAND-NAS:~# cat /etc/fstab none /proc proc defaults 0 0 /dev/root / ext4 defaults 1 1 /dev/vg1000/lv /volume1 btrfs auto_reclaim_space,synoacl,noatime 0 0 /dev/md4 /volume2 btrfs auto_reclaim_space,synoacl,noatime 0 0 lvdisplay -v root@ANAND-NAS:~# lvdisplay -v Using logical volume(s) on command line. --- Logical volume --- LV Path /dev/vg1000/lv LV Name lv VG Name vg1000 LV UUID 2kxrUL-GlLw-QNWB-DKnN-0u3C-gMnj-uLNI8f LV Write Access read/w
  13. This is a catetrophe for me. I know lot of it if my fault, but please hel out if you can. My setup of a 3 HDD SHR (as shown in pic ). I am only concerned with Volume1 (Drive 1,2,3) . Drive 2 (2TB) was failing with bad sectors. I could not get physical access and told someone who did to turn off NAS. Apperantly he did not! Before the drive could be replaced, One morning drive 1 (4TB) crashed. This happend within 1-2 week or so . After that I shut it down for good till I can recover data. Today is that day...hopefully i am posting some basic data below. If someone could help me out. Pleas
  14. My INTERNET by my ISP is Double NATed. So I dont get a unique "public IP" which can directly be linked to me. QC was different because it had a relay feature too(in addition to just a dumb DDNS ) which I was using. Can anyone point to some other DDNS service which works like that? Cant use QC at the moment.