inventory

PCIE sata card+ESXI, disk not showing

Recommended Posts

Hi All,   

 

I started building a esxi solution with jun's mod v1.02b

 

What I did is

Use star converter, get a vmdk image for booting,  

In ESXI, created a new vm and start from the vmdk image

Installation works fine and able to login to system and apply some patches.  

 

The issue I got is,  

I am using a PCIE sata card,  in order to get smart info and make disk sleep

SYBA SI-PEX40057 PCI-Express 2.0 x2 Low Profile SATA III (6.0 Gb/s) 4-port RAID Card

This one is using marvell 88SE9230 PCIe SATA 6Gb/s Controller

 

I remember this is a supported chip by DSM,   not sure why after I enable direct pass through,   nothing show up in DSM management interface.   

 

Is there any extra step I need to do with jun's mod?  load driver?   

Share this post


Link to post
Share on other sites

Is that marvell controller supported in ESXi, ie can you see it as a storage controller in the ESXi console? I suspect it may not be supported (depricated) have a look at this post.

https://www.v-front.de/2013/11/how-to-make-your-unsupported-sata-ahci.html

 

You can reinject the drivers to ESXi with powershell, but that still might not give passthrough

 

Share this post


Link to post
Share on other sites
2 minutes ago, sbv3000 said:

is that marvell controller supported in ESXi, ie can you see it as a storage controller in the ESXi console? I suspect it may not be supported (depricated) have a look at this post.

https://www.v-front.de/2013/11/how-to-make-your-unsupported-sata-ahci.html

 

You can reinject the drivers to ESXi with powershell, but that still might not give passthrough

 

 

It is supported in ESXI,  showing correctly in ESXI pcie devices and able to mark it enable. 

Tried with a windows VM today,   add pass through ,  recognize fine ,   hdd tune is able to read smart as well, /      so I think it's not esxi issue

Share this post


Link to post
Share on other sites

I believe that exact chipset is not PCI passthrough compatible.  It never shows up in a guest.  I fought this issue for a couple of hours before finding a post on it somewhere.  Try a different chipset/sata card.

Share this post


Link to post
Share on other sites

if ESXI has the option to allow you to passthrough a PCI device, then your chipset should already support VT-d.   You can double check by making a new VM, and boot any LInux live CD (Ubuntu, Fedora, etc.. ), and see if you can see the attached hard drives from that SATA controller. 

Share this post


Link to post
Share on other sites

By chipset, I mean the SATA card, just so there is not some confusion.

Share this post


Link to post
Share on other sites

SATA controller chipset. doesn't have to be supported by ESX. As long as your CPU(and its chipset) supports VT-d,  you should be passthrough individual PCI(e) device to the VM.  

 

Also check the VM/ESX log, during the VM start. If ESX has issue passing through the PCI device, it would say something in the log.  You can also do a "lspci" in the VM to validate.   I have Proxmox 5.1, and the onboard Intel SATA controller is reported as:

0000:01:00.0 Class 0106: Device 8086:a282 (prog-if 01)
	Subsystem: Device 1458:b005
	Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 45
	Memory at 91600000 (32-bit, non-prefetchable) [size=8K]
	Memory at 91603000 (32-bit, non-prefetchable) [size=256]
	I/O ports at a020 [size=8]
	I/O ports at a028 [size=4]
	I/O ports at a000 [size=32]
	Memory at 91602000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [70] Power Management version 3
	Capabilities: [a8] SATA HBA v1.0
	Kernel driver in use: ahci

 

Share this post


Link to post
Share on other sites

From (hxxps://www.v-front.de/2013/11/how-to-make-your-unsupported-sata-ahci.html):

 

There is a bug in the firmware of some Marvell adapters (at least 88SE91xx) that prevents it from properly detecting attached devices if you have VT-D enabled in your computer's BIOS. As a workaround disable VT-D! (see this bug report. Many thanks to Adalbert for finding this out!).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now