Sign in to follow this  
Bonebreaker777

Assistance with Web Station

Recommended Posts

Hi,

 

First of all, hail XPEnology.

 

Secondly, is there anybody who could assist me with the following task, please? > I'm trying to run a service and for testing I would like to use my NAS. The software is called Kit-Catalogue and it's free. But to run it I need apparently Apache HTTP server (installed on my NAS from the Package Center), MySQL (installed MariaDB from Package Center) and PHP (installed v5.6 from Package Center).

 

If I open Web Station I see the following:

Status > General > Default server status: Normal, Personal website status: Enabled, Virtual Host status: Normal.

General Settings > I chose 'Apache HTTP Server 2.2' and 'PHP 5.6' in the corresponding fields.

PHP Settings > PHP version: PHP 5.6

 

The manual for the software dictates the following: 'If you’re a technician tying to install the software, once you’ve unzipped everything onto your web server, you should start by browsing to http:///install/ folder. There is extra information on local configuration and setup options in the ‘/docs/’ folder.'

 

I've unzipped the content of the installation archive onto a separate folder in the 'web' shared folder on the NAS. How should I continue? If I enter http:///install/ into the browser, I only get a massive 404 error with 'The page you are looking for cannot be found'.

 

Any help, please?

Edited by Guest

Share this post


Link to post
Share on other sites

Check what 'index' file is in install folder. Maybe its not index.html and web station dont know what else file should look at. Then you need to use full path:

http:///install/

Share this post


Link to post
Share on other sites

No change.

 

Currently I have the 'kitcatalogue' folder inside the 'web' shared folder. The 'kitcatalogue' folder contains a 'index.php' file. But furthermore there's a 'install' folder inside the 'kitcatalogue' folder and there's another 'index.php' file inside of the 'install' folder.

 

Now, if I type in http:///install/index.php - I get a '404 - The page you are looking for cannot be found' error.

Then when I type http:///install/installer.php - I get a '404 - The page you are looking for cannot be found' error.

Then when I type http:///kitcatalogue/install/index.php - I get a internal server error.

Then when I type http:///kitcatalogue/install/installer.php - I get a internal server error.

 

 

Should I copy the 'index.php' file from the 'kitcatalogue' folder to the root of the 'web' shared folder? < Nvm, tried, got the following error: Warning: include(./app/bootstrap.php): failed to open stream: No such file or directory in /volume1/web/index.php and so on...

 

EDIT: Not sure if it helps, but I'll provide the content of the folder(s):

web(shared folder) > kitcatalogue(folder) > app(folder), css(folder), docs(folder), images(folder), install(folder), js(folder), new_local(folder), sso(folder), .thaccess, inder.php, keep_alive.php, license.txt, readme.txt

 

web > kitcatalogue(folder) > install(folder) > install_steps(folder), upgrade_steps(folder), inc__install.php, inc__installer_warning.php, index.php, installer.php, readme.txt, upgrader.php

 

The 'readme.txt' contains some interesting instructions: INSTALLING - The installation wizard will guide you through the changes required to get Kit-Catalogue up and running at your institution. To start the wizard, browse to your installation's /install/ folder. I'm pretty sure I'm missing something fundamental :sad:

 

help, please?

Share this post


Link to post
Share on other sites

Now it is simple. What i told you before was for situation when you dont have subfolder for your app. You see error 404 cause shared folder 'web' does not contains any index file in it and its main folder for defauld virtual

 

In your case you have to do this:

- in web station settings go to virtual host page

- setup all you need, subfolder (web/kitcatalogue)

- host name (myDDNS)

- server and php.

 

My sugestion:

1) If you want to have access from local network do above steps 2 times, but in 2nd dont setup by host name, just setup by port.

 

Access to install this app will be with

http:///install/index.php,

 

or from local network

http://nasIP:port/install/index.php

 

I think you will also need to login with ssh and delete default page settings for apache. But check it first.

Share this post


Link to post
Share on other sites

I'm so sorry to taking up your time, but it didn't work :sad:

 

- in web station settings go to virtual host page - Done

- setup all you need, subfolder (web/kitcatalogue) - Done

- host name (myDDNS) - Done

- server and php - Apache HTTP Server 2.2 & PHP 5.6, done

 

I've done it while it was in the previous sub-folder, then I've done it too when I moved everything to the root 'web'. Now I'm getting a new error: 500 There is an error while processing this request.

 

EDIT: now I've tried the port based option, everything as previously but no host name, instead I've used a custom port number which I've added to the External Access>Router Configuration tab and I manually added the port on the router (TCP). Still error 500 - whether I type in http://NASip:port/install/ or http://NASip:port/install/index.php or http://NASip:port/kitcatalogue/install/ or http://NASip:port/kitcatalogue/install/index.php

 

Any ideas, please?

 

EDIT: same after a restart too, software, hardware or WOL. I start to think that this web thing is inconceivably hard :shock:

Share this post


Link to post
Share on other sites

Error 500 is most probably problem with access rights. Check if folders and files dont have setup admin or root access rights, and http user have all required priviledges.

 

PS Just to be clear, you are using DSM 6.x, right?

Share this post


Link to post
Share on other sites

I've download this app and tried to run it and i've got error 500. After investigating error log i've found that its problem with .htaccess file.

 

/.htaccess: Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration

 

You need to fix it or remove it. Thats all.

Share this post


Link to post
Share on other sites
I've download this app and tried to run it and i've got error 500. After investigating error log i've found that its problem with .htaccess file.

 

/.htaccess: Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration

 

You need to fix it or remove it. Thats all.

 

You're the man (or woman)! That was it! Sweet - will let you know how did I get on :smile:

 

EDIT: and I'm stuck again :???: got the following message:

 

Check .htaccess file

Kit-Catalogue needs a .htaccess file in the /public/ root folder to setup mod_rewrite.

On windows in particular, it's very easy to mistakenly not copy this hidden file across along with the rest of your Kit-Catalogue installation.

Error - The .htaccess file appears to be missing.

Check the installation zip-file and copy across the missing .htaccess file. If you can't see the file, you may need "show hidden files" in your file browser.

Check Apache mod_rewrite

Kit-Catalogue requires that Apache's mod_rewrite be enabled so it can process all incoming requests correctly, and provide 'friendly' URLs.

Error - mod_rewrite appears to be disabled.

If you need to enable mod_rewrite, edit your system's httpd.conf file and make the following changes:

Make sure the AllowOverride option is set to a minimum of:

AllowOverride FileInfo Options

Using AllowOverride All should definitely work, but may enable settings you do not wish to use.

Ensure that mod_rewrite is enabled by uncommenting this line:

LoadModule rewrite_module modules/mod_rewrite.so

 

If I create a 'public' folder in the 'kitcatalogue' folder and move .htaccess file into it - get the same long error message

If I create a 'public' folder in the 'web' shared folder and move .htaccess file into it - get the same long error message

If I leave .htaccess file in the root folder of 'kitcatalogue' - back to error 500, regardless of the permissions of a http group

 

Can't seem to find any way of configuring Apache in DSM. Help, please?

Share this post


Link to post
Share on other sites

Just remove line with php_flag from .htaccess, and try again.

 

Here you find apache files:

/usr/local/etc/apache22/sites-enabled/

 

and log files:

/var/log/httpd/

 

EDIT:

It took me about 30 minutes to pass thru installation process. Im not sure you need to edit any DSM files, but app need some tweaks.

- delete last line from .htaccess,

- create folder writable and change priviledges for http user, required write access,

- rename or copy new_local folder to local,

- edit local/local_config.php,

- ignore error message about mod_rewrite (its enabled in apache config file),

- enable mysqli plugin in webstation->php settings->plugins(or addons),

- ive had to create database in mariabd thru ssh command line.

 

Thats all i think.

Share this post


Link to post
Share on other sites

Sorry for the late reply, been very busy this week.

 

- delete last line from .htaccess - done, helped to to progress to the next window

- rename or copy new_local folder to local - done, helped to to progress to the next window

- ignore error message about mod_rewrite (its enabled in apache config file) - ignored

- enable mysqli plugin - I've enabled the mySQLi extension, the CPU utilisation reached 100% for some reason (even if I couldn't see any process responsible for it in the 'process' tab) so I've restarted the NAS and when it came back, I couldn't restore the web installation :sad: so I decided to start everything from the beginning, including turning off mySQLi for now. But I can't reach the same process as before. I hate this soo badly :sad:

 

EDIT: here I go again :-|

- de-compressed the kitcatalogue v2.0.10.zip into a folder and renamed it kitcatalogue

- removed the last line from .htaccess

- renamed new_local folder to local folder

- in Web Station I've retained all the previous settings (Apache HTTP Server 2.2 enabled under General Settings tab, PHP 5.6 enabled under General Settings tab, PHP 5.6 enabled under PHP Settings tab, Virtual Host created under Virtual Host Tab with the following parameters: port-based HTTP (port no.: xx), document root set to web/kitcatalogue and both HTTP back-end server and PHP set as in General Settings tab).

 

But I can't reach nothing. Anything I type into the browser, I get 'This site can't be reached' :sad: Why?????

 

http://:xx/install/installer.php - 'This site can't be reached'

http://:xx/install/ - 'This site can't be reached'

http://:xx/install/index.php - 'This site can't be reached'

 

EDIT: would you happen to know about a package which would allow me to do something similar, please? Allow tracking & sharing equipment?

Share this post


Link to post
Share on other sites

Check log file for apache at /var/log/httpd/apache22-error_log.

 

Maybe try to change port for this virtual host.

Share this post


Link to post
Share on other sites

Well, you were right. Given time I managed to go as far as the '...- ive had to create database in mariabd thru ssh command line...'

 

Any chance I could ask you for the exact instructions, please? (I've tried to google it but I got too many different ways how to deal with this). Also, my last experimentation messed up my full time NAS, so I've created a replacement NAS from an old DELL FX160 :smile:

 

Check log file for apache at /var/log/httpd/apache22-error_log. Maybe try to change port for this virtual host.

 

Looks like this had to do something with my incomplete migration from 5.2 to 6.0 DSM. On the FX160 I've reached this stage (thanks to your instructions) in 5min or so. :wink:

Share this post


Link to post
Share on other sites

SSH commands:

- mysql, (to open mariadb)

- create database ;

 

Thats it.

Glad to hear you made it.

Share this post


Link to post
Share on other sites

I'm back again :-| sorry!

 

- Enabled SSH on XPEnology

- Downloaded Putty

- Entered my IP - Putty started

- Tried to log in as 'root' - can't. My regular admin password doesn't matches the root password - God knows at this point what is the root password. I know it is not my admin password and it is not blank either

- So I've logged in as 'admin'

- Entered mysql - which started MariaDB

- Typed in - no reaction

- Typed in - no reaction

- Typed in - no reaction

- Typed in - no reaction

- Exited Putty

- Tried to resume the KitCatalogue installation > Error - Failed to connect to the database server. MySQL DB Error (kitcatalogue@localhost). Connecting to Database : 1045 ::

 

Do I need to take into account any of the options listed by the installation?

db.use_mysqli - true

db.host - localhost

db.port - 3308

db.username - kitcatalogue

db.password - ******

db.database - kitcatalogue

 

Thank you...

Share this post


Link to post
Share on other sites
I'm back again :-| sorry!

 

Do I need to take into account any of the options listed by the installation?

db.use_mysqli - true

db.host - localhost

db.port - 3308

db.username - kitcatalogue

db.password - ******

db.database - kitcatalogue

 

Thank you...

 

Sorry i didnt mention about hat. You need to make some tweaks here:

- standard db.port is 3306,

- db.user is root,

- db.password is blank, no password.

 

Also to login as root you need to use command: sudo su -. Admin password.

Share this post


Link to post
Share on other sites
I'm back again :-| sorry!

 

Do I need to take into account any of the options listed by the installation?

db.use_mysqli - true

db.host - localhost

db.port - 3308

db.username - kitcatalogue

db.password - ******

db.database - kitcatalogue

 

Thank you...

 

Sorry i didnt mention about hat. You need to make some tweaks here:

- standard db.port is 3306,

- db.user is root,

- db.password is blank, no password.

 

Also to login as root you need to use command: sudo su -. Admin password.

 

I'll need to go back to school - I hate this shit. Took me 15min to figure out about the root login (first you login as admin with your admin password, then you request root access via sudo -i or sudo su and re-confirm with your admin password). Swear, this could be easier :evil:

 

EDIT: I've changed the config file settings as suggested but my error remains the same - MySQL DB Error (kitcatalogue@localhost). Connecting to Database : 1049 ::. I think I'm not creating a database in MariaDB. Any ideas, please?

 

EDIT: New thing learned - Commands end with ; or \g. swear I would hit myself but I have a date tonight :grin:

 

EDIT: I've done it! Thanks a lot. Really! Now I need to learn to use it :ugeek:

 

EDIT: how do I access it via the web? If I modify the 'Virtual Host' settings, I only get a default Synology page with Web Station has been enabled. To finish setting up your website, please see the "Web Service" section of DSM Help. and if I leave the post based 'Virtual Host' up and create a secondary host name based 'Virtual Host' with practically the same settings, I get This site can’t be reached

 

Post based Virtual Host settings:

- HTTP port selected (port number xx)

- document root selected (web/kitcatalogue)

- HTTP back-end server selected (Apache HTTP server 2.2)

- PHP selected (PHP 5.6)

I can access the software via http://:

 

Host name based Virtual Host settings:

- Host name selected (myDDNS)

- HTTP port selected (port number xx)

- HHTPS port selected (port number xy)

- document root selected (web/kitcatalogue)

- HTTP back-end server selected (Apache HTTP server 2.2)

- PHP selected (PHP 5.6)

I can't access the software via the following routes:

http://:

https://:

 

EDIT: I've sorted it, the port numbers xx for HTTP and xy for HTTPS wasn't added to the 'Router Configuration' and wasn't forwarded in the router.

Share this post


Link to post
Share on other sites

Hello again :smile:

 

Odd situation - I can access the login website even from outside of my network but as soon as I log in, I get redirected to my which, of course, doesn't do any good. Do I have to do anything for the website to redirect to instead of my ?

Share this post


Link to post
Share on other sites

Check kitcatalogue settings. In local_config.php is option to set:

 

 // The Full URL that the catalogue will be served from (i.e. the browsable location of  /index.php)
// e.g. http://www.example.com/catalogue
// DO NOT include a trailing slash '/'
// For SSL, use a URL like: https://www.example.com/catalogue
$config['app.www'] = https://:port 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this