Xpenology on N54L eSata internal/external Problem


Recommended Posts

Im using XPEnology DS3612xs DSM 4.2 build 3211++ (repack v1.2) on a HP N54L.

I connected an 3TB WD Harddrive via eSata.

 

My Problem is that the eSata-Drive is not under external device. It appears in the Store-Manager.

So no HotPlug!

The Drive should be used as a Backup of the internal Drives. So Hotplug would be fine...

 

Someone with the same Problem??

 

SOLVED:

SSH to your Station and edit /etc/synoinfo.conf and /etc.defaults/synoinfo.conf

 

For N54l edit this:

esataportcfg=0x10

internalportcft=0x2F

usbportcfg=0x1FC0

Edited by Guest
Link to post
Share on other sites

From the main screen go to ‘Chipset > Southbridge Configuration > SB SATA Configuration’ and make sure your settings are the same as below:
OnChip SATA Channel = Enabled
SATA PORTS 4/5 IDE mode = Disabled
SATA EPS on all PORT = Enabled
SATA Power on all PORT = Enabled
Return to the main screen then go to ‘Advanced > IDE Configuration’ and again, make sure your settings are the same as below.
Embedded SATA Link Rate = 3.0Gbps MAX

 

Yep. Did everything above.

 

EDIT: Its weird. Everyone writes about how to use the eSata as an internal Sata. For me its never been a Problem... Even with the original HP Bios.

 

EDIT2:

viewtopic.php?f=2&t=1028&start=80#p5413

 

This might be the Solution. Mh have to figure out the correct Values.

Link to post
Share on other sites

Solved it.

 

SSH to your Station and edit /etc/synoinfo.conf and /etc.defaults/synoinfo.conf

esataportcfg=0x30
internalportcfg=0xf
usbportcfg=0x1FC0

 

This sets the odd and the esataport to esata.

 

Edit:

Hex in Bin ( 7 usb 2esata/odd 4internal)

0x30 = 0000000 11 0000 (you could try ´[0x20=0000000 10 0000] the other one should be the odd port)

0xf = 0000000 00 1111

0x1fc0 = 1111111 00 0000

Link to post
Share on other sites
  • 5 months later...
  • 3 weeks later...
  • 1 month later...

I have the Problem that this settings does not work under nanoboot....

i use the internal 5th odd port as esata backup drive ...

any ideas ??

 

under xpenology 4.3 the internal 5th hdd works fine with your settings and shown as esata drive for my backup...

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...
  • 1 month later...

when I run these settings I loose both esata port and ood port out of storage manager is there away just to put back the ood by itself?

 

SSH to your Station and edit /etc/synoinfo.conf and /etc.defaults/synoinfo.conf

esataportcfg=0x30
internalportcfg=0xf
usbportcfg=0x1FC0

 

This sets the odd and the esataport to esata.

 

Edit:

Hex in Bin ( 7 usb 2esata/odd 4internal)

0x30 = 0000000 11 0000 (you could try ´[0x20=0000000 10 0000] the other one should be the odd port)

0xf = 0000000 00 1111

0x1fc0 = 1111111 00 0000

Link to post
Share on other sites
  • 2 weeks later...

Look at my initial Post of this Thread.

 

For handling just the ODD or! the external as eSata try:

 

esataportcfg=0x20 or 0x10

internalportcft=0x1F or 0x2F

usbportcfg=0x1FC0

 

Setting esataportcfg to 0x30 will use ODD and! External as eSata.

If you understand the Bin to Hex then you could fingure out the Settings yourself.

Link to post
Share on other sites
  • 5 months later...
  • 1 month later...

I have the modded bios, with the settings related... i try some configs and my DSM 5.1-5022 Update 5 not recognice the 5th and 6th disk atacched... i try with ubuntu and windows install and they recognice all 6 disks ... Any Suggestions ? :grin: Thanks

Link to post
Share on other sites
  • 2 weeks later...
  • 3 months later...