Jump to content
XPEnology Community

Wireguard broken after DSM 7.2 update

Recommended Posts

Machine... HP Microserver gen8



The story.. I've updated to DSM 7.2, from DSM 7.1.1 42962 release 5 (never saw there was a release 6). After that, every container was running fine, except wireguard. I've uninstalled the spk, because there are different from 7.1 to 7.2. Removing the container got me with some btrfs error so I had to erase it manually. 
I've installed again the 7.2 version of the Wireguard spk, installed the container, but the container doesn't start. Wireguard package is running fine, but the container gives me this error..."failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: "docker-entrypoint.sh": executable file not found in $PATH: unknown".

I've removed and reinstalled every part of wireguard, tried different images, erased manually, tried to install from portainer, with docker-compose, did docker system prune...same error.

Other containers are installing & reinstalling just fine.
I'm using docker image from here... https://github.com/wg-easy/wg-easy

Installed by this tutorial... https://www.blackvoid.club/wireguard-spk-for-your-synology-nas/

Does anybody have any idea how to solve this problem?

Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...