Sign in to follow this  
Pvivien

XPENOLOGY IP Failover Online.net

Recommended Posts

Bonjour à tous,

 

Alors je vous écris car je me retrouve bloquer. :oops::oops:

Voici ma configuration:

DEBIBOX chez ONLINE.NET

ESXI version 6

XPENOLOGY 5.2-5967

DSM DS3615xs 5.2-5967

Windows serveur 2008 R2

 

Niveau réseau:

l'ip de l'ESXI en 62.xx.xx.xx (IP.DU.DEDIE.1)

le XPENOLOGY Lan 192.168.1.10 sur ETH0 / WAN 212.xx.xx.xx (IP FAILOVER) sur eth1 / Mac adresse fournit par Online.net au niveau de la carte réseau de la VM sur l'ESXI

Windows 192.168.1.1

 

J'accède à mon SYNO à partir du Windows serveur en SSH avec le compte root.

J'ai modifié la configuration de la carte réseau eth1 qui correspond à mon WAN:

DEVICE=eth1

BOOTPROTO=none

ONBOOT=yes

USERCTL=no

IPV6INIT=off

PEERDNS=yes

TYPE=Ethernet

NETMASK=255.255.255.255

IPADDR=IP.FAILOVER

GATEWAY=IP.DU.DEDIE.1

ARP=yes

HWADDR=MA:MAC:VI:RT:UEL:LE

 

Le GATEWAY, d'après ONLINE.NET, il faut prendre l'ip de l'ESXI et remplacer le dernier groupe par à 1!

 

Ensuite au niveau des routes:

route add 62.21x.xx.1 dev eth1

route add default gw 62.21x.xx.1

 

J'ai rajouté les dns googles pour tester le ping, mais ne passe.

 

Est-ce que quelqu'un a déjà réussi à configurer un XPENOLOGY avec une adresse IP FAILOVER?

Je suis complètement bloqué et je ne sais pas du tout quoi modifié ou configuré.

 

Merci d'avance

Vivien

Share this post


Link to post
Share on other sites

Bonjour,

 

Pour ta question, je n'utilise pas Failover, donc je ne pourrais pas te donner directement une réponse.

 

Déjà, il y a un truc anormal dans ta configuration IP :

IPADDR=IP.FAILOVER => donc dans le réseau 212.xx.xx.xx /24

GATEWAY=IP.DU.DEDIE.1 => donc 62.xx.xx.1 si j'ai bien compris

 

Avec une machine dont le réseau est défini en 212.xx.xx.0 (masque à 3x255), on ne peut pas joindre l'adresse du routeur qui est en 62.x.x.1.

Donc, pas la peine d'essayer de sortir.

Le routeur doit impérativement être dans le même sous-réseau que la machine qui l'utilise, sinon c'est comme essayer de traverser une rivière en partant du côté opposé que celui où on se trouve.

 

Pour vérifier le ping, tu as plusieurs cas de "panne" dépendant soit de la configuration, soit d'éléments dont tu n'as le contrôle.

1) Mettre les DNS de Google, cela permet une résolution de nom, mais ne te garantie pas un ping.

L'idéal est de faire une résolution de nom depuis une machine ayant accès au web, et de pinger l'adresse depuis ta VM et de voir ce qui se passe

2) Si quand tu fais un poing avec le nom, tu as l'envoi de paquets vers une adresse IP qui correspond à celle de l'adresse (à vérifier via une autre machine hors VM), c'est que le dialogue se fait vers le Web, mais que le ping est bloqué

3) Si le message d'erreur du ping est quasi immédiat (et non pas après un timeout d'envoi du message ICMP), il y a 95 chances sur 100 que le problème de configuration soit sur ta VM, si c'est après timeout, le paquet sort et la réponse ne revient pas

4) Un firewall suffit à bloquer les ping... et en rincipe à laisser passer le trafic HTTP

5) En ligne de commande sur le XPnology, tu dois disposer de wget opur faire un test http

 

Bon, ça ne règle pas ton problème, mais tu peux peut-être affiner ainsi la source de ton problème.

 

Jacques

 

PS : Pour régler des problèmes de routage, il faut faire le ping sur les adresses successivement utilisées pour sortir (la VM, le routeur (donc l'ESXi), le serveur final et la commande traceroute (tracert sous Windows).

En principe, le réseau de ta VM utilise un switch virtuel émulé par l'ESXi, qui dans la gestion de l'hyperviseur utilise lui une ou plusieurs cartes réseau pour accéder au réseau IP physique.

Share this post


Link to post
Share on other sites
Sign in to follow this