Sign in to follow this  
MassiDiFi

Prestazioni & Upgrade

Recommended Posts

Salve ragazzi

La mia configurazione è la seguente:

Processore: AMD Dual-Core C-60

MainBoard: Asus C60M1

Ram: 2Gb DDR3

HDD: 4x 1Tb 2.5"

DSM: 5.2

FileSystem: Ext4

Raid: SHR

 

Ho effettuato un CrystalDiskMark utilizzando il portatile collegato in LAN tramite il router di Infostrada (Huawei), questi i risultati:

 

-----------------------------------------------------------------------
CrystalDiskMark 5.1.2 x64 (C) 2007-2016 hiyohiyo
                          Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [sATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

  Sequential Read (Q= 32,T= 1) :    58.775 MB/s
 Sequential Write (Q= 32,T= 1) :   112.009 MB/s
 Random Read 4KiB (Q= 32,T= 1) :     0.771 MB/s [   188.2 IOPS]
Random Write 4KiB (Q= 32,T= 1) :    22.438 MB/s [  5478.0 IOPS]
        Sequential Read (T= 1) :    67.075 MB/s
       Sequential Write (T= 1) :    98.984 MB/s
  Random Read 4KiB (Q= 1,T= 1) :     1.145 MB/s [   279.5 IOPS]
 Random Write 4KiB (Q= 1,T= 1) :     6.243 MB/s [  1524.2 IOPS]

 Test : 1024 MiB [X: 76.3% (2088.3/2737.2 GiB)] (x5)  [interval=5 sec]
 Date : 2016/09/18 11:12:52
   OS : Windows 10 Professional [10.0 Build 10586] (x64)

 

Come potete vedere i valori di "Random Read 4KiB e Random Write 4KiB" sono molto bassi.

Secondo voi come posso migliorarli? Aumentando la RAM? oppure montando un controller RAID Hardware?

Per il budget a disposizione avrei addocchiato un LSI 9260-8i ovviamente usato verrebbe sulle 150€ spedito dalla cina, che ne dite?

Potrebbe fare al caso mio?

Altri accorgimenti per migliorare le prestazioni?

Share this post


Link to post
Share on other sites

eccoti un paragone con un server con 10 HDD:

 

-----------------------------------------------------------------------
CrystalDiskMark 5.1.2 x64 (C) 2007-2016 hiyohiyo
                          Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [sATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

  Sequential Read (Q= 32,T= 1) :   118.138 MB/s
 Sequential Write (Q= 32,T= 1) :   117.978 MB/s
 Random Read 4KiB (Q= 32,T= 1) :    97.914 MB/s [ 23904.8 IOPS]
Random Write 4KiB (Q= 32,T= 1) :    83.309 MB/s [ 20339.1 IOPS]
        Sequential Read (T= 1) :   109.268 MB/s
       Sequential Write (T= 1) :   110.483 MB/s
  Random Read 4KiB (Q= 1,T= 1) :     7.929 MB/s [  1935.8 IOPS]
 Random Write 4KiB (Q= 1,T= 1) :     9.871 MB/s [  2409.9 IOPS]

 Test : 1024 MiB [Y: 20.4% (1687.8/8276.2 GiB)] (x5)  [interval=5 sec]
 Date : 2016/09/30 15:32:20
   OS : Windows 10  [10.0 Build 14393] (x64)

Share this post


Link to post
Share on other sites

Ciao

Mi potresti dire che controller hai usato?

Hai esperienze con quello indicato da me?

Su altre discussioni parlano di un non corretto riconoscimento degli hdd.

Se ho ben capito per farli rilevare dal dsm bisogna impostare i vari hdd dal software del controller come singoli raid.

Confermi? O ho capito ceci per fagioli? :sad:

Share this post


Link to post
Share on other sites

io avevo usato il controller onboard sulla sceda madre in più ho usato un controller Promise Serial ATA TX2/TX4.

 

in questo thread puoi trovare tutti i controller sata/sas che vanno bene, avevo provato anche un Adaptec 5805 con 8x SATA/SAS è andava bene...

l'unica cose, se mi ricordo bene, non riusciva a leggere la temperature del HDD.

 

Oggi non uso più quella configurazione. ho sostituito tutti i dischi e ora ne ho "solo" 3 da 3TB con un SSD da 80GB che mi fa da Cache... basta e avanza

Share this post


Link to post
Share on other sites

Ho trovato un po di tempo per fare altre prove, ma sopratutto ho riesumato da un cassetto due vecchi SSD della Sandisk (ReadyCache da 32Gb)

Il setup è sempre lo stesso ma questa volta ho effettuato i test impostando CrystalDiskMark su 9 e 32Gb, Il volume è di quasi 3Tb occupati per circa il 80% (Magari con un volume piu scarico le prestazioni potrebbero essere migliori)

 

A) Senza abilitare la Cache con gli SSD:

Gn5cMKq.jpg

 

B) Cache abilitata solo in lettura:

AgvK543.jpg

 

C) Cache abilitata sia in lettura che in scrittura:

FeFILYi.jpg

 

Credo che il JumboFrame sia attivo, mi piacerebbe fare delle provo con e senza.

Ma sopratutto mi piacerebbe fare delle prove anche con uno Switch "serio" e non con il router della Huawei.

Sarebbe bello fare una raccolta comparativa in base all'Hardware utilizzato!

Beta17 le prestazioni non sono paragonabili alle tue, ma senza un controller RAID Hardware credo che non si possa pretendere molto di piu?

Che ne pensi?

Share this post


Link to post
Share on other sites

Ciao MassiDiFi

 

cmq io non uso nessun controller RAID Hardware... secondo me non puoi pretendere molto di più dal processore che usi. al contrario, allmeno arrivi a sfruttare la tua connession da 1gbit in scrittura e letturi sequenziale. avevo fatto altre prove con dei mainboard itx con processori atom e arrivavo appena a 30 - 40 mb/s....

 

io nel mio xpenology principale uso un processore intel g3220, con 3 HD da 3TB (Seagate) e una sola SSD da 80GB... cioè niente di speciale

Share this post


Link to post
Share on other sites

Ciao

Piccolo aggiornamento sulla faccenda!

Ho notato che il mio sistema in "Idle" ha quelle performance con Chrystal, ma se per esempio metto in download alcuni torrent le performance crollano drasticamente, tanto da arrivare al punto che Kodi mi va di continuo in buffering. Infatti provando anche semplicemente a copiare un file dal NAS al computer il transfer rate cala a qualche Mb\s.

Durante sempre il Download dei torrent ho notato che il led degli HDD è costantemente acceso, ho provato anche a lanciare un benchmark con Crystal ma dopo 5min non aveva restituito neanche il primo valore.

Andando in risorse del sistema noto un'occupazione della CPU tra l'80 e il 100%

 

ilinj7c.jpg

Attesa I/O 80%

 

pgQUPNv.jpg

Occupazione Media dei dischi 20%

 

hwpc3Qq.jpg

Mentre del Volume è del 100%...

 

Questa sera quando torno a casa provo a mettere in download di nuovo questi torrent e faccio di nuovo una prova di copia e incolla dal NAS.

Beta tu hai mai notato rallentamenti così marcati durante il download di file torrent?

Se si ti andrebbe di fare una prova? Nel caso ti invio i torrent.

Fammi sapere

Share this post


Link to post
Share on other sites

Altro piccolo Update:

Ieri dopo varie prove il NAS per la terza volta in poco piu di una settimana ha fatto il controllo della parità... andando a spulciare sempre su Gestore Archiviazione ho notato che l'HDD N°2 ha 50 "Riconnessioni"...

Potrebbe essere lui la causa dei rallentamenti?

Share this post


Link to post
Share on other sites

non per niente esistono processori molto più potenti di quello che usi tu nel tuo NAS :smile:

io il mio nas non lo uso come download station, le prove che mi hai cheisto non le posso fare

Share this post


Link to post
Share on other sites

:wink:

Ho preso sulla Baia un LSI 9260-8i, vediamo se riesco a sgravare un pò la povera CPU AMD... :smile:

Appena mi arriva faccio altri due test e vi faccio sapere!

Share this post


Link to post
Share on other sites

Test veloce veloce con un RS3617RPxs:

 

-----------------------------------------------------------------------
CrystalDiskMark 5.1.2 x64 (C) 2007-2016 hiyohiyo
                          Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [sATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

  Sequential Read (Q= 32,T= 1) :   365.774 MB/s
 Sequential Write (Q= 32,T= 1) :   859.571 MB/s
 Random Read 4KiB (Q= 32,T= 1) :   240.496 MB/s [ 58714.8 IOPS]
Random Write 4KiB (Q= 32,T= 1) :   108.829 MB/s [ 26569.6 IOPS]
        Sequential Read (T= 1) :   344.574 MB/s
       Sequential Write (T= 1) :   604.263 MB/s
  Random Read 4KiB (Q= 1,T= 1) :    15.403 MB/s [  3760.5 IOPS]
 Random Write 4KiB (Q= 1,T= 1) :    15.573 MB/s [  3802.0 IOPS]

 Test : 4096 MiB [E: 0.0% (0.6/49999.9 GiB)] (x5)  [interval=5 sec]
 Date : 2016/11/18 9:21:52
   OS : Windows Server 2012 R2 Server Standard (full installation) [6.3 Build 9600] (x64)

Share this post


Link to post
Share on other sites

Aggregare le 4 porte non serve a niente se vieni soltanto da Server. Un sessione TCP è sempre sù un cavo.

Sul RS3617RPxs usa due schede da 10Gbe :wink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this