Failed 6.2 Upgrade on Shuttle SG41J1


Recommended Posts

Hey Guys,

i was a fool and uprgraded my XPenology which was running very well for 2 years on a Shuttle SG41J1 (http://www.shuttle.eu/de/produkte/discontinued/barebones/sg41j1/spezifikation/). 

Now i want to do a fresh reinstall and i always get error 38 during the installation. I read in another posts that this is caused by missing drivers in the loader. 

 

Can anyone help me to get my NAS installed again.

 

greetings Marshel

Link to post
Share on other sites

there is not much information in you request about what version you had befor updating, what  loader, dsm type and dsm version you tried

 

did you read any guides here or driver threads?

 

this link should tell you tat 1.04b 918+ is not working (cpu to old)

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

also it tells you that you need csm mode and you ned to boot from the non uefi usb boot device as 1.03b 3615/17 does not support uefi

 

the nic is ununsual and will not work with the loaders default driver set, it need sky2.ko driver and thats in my extended drivers, so you need to replace the extra.lzma

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

  • Like 1
Link to post
Share on other sites

Thanks for your reply.

 

I had 3615 installed with bootloader 1.03b. 

i dont know which DSM i had i think 6.17 and accidently upgradet to 6.2

 

Now i tried it with your tip and used the extra.lzma. The device is booting and shows "Screen will stop updating shortly, please open find.synology.com to continue."

 

i cant find the NAS on Synology Assitant or find.synology.com

Edited by M4rshel
Link to post
Share on other sites

I should take this extra.lzme 

Quote

extra.lzma for loader 1.03b ds3615 DSM 6.2.3 v0.11_test, same added drivers as for 6.2.2 like newer intel drivers, 10G nics, ...

with Bootloader 1.03b for 3615 right?

How could i see if the stick is booting UEFI? 

 

Link to post
Share on other sites
10 hours ago, M4rshel said:

How could i see if the stick is booting UEFI? 

activate csm in bios, save it, reboot, go into bios again and check boot devices, there should be more then one boot device for the usb flash drive

usually the uefi devices have uefi in the name (often two for every partition in the drive)  and the legacy device looks normal like "Adata USB 3.0 ..."

 

10 hours ago, M4rshel said:

with Bootloader 1.03b for 3615 right?

yes if you use the 3615 loader

 

10 hours ago, M4rshel said:

i cant find the NAS on Synology Assitant or find.synology.com

you can check your dhcp server (broaband router) it it found a device in network

i usually use the synology assistant (program) that can be downloaded from synology to find a dsm loader in network

Link to post
Share on other sites

I have fixed it. I run it with 1.02b Genesis MBR because there is no option in BIOS to change between UEFI and CSM. 

NO i have 6.17. succesfully installed. Im fine with that. The problem was i didnt realeased the usb drive safe before. -.-

 

Thanks for your help!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.