Unable to Install any linux distro on VMM


Recommended Posts

Hi all,

 

- DSM version - DSM 6.2.3-25426 Update 2

- Loader version and model: JUN'S LOADER v1.04b - DS918+

- Using custom extra.lzma: NO

- Installation type: BAREMETAL - msi b85I gaming, intel i5-4570t, 8gb ram

 

I am trying to use synology's vmm software to learn and play around with linux. However I am unable to install any linux distro. For example using the 64 bit version of Manjaro-kde, the installation process stops at 90% where the bootloader is meant to install as shown below. Also shown below is where the installation for linu mint hangs

 

image.thumb.png.0a8dca65b723dd2e7252ed728c781582.png

image.thumb.png.1b5102fcc8506de9a083062ccd25a59c.png

 

 

I have tried several permutations of the vmm settings. What i have settled on so far is as follow.

 

image.png.5d4ade636a8b2c0e940f4d6a041a5ef1.png

Note that the outcome doesn't change when I've allocated 2gb or 4gb of ram.

Setting the video card to vga worked best in even getting the iso to boot.

Below I've alternated between SAT and SCSI and the outcome is the same, the installation hangs.

image.thumb.png.03d164d756d66285a280a53562f14f44.png

Lastly I've alternated between Legacy and UEFI and no change in the installation outcome.

image.png.d8d92ab437ab8f006162f92249f2dd02.png

 

 

Any advice on what I can do?

 

 

Link to post
Share on other sites

Yes, I have the same problem, it hangs at the grub bootloader installation, whichever Linux variant I install and I know it's a common issue on Xpenology systems (search the forum). 
What I do is install the desired Linux OS in VirtualBox on my computer with similar settings, then export it in OVA format, it works good like that even if it's a bit more complicated.

  • Like 1
Link to post
Share on other sites
1 hour ago, pmchan said:

If you want, I have a Zorin OS 15.3 Lite OVA I've installed this way to share. It's just the basic installation, nothing more except the Synology VMM tools.

 

Yes please. I'm new to the world of linux so things will be slow on my end.

 

Do i import the Zorin OS into synology?

Link to post
Share on other sites

I'll give you the link in PM but don't expect lightning speed transfer.
Once the file is downloaded, go in VMM/Virtual Machine/Create "arrow"/Import and select the OVA file.
After that, you can set the VM by choosing number of cpu, amount of ram, etc... Zorin OS is very light and can do things with only 1GB RAM but choose 2GB if you can. Then disk space, default to 10GB but your choice (I select VirtIO SCSI driver in options), Default VM network but I change to  VirtIO model. In the next page, you can give USB access to peripherals if you want but I left Legacy bios and no other images mounted. That's it.

Edited by pmchan
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.