Recommended Posts

esxi 6.7u2

CPU:   2 CPUs x Intel(R) Pentium(R) Gold G5400 CPU @ 3.70GHz

Memory:  15.43 GB (2х8)

MB: ASUS PRIME H310T R2.0

LAN: Realtek RTL8111H

 

Суть проблемы и вопроса

При установке на флешку и диски сразу Xpenology DSM 6.2.1-23824 Update 6, HW транскодинг работает(*)

В Videostation включаются почти все видео файлы, нагрузка на проц не больше 15%. Качество меняется (исходное, Режим FHD с высокой..., Высокое, среднее, низкое) и видео соответственно сжимается и воспроизводится без большой нагрузки на CPU.

 

 

Если ставить Xpenology на ESXi, то HW транскодинг , вроде, тоже работает. НО:

я не могу переключать качество. Работает только исходное качество. В остальных случаях "Видеоформат не поддерживается Мой Компьютер".  При этом работает преобразование в автономном режиме любых видео в любое качество (исходное, высокое, низкое) и тоже не тратит ресурсы CPU.

Кодеки активированы автоматически, sn/mac реальные и в \dev\dri всё имеется

В PLEX премиум тоже HW работает и при установке через esxi и без.

 

Кто-то может что-то подсказать?) В чём причина этого ? 

 

 

P.S. 

Ы логах ошибка :

synoscgi_SYNO.VideoStation2.Streaming_2_open[14731]: video_format_profile.cpp:367 There is no such json member,  value[braswell_1] in [/var/packages/VideoStation/target/etc/TransInfo_VAAPI_HLS]
data-test synoscgi_SYNO.VideoStation2.Streaming_2_open[14731]: handle_error.cpp:14 error: failed to determine profile                                                                                          

 

Edited by dantesian
Link to post
Share on other sites
12 часа назад, dantesian сказал:

Если ставить Xpenology на ESXi, то HW транскодинг , вроде, тоже работает

Через esxi не пробовал, но в vmware workstation работает только совтовый, вы уверены что hw работает, а не sw?

Link to post
Share on other sites
Posted (edited)
30 минут назад, Olegin сказал:

Через esxi не пробовал, но в vmware workstation работает только совтовый, вы уверены что hw работает, а не sw?

Как на J4105(до этого был odroid h2), так и на intel G5400 +- одинаково

Могу и ошибаться, но загрузка CPU  10-20% одного ядра и в PLEX pass и videostation при автономном преобразовании.

Наблюдал через htop

 

Такая же нагрузка, если ставить систему без ESXi

 

 

Сомнения у меня, что это SW преобразования...

 

Зато если в плексе убрать премиум (pass), то при транскодинге сразу все 4 потока по 100%

 

 

 

P.S.

Я бы использовал систему без ESXi, если бы виртуалки работали хорошо в xpenology... ubuntu сервер тормозит безбожно, про винду и говорить не стоит...

Когда на ESXi всё замечательно и в нескольких unix серверах, так и если запустить 7 винду для каких-то лёгких задач-программ 

 

P.S.S

Вчера обновился до последней 6.2.2 U5. Ситуация сохранилась.

Так же в фоне преобразования videostation и стриминг PLEX pass с нагрузкой 10-20% одного ядра CPU.

Вот только Videostation перестал все подряд видеофайлы воспроизводить в "оригинальном" качестве. Вместо этого "оригинал" недоступен и он пытается в высоком, на котором выдаёт ошибку "Видеоформат не поддерживается Мой Компьютер"

 

Я не знаю, что это за абракадабра ....

НО! важное уточнение! 

В Виртуалку в esxi я пробросил напрямую видеоадаптер. Без этого он не преобразует.

Edited by dantesian
Link to post
Share on other sites
Posted (edited)

При преобразовании 4к видео на 5 минут  вот такие значения, а если поставить fullhd фильм гигов на 20-30 преобразование, то cpu 80-100% на один поток выдаёт

 

 

 

2020-03-24_09-50-49.png.415c2ff8808f9ce8fa805095d7d3fd43.png2020-03-24_09-50-44.thumb.png.18a5565c9663c34f5bbd2f3811fb4f1c.png

Edited by dantesian
Link to post
Share on other sites
В 24.03.2020 в 09:37, dantesian сказал:

В Виртуалку в esxi я пробросил напрямую видеоадаптер. Без этого он не преобразует.

 

В 23.03.2020 в 20:15, dantesian сказал:

я не могу переключать качество. Работает только исходное качество. В остальных случаях "Видеоформат не поддерживается Мой Компьютер". 

Видимо есть ограничения в дровах esxi при пробросе...

Link to post
Share on other sites
3 часа назад, Olegin сказал:

 

Видимо есть ограничения в дровах esxi при пробросе...

 

Либо...

Если установить голую чистую систему (даже последней версии), то транскодинг работает замечательно

Но как только я в биосе включаю VT-D, чтобы в дальнейшем в esxi пробросить видеокарту в xpenology, так сразу в системе без esxi  (установка на флешку и загрузка с неё) повторяется всё то же, что и в ESXi. Повторяется то, что описано в 1 сообщении

 

Итог такой, что с включенным VT-d не всё работает замечательно

Проблема в том,  что в esxi он обязателен. А на что конкретно влияет включение этого параметра(понятно, что возможность пробрасывать устройства и т.д. и т.п.) я не разобрался, как и  "какие настройки добавить виртуальной машине, чтобы она не знала про включенный VT-d" =(

 

Кажись не судьба подружить и ESXi и транскодирование из коробки

Link to post
Share on other sites
32 минуты назад, dantesian сказал:

А на что конкретно влияет включение этого параметра

Только на возможность проброса устройств по шине  pci, но при этом видимо возникают определенные ограничения. Можно попробовать биос обновить, но вряд ли это поможет.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.