Recommended Posts

Bonjour à tous,

Tout d'abord un énorme merci a votre communauté pour le travail que vous avez accomplit.

 

Mon Nas est sous expenology 6.0.2-8451 a la base avec loader v1.1

Suite a une mauvaise manipulation de ma part je me suis retrouver a faire une mise à jours vers la dernière version oupsss

J'ai bien évidement essayé de refaire la clés usb avec le dernier loader en date v1.4 mais impossible de détecter mon nas sur mon réseau.

A priori le seul loader qui soit supporter par mon cpu AMD A4-3400 est le 1.1 avec l'option AMD.

 

Après des heures a tester différentes clés j'ai réussis a retrouver mon nas sur mon réseau.

Maintenant il me demander de migrer seulement voià j'ai une belle erreur 13 fichier endommagé vous avez des idées de la cause??

Quand j'essaie via synology manager la j'ai une erreur 21?? ouvrir le port 23.

 

J'ai des données importantes a récupérer sur les disques raid ( 3x 2TO).

 

D'avance un tout grand merci.

Edited by eviledeath
Link to post
Share on other sites

Merci pour ta réponse.

Très bonne question je ne savais pas qu'il y avait les deux.

 

J'ai téléchargé le fichier DSM_DS3615xs_8451.pat qui correspond a la dernière version supportée par le loader 1.1

A cette adresse https://archive.synology.com/download/DSM/release/6.0.2/8451/

 

Downgrader sur qu'elle version?? 

 

Après annalyse des disques sur mon pc sous windows 10 l'un de mes 3 disques est HS étrange que cela n'aie pas été détecté.

J'avais donc dans l'idée de monter mes disques sur mon pc de bureau qui dispose d'un cpu intel plus récent et de passer sur le loader 1.4 juste pour récupérer mes données.

Ou via un linux bootable?? mais je n'y connais rien en linux.

Sous windows les partitions ne sont pas accessibles.

Link to post
Share on other sites

Si ton NAS a déjà fait la mise à jour il faut que tu installes le pat correspondant à cette version et je doute que ce soit la 6.0.2-8451 mais plus là 6.2.2 : https://archive.synology.com/download/DSM/release/6.2.2/24922/DSM_DS3615xs_24922.pat.

Ceci étant dit, si même avec ce fichier ça passe pas et que visiblement tu n'as même pas accès en SSH, un downgrade ne changera rien en l'état. Le mieux effectivement c'est de monter tes disques avec un live CD linux. Le forum regorge de personnes qui décrivent la procédure après c'est vrai qu'ils faut des connaissances en Linux un minium.

 

Tu peux aussi tenter de convertir ton PC en NAS le temps pour toi de convertir les données ou alors la solution que je conseil souvent de passer par une VM sous ESXi ou VMware Workstation (il est possible de mapper directement tes disques à une VM même sous Windows) 

 

A toi de trouver la meilleure solution 😕

Link to post
Share on other sites

J'ai choisis la solution la plus appropriée a mes compétences , j'ai transformé mon pc en nas.

Cela a bien fonctionné le nas est relancé avec une nouvelle installation en 6.2.23739

 

Par contre pas accès a mes données ça ces pas cool malgré un raid5

 

Mais mon volume est en statut "Danger Volume planté" a cause de l'un de mes 3 disques qui est HS.

Ma dernière question étant la suivante , si je remplace le disque défectueux que le répare le raid j'aurais de nouveau accés a mes données??

 

Merci encore pour votre aide.

Link to post
Share on other sites

je ne me rappelle plus quelles sont les options disponibles dans ce mode dégradé. Mais normalement avec un RAID5 sur 3 disques et si ces 3 disques sont strictement identiques il devrait être possible d'accéder à tes données. Si il ne le propose pas c'est que tes disques ne sont pas les mêmes et effectivement il te faut un autre disque pour qu'il puisse reconstruire le volume à l'aide des infos de parité situées sur les 2 autres disques.

Link to post
Share on other sites

Bonjour,

 

Merci pour votre aide précieuse , en effet les 3 disques sont strictement différents ce sont principalement des disques de récupération.

Je vais cette après midis acheter un nouveau disque de 4TO tant cas faire et effectuer la réparation du raid.

Un amis est passé hier en allant en ssh le volume1 est bien la mais ces mit en protection.

 

Je revient vers vous pour vous dire si cela a marcher. 

Link to post
Share on other sites

Voilà j'ai placé un nouveau disque de 2TO a place du disque HS et j'ai lancé la réparation du raid.

Celui ci vient de terminer ( 10h au total ) mais le volume 1 reste toujours en statut en panne que faire??

 

Voici ce que me donne la commande cat /proc/mdstat

admin@Diskstation:/$ cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sdc5[3] sdb5[2] sdd5[1]
      615480192 blocks super 1.2 level 5, 64k chunk, algorithm 2 [3/3] [UUU]

md3 : active raid5 sdd6[0] sdc6[3] sdb6[1]
      3281868544 blocks super 1.2 level 5, 64k chunk, algorithm 2 [3/3] [UUU]

md1 : active raid1 sdb2[1] sdc2[0] sdd2[2]
      2097088 blocks [16/3] [UUU_____________]

md0 : active raid1 sdb1[1] sdc1[0] sdd1[2]
      2490176 blocks [16/3] [UUU_____________]

 lvdisplay

admin@Diskstation:/$ sudo lvdisplay
Password:
  --- Logical volume ---
  LV Path                /dev/vg1/syno_vg_reserved_area
  LV Name                syno_vg_reserved_area
  VG Name                vg1
  LV UUID                BGfRWM-A18v-ppnn-MKUA-Yh2D-232D-dqxpvO
  LV Write Access        read/write
  LV Creation host, time ,
  LV Status              available
  # open                 0
  LV Size                12.00 MiB
  Current LE             3
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     512
  Block device           252:0

  --- Logical volume ---
  LV Path                /dev/vg1/volume_1
  LV Name                volume_1
  VG Name                vg1
  LV UUID                rKPiVZ-NZHQ-4Lrw-BSOQ-pIW5-mn1S-rgzLqH
  LV Write Access        read/write
  LV Creation host, time ,
  LV Status              available
  # open                 0
  LV Size                3.63 TiB
  Current LE             951497
  Segments               3
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     4096
  Block device           252:1

pvdisplay

 

admin@Diskstation:/$ sudo pvdisplay
  --- Physical volume ---
  PV Name               /dev/md2
  VG Name               vg1
  PV Size               586.97 GiB / not usable 2.31 MiB
  Allocatable           yes (but full)
  PE Size               4.00 MiB
  Total PE              150263
  Free PE               0
  Allocated PE          150263
  PV UUID               QKR628-jSA3-vM1y-e0o1-96uJ-LsjV-QXLDMN

  --- Physical volume ---
  PV Name               /dev/md3
  VG Name               vg1
  PV Size               3.06 TiB / not usable 1.19 MiB
  Allocatable           yes (but full)
  PE Size               4.00 MiB
  Total PE              801237
  Free PE               0
  Allocated PE          801237
  PV UUID               meTjFW-l23c-qq9i-iVp3-s1I6-P1wf-zaDIYY

Merci pour votre aide.
 

Link to post
Share on other sites

En effet étrange , ces peut-être cela le raid SHR?? un mélange de raid1 + un raid5?

J'ai bien 3 disques de 2TO dans ce raid.

 

Voici les captures demandée.

 

3Cj8WG.png

 

dm7RmO.png

 

uk2VWS.png

 

SQ7Gv4.png

 

Je ne sais pas si ces captures peuvent vous être utile.

Au niveau de l'interface DSM je ne sais plus rien faire a part supprimer le volume pour en créer un nouveau ce que je ne vais bien évidement pas faire.

 

 

Edited by eviledeath
Link to post
Share on other sites

Non pas accès ces exactement comme sur ta capture ces grisé.

Ces l'option que j'ai utilisé quand j'ai remplacé mon disque de 2TO qui était HS par le nouveau car a ce moment la j'y avais accés.

La réparation a duré 10h mais visiblement cela n'as pas fonctionné?

 

D'après mes logs l’opération de réparation a été un succès.

Mais le volume1 reste en statué crashé et aucuns dossier visible dans file station.

Edited by eviledeath
Link to post
Share on other sites

Ton pb c'est qu'il n'arrive pas à remettre les partition active. Je pense qu'effectivement le RAID s'est bien reconstruit mais les partitions elles non... J'ose espérer que qqun d'autre de la communauté connaitrait THE ligne de commande qui remet ça en place.

Link to post
Share on other sites

Le pronostique me semble mal engagé.

J'espère qu'une personne qui sais donc comment activer une partition passe par mon topic.

 

Sinon j'essaie sur le côté de lire une partition Btrfs sous windows car en principe les données doivent ce trouver sur chaque disque durs.

Link to post
Share on other sites

Voici sous le gestionnaire de disque de windows ce que cela donne

 

8lUTWE.png

 

La structure est identique sur les 3.

 

Avec LFS je n'accède cas la partition de DSM , cela rejoint ce que  nicoueron disais plus haut , partition non active.

 

hqHrqE.png

 

Je vais tester avec le disque qui était HS ce que cela donne.

Link to post
Share on other sites

Bonjour,

 

md0 et md1 sont les partitons du DSM (respectivement / et le swap). On peut le voir par le fait que dans mdstat elles utilisent tous les disques disponibles (ici 3) et sont créées sur tous les disques potentiellement utilisables (ici 16, et 12 pour un ds3615 par exemple).

Citation

Sinon j'essaie sur le côté de lire une partition Btrfs sous windows car en principe les données doivent ce trouver sur chaque disque durs.

Lire de l'ext3 ou ext4 sous windows est déjà plus que difficile, alors lire du Btrfs... j'en doute encore plus.

L'idéal est d'utiliser un liveCD linux et de le laisser monter les volumes, ou éventuellement de les configurer manuellement (voir cet article).

Dans le résultat de tes commandes, il manque vgdisplay pour être complet, je comprends (et je suis loin dêtre expert en LVM) que ton volume logique 1 est composé du groupe vg1 lui-même réparti sur les volumes physiques md2 et md3 (qui se composent de plusieurs disques physiques assemblés en raid 5).

Le raid a l'air d'être correct (état des disque à normal dans la capture d'écran) mais le volume ne semble pas accessible.

Si tu démontes le volume 1 (commande umount /volume1 en root) et le remonte ensuite (mount /volume1 ou mount /dev/vg1/volume_1) est-ce que ça marche, ou sinon quelle erreur est affichée ?

J'ai l'impression que suite au problème de raid, le volume est passé en lecture seule pour empêcher de créer des erreurs.

Tu peux aussi éventuellement forcer le volume à être monté dans un autre répertoire avec (par exemple) mount /dev/vg1/volume_1 /mnt -o rw

Si ça passe sans erreur, essaye de créer un fichier dans le volume (touch /mnt/toto) et vérifie qu'il est présent (taille 0 octets) avec ls -l /mnt/toto.

Si ça marche, démonte le volume (umount /mnt) et retente de monter le volume manuellement (mount /volume1).

Ces commandes sont en principe sans risque puisqu'on ne fait que monter le système de fichiers et de créer un fichier vide. Je te recommande la lecture de l'article indiqué plus haut pour comprendre le LVM (qui est une part du SHR avec le raid soft mdadm).

 

Bons tests

Jacques

Link to post
Share on other sites

Merci JacquesF pour ton intérêt.

Effectivement ces le btrfs qui pose soucis dans mon cas , je vais repasser en ext4 pour la prochaine fois.

 

J'ai essayé plusieurs commandes hier avec un amis sous linux live.

 

7sdCGH.jpg

 

FhudzT.jpg

 

J2ctXW.jpg

 

trLUGD.jpg

 

Il ne veux rien savoir /dev/vg1/volume_1 reste inaccessible , les données sont pourtant belle et bien présentes.

Je crois que je vais jeter l'éponge , 5 jours que je suis dessus. 

Link to post
Share on other sites

Bonjour,

Si /dev/vg1 n'existe pas, c'est que le noyau ne dispose pas de la couche LVM ou que rien n'a été fait en automatique.

Si les commandes pvdisplay, vgdisplay existe (même si elle retourne une erreur autre chose que not found, c'est que le paquet LVM est installé.

Ensuite, il faut recréer le volume avec les commandes comme indiqué dans l'article que j'ai donné.

LVM permet d'assembler dasn un volume une ou plusieurs disques et facilite ainsi l'extension de capacité. Combiné au raid soft, ça s'appelle SHR chez Synology.

En clair, il faut une couche physique (les disques) gérée avec pv (physical volume), une couche groupe (commandes vg*) qui permet de créer un périphérique dans /dev/vgX, et une couche logique (commandes lv*) qui offre un accès au périphérique. Dans le cas du SHR, les disques physiques sont supportés par les périphériques /dev/mdX créés par le raid soft de linux.

Donc, cela fait un "disque" logique, supporté par un volume créé sur un ou plusieurs disques physiques qui sont en fait une autre couche d'abstraction regroupant les données sur les périphériques raid. Sans l'ensemble de ces couches, les données ne peuvent être lues directement sur le disque (en raid 1 ça irait encore puisque c'est du mirroring, mais en raid 5 elles sont éclatées sur les différents disques).

Personnellement je tenterais avec un liveCD du type RescueCD, tous les outils pour la récupération de données sont en principe disponibles, et on peut utiliser une interface graphique (mais pas pour ce genre de montage, autant rester en console pour passer les commandes).

Jacques

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.