darthf1

Created ESXI VM with Loader 1.04b, now have crashed volume (raid5)

Recommended Posts

Hi,

 

Yesterday i tried to created a new ESXI VM based on the new 918+ 1.04b loader by Jun. It booted fine, so I shutdown the VM and attached my SATA controller as a passthrough device. I got the option to migrate from the 3615xs to the 918+ and all went fine.

 

After my first login, I got the message that my Volume1 had crashed. Looking at the disks that Synology detects, i see the following:

- 2x 4TB WD RED

- 1x 50mb VMWare Virtual SATA HDD

 

What i would expect to see here, are my 4x 4TB WD RED. The 50mb VMware hdd is new for me, which make me believe i did something wrong in the VM config.

 

So i SSH'd into the device, and with fdisk I learned that all my 4x 4TB disks are detected. Theyre just not visible in the WEBUI. The RAID 5 (/dev/md2) consists of only 2 of 4 disks. Next thing is that I used mdam to stop and recreate the /dev/md2 raid5. I mounted the /dev/md2 to /volume1 again and I can see all my original files there. This makes be believe theres nothing wrong with the disks.

 

After this, i dont know how to proceed. I recreated the raid with mdam, but in the webui i still can only see my 2x 4TB and 1x 50mb. After a restart, i get the same volume crashed errors and I have to recreate the raid again.

 

Does anyone have any experience with this?

 

My VMDK file

synoboot.vmdk

 

This VMDK just links to the .img file. I have also tried converting the .img to a .vmk, but i get the same result.

 

Storage Manager

dsm storage manager.png

dsm gui disks.png

 

VM Settings

vmware guest os.png

 

vmware settings 1of2.png

vmware settings 2of2.png

vmware settings bios.png

 

ESXI Hardware / Version

vmware hardware.png

vmware hardware.png

Edited by darthf1

Share this post


Link to post
Share on other sites

Hope you didn't have any important data on them? 😕

 

Check your "External Devices" in DSM Control panel and see if they show up there..

You're splitting your disks between your onboard controller and add-in controller, by the look of it..

If they DO show up in External devices (in DSM control panel), you need to do this... See comment #4..

 

Share this post


Link to post
Share on other sites

Well the most important data is backed up, but i would prefer to fix this over to starting over again.

 

Unforunately i dont see any disks under "External Devices"

Share this post


Link to post
Share on other sites

I use Starwind V2V image converter, by the way.. Works great for IMG to VMDK conversion - and it's free..

Are all of your disks on the add-in controller card?

Did you try editing the config files (linked post 4)?

Give it a reboot, just in case..

Edited by Hostilian

Share this post


Link to post
Share on other sites

Yeah i used the same application, but using the .img or the converted .vmdk is giving  me the same results.

Yes, all my disks are on the SATA controller. This is the exact same setup which was working on the 3615xs on loader 1.03 with DSM 6.2.

Share this post


Link to post
Share on other sites

Fixed it!

 

I was looking further into the grub.cfg and the first menu entry there was not the ESXI one. So i removed the first two options only letting the ESXI menu entry active. And now it worked fine.

 

*DOH*

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.