oakey

Wake on Lan, how?

Recommended Posts

Posted (edited)

I've googled this and read every thread that shows up on this subject here but I'm still non the wiser how to get Wake On Lan to work. 

 

I'm running Jun's Loader 1.02b with DSM 6.1.7 on a Gen8 Microserver, and as far as I know I have the proper MAC address for my ethernet1 port in the grub file.

 

Wake on LAN is enabled in the BIOS, it's enabled in DSM and I've set up in Synology Assistant yet whenever I use any apps to send the magic packet it does not wake up the system. I use task scheduler to start my NAS up at 7pm and to automatically shut it down at 2am, from what I've read this auto shutdown may not be putting it into the correct state in order to wake it up?

 

There's a guide someone posted on here where you Putty in and enter a command but I can't for the life of me remember (or Synology have disabled it if what I've read elsewhere is true) my root password so I can't do this. 

 

If it means anything, when the system is powered off the LED's on the ethernet port are still active.

 

Does anyone have the definitive guide to setting up Wake on Lan and getting it to work?

 

Thanks

 

 

Edited by oakey

Share this post


Link to post
Share on other sites
Posted (edited)

Couple notes as I've gone through the ringer a few times on WOL. 

 

First, your root password is just your administrative user's password. If you have ssh enabled (default port 22), then you should be able to use Putty to ssh in with the same credentials as you use to log in administratively to the UI. There used to be a secret password to ssh in with that varied by month and so on, I don't know if that's still true, it was used by Synology support to get into your machine in emergencies. But if you can log in to the UI as administrator, that should work for ssh. IIRC you would `ssh <admin user id>:<admin password>@<nas IP>` or the equivalent Putty. I believe you can then `su root` with the same password, or just use sudo.

 

Second, in order for magic packet to work for WOL, you need to not only have your hardware set up to acknowledge the magic packet, the box has to actually GET the magic packet. Any network devices between the system you're sending the packet from and the NAS _could_ be blocking the packet, which I believe is typically a UDP packet sent on port 7 or 9 (double check, it may even be 22). It's unlikely your sending system is blocking it, firewall rules don't usually prevent outbound packets. But your router could be blocking it. I had a FIOS router and I had to perform a manual step to add a static route to the ARP cache (that Putty command you're trying to think of) of the router so that the router didn't forget about the NAS when the NAS was turned off. So, consider that the packet may not be making it through any intermediary network device.

 

Good luck.

 

EDIT:

 

Good blog post on this, although his situation involves both an ISP modem/router and an internal router and he can't put his internal router in bridge mode so he has to create a DMZ, which is hopefully more complicated than your setup.

 

http://www.dreamcraftdigital.com/setup-wake-on-wan-with-the-asus-rt-ac68u-router-and-the-synology-ds216j-nas/

Edited by aol

Share this post


Link to post
Share on other sites
Posted (edited)

I'll double check everything, at least one of my Windows PC's on my network can be woken with the magic packet and the WakeOnLan app on Android so the router shouldn't cause any problems. 

 

I tried the admin password for root and it was denied in Putty, I even logged in to DSM and changed the password and tried it again. 

 

Edit: okay, WoL works on my other Windows PC that's connected to the same switch as the NAS so it's not a network issue.

 

Is there more than one BIOS in the MicroServer that needs WoL enabling?

Edited by oakey

Share this post


Link to post
Share on other sites
Posted (edited)

Okay, managed to get root access with sudo -i and entered "ethtool -s eth0 wol g"

 

Still not working. I'm wondering if I don't have the correct MAC address. 

 

Edit:

 

I've connected it to a monitor and logged into the network configuration screen and the MAC address is correct and the same as I've put in the grub file so not sure where it's going wrong. 

Edited by oakey

Share this post


Link to post
Share on other sites

hey. i have wake on lan on my xpenology box working.

you just need to enable in the bios:  poweron by pci/pcie or both if you have

then also enable it in DSM

 

i have an android Phone and use the app Wake On Lan    https://play.google.com/store/apps/details?id=co.uk.mrwebb.wakeonlan&hl=nl

in the app set the mac adress to the one dsm is saying not the one your network card has

for the hostname/IP/Broadcastadress you will need to fill in your external ip. you can look that up on this website:http://www.whatsmyip.org/

for the port just use any port like 5000 or 5001.

 

after thats done port forward that port on your modem. (if you have 2 routers and have your xpenology box on the second router you will need to port forward twice. the first one needs to port forward the port to the second router and then the second router will port forward it to the xpenology box).

 

 

it should work by now but if it doesnt bind the mac adress of DSM to the ip your nas is on like 192.168.0.105.

it can be called ARP binding or IP & MAC Binding

 

i hope this helps

Share this post


Link to post
Share on other sites

I don't know what you mean by set the mac address in the Wake On Lan app to the one DSM says. The mac address in the Wake On Lan app is already the same as the one in DSM which is the same as the one in the BIOS which is the same as the grub file. 

 

All my devices are already configured for ARP

Share this post


Link to post
Share on other sites

Well if you already have your Mac address the same then just use that Mac adress. With the one that dsm says I meant the local IP the machine got.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

How do I look at the synoinfo.conf file in putty to make sure the settings are correct?

 

edit: figured it out

 

Is this the problem? the wol settings are set to 'd'

 

 

Capture.PNG

 

or not, just found this

 

 

Capture.PNG

Edited by oakey

Share this post


Link to post
Share on other sites

I thought the g was correct

 

If you enabled it in the BIOS and DSM and have configured the app correctly then it should work right now.

 

I also had to mess with is for a few days😂

Share this post


Link to post
Share on other sites
Posted (edited)

So through a steep learning process I've figured out how to navigate through Putty and everything points to the MAC address being correct where it needs to be; the Wake On Lan app, the grub file, in DSM, the BIOS, etc, the MAC address is the same in all of them. 

 

I've logged in as root and entered ethtool -s eth0 wol g

 

synoinfo.conf shows wol as enabled and eth0 set to g

 

I've bound the MAC to the IP in ARP in the router (as well as using address reservation). 

 

Neither Wake on Lan app or Synology Assistant can wake it. 

 

I think I need to do this but it's a bit beyond me;

 

https://xpenology.com/forum/topic/9530-how-to-get-wake-on-lan-working/?do=findComment&comment=81927

 

 

 

 

Edited by oakey

Share this post


Link to post
Share on other sites

Aha! It works!

 

I had to boot up the system and then when it finished booting I killed the power at the switch. Then when I used DS Finder to wake it up it turns on. So it seems the issue is when the system is shutdown through DSM or the task scheduler it's not shutting down properly. I need to do the shutdown script in the above link but I'm not familiar with how I create the file in Putty and set the execute permissions. 

Share this post


Link to post
Share on other sites

It's not working fully yet, I need to to the shutdown script in the above link so it works all the time

Share this post


Link to post
Share on other sites
Posted (edited)

Done it, finally! All works now. Thanks to you both for all your help.

 

These two posts also helped a lot in getting past that final hurdle:

 

 

 

I do have one more problem, all my packages have now disappeared from here even though they still appear to be running, how do I recover them?

 

 

Capture.JPG

Edited by oakey

Share this post


Link to post
Share on other sites

Argh, I've broken it. I shutdown and then started it up via WoL but now I can't access the DSM, it's not showing up connected to my router and if I connect it to a monitor it just says 'Booting the Kernel' (which is what it should do I think?). IT appears to have no LAN connection anymore. 

Share this post


Link to post
Share on other sites
Posted (edited)

Try to reset the BIOS and save it then go back to the BIOS and reconfigure it

 

Does the lan light flash or be on?

Edited by TheIronShadow

Share this post


Link to post
Share on other sites

Yep. The LAN light flashes. I can turn it on via Wake On Lan but once it's booted up it doesn't seem to be connecting to the LAN. I assume DSM is still functioning as it should just that it's unreachable. 

Share this post


Link to post
Share on other sites

Try to find it on find.synology.com and Synology assistant on your pc or Mac.

 

What do you use to see if your Nas is online. The ip?

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Tried find.synology.com and it says nothing is there. 

 

I either log in to my router and look at the list of connected devices or I use Windows and look at what's showing on the network. The diskstation doesn't show in either of them. the DS Finder app just shows it offline as well. 

 

Oh, wait... it's working after I tried your suggestion of resetting the BIOS. 

 

It's showing in the router and I'm logged in to DSM, the packages are back as well. However, both Synology Assistant and DS Finder show it as 'Offline'

Edited by oakey

Share this post


Link to post
Share on other sites
Posted (edited)

No, something isn't right. I'm logged in to DSM but the packages aren't working. File Station won't even open, just get the spinning circle on the icon also even though it shows up in the router and I'm actually logged in both Synology Assistant and DS Finder are showing it as offline.

 

Can't open Control Panel, can't do anything. 

Edited by oakey

Share this post


Link to post
Share on other sites

mmmm
what if you shutdown your xpenology and restart your modem/router.

 

otherwise i dont know what happend.

 

do you have any data on the nas?

Share this post


Link to post
Share on other sites

It's gone again. Restarted it but it's not showing up in the router. 

 

Would reinstalling Jun's Loader fix this?

Share this post


Link to post
Share on other sites

Maybe

I once had updated the Nas but it also didn't show up so it reinstalled the loader on my usb then the Nas says it needs to fix something.

After that it worked

 

I hope it will work for you

Share this post


Link to post
Share on other sites

The problem seems to be it keeps dropping the connection. I boot it up and it starts up and I can login but then it drops off the network and that's it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now