Jerks88

DSM 6.1.5 Gigabit USB Geschwindigkeitsproblem

Recommended Posts

Hi,

 

ich habe auf meinem ReadyNAS Ultra 6 DSM 6.1.5 installiert und leider viele Netzwerk-Probleme.

 

Mein NAS hat 2 Gigabit Ethernet Karten (Marvell Yukon 88E8057), welche im normalen Betrieb super funktionieren. Ich kann ohne Probleme 20 GB große Dateien in beide Richtungen mit 101-110MB/s schieben (NAS <-> PC), aber wenn ich über den jDownload auf dem NAS etwas runterladen möchte brechen die Netzwerkadapter mit einem HW-Fehler zusammen:

 

Quote

2018-02-24T00:32:44+01:00 Synology kernel: [  366.008795] sky2 0000:01:00.0: error interrupt status=0x8
2018-02-24T00:32:47+01:00 Synology kernel: [  368.475121] sky2 0000:01:00.0: error interrupt status=0x40000008
2018-02-24T00:32:47+01:00 Synology kernel: [  368.475202] sky2 0000:01:00.0: error interrupt status=0x8
2018-02-24T00:32:49+01:00 Synology kernel: [  371.013349] net_ratelimit: 1420 callbacks suppressed
2018-02-24T00:32:49+01:00 Synology kernel: [  371.013365] eth0: hw csum failure
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327] CPU: 1 PID: 0 Comm: swapper/1 Tainted: P         C O 3.10.102 #15254
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327] Hardware name:    / , BIOS 080016  06/10/2010
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  ffffffff814aa678 ffffffff813e54cd 000000008141c6ac ffffffff81854800
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  ffffffffa0c88522 ffff880036d47c80 ffff88003974e4c0 ffff88003a2e82c0
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  0000000000000000 ffff88003974e788 0000000000000002 ffffffff81854800
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327] Call Trace:
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  <IRQ>  [<ffffffff814aa678>] ? dump_stack+0xc/0x15
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  [<ffffffff813e54cd>] ? __skb_checksum_complete_head+0x6d/0x80
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  [<ffffffffa0c88522>] ? tcp_error+0xa2/0x210 [nf_conntrack]
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  [<ffffffffa0c8483e>] ? nf_conntrack_in+0xbe/0x570 [nf_conntrack]
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  [<ffffffff8143016f>] ? tcp_rcv_established+0x1ef/0x660
2018-02-24T00:32:49+01:00 Synology kernel: [  371.014327]  [<ffffffff814172e0>] ? inet_del_offload+0x30/0x30

 

Damit ich wenigstens halbwegs ordentlich mit dem NAS arbeiten kann, wollte ich Gigabit USB Adapter mit 480Mbit limitierung über die USB2.0 Ports betreiben. Hier hatte ich zuerst einen Adapter mit Realtek Chipsatz (r8152) erwischt, der wurde zwar erkannt, aber offensichtlich ist in dem DSM Image kein Treiber dafür, so dass er nicht als interface initialisiert wird:

 

Quote

  |__2-2         0bda:8153:3000 00  2.10  480MBit/s 200mA 2IFs (Realtek USB 10/100/1000 LAN 000002)
  2-2:2.0         (IF) 02:06:00 1EP  ()
  2-2:2.1         (IF) 0a:00:00 0EPs ()

 

Da dieser Chipsatz nicht funktionierte, habe ich mir noch einen USB Adapter mit ASIX AX88179 Chipsatz besorgt, welcher auch sofort erkannt wurde:

 

Quote

  |__2-3         0b95:1790:0100 ff  2.10  480MBit/s 248mA 1IF  (ASIX Elec. Corp. AX88179 008CAE4CF4D53B)
  2-3:1.0         (IF) ff:ff:00 3EPs () ax88179_178a net/eth2

 

Ich habe mich schon gefreut, das Ding schnell durchkonfiguriert und zum testen ein 5GB Windows 10 Image vom NAS auf meinen Rechner kopiert. Super, dachte ich, denn er hat mit 40 MB/s kopiert, zumindest brauchbar.

 

Nun wollt ich jDownloader anschmeißen und ein paar Downloads testen und musste feststellen, dass jDownloader nur mit 3 MB/s lädt. Nach einigen Tests stellte sich heraus, dass ich zwar ohne Probleme mit 40 MB/s Daten vom NAS wegkopieren, aber nur mit max 4,5 MB/s aufs NAS drauf kopieren kann.

 

Quote

# uname -a

Linux Synology 3.10.102 #15254 SMP Fri Jan 26 06:43:52 CST 2018 x86_64 GNU/Linux

Quote

# lsusb -i

|__usb1          1d6b:0002:0310 09  2.00  480MBit/s 0mA 1IF  (ehci_hcd 0000:00:1a.7) hub
  |__1-2         0bda:8178:0200 00  2.00  480MBit/s 500mA 1IF  (Realtek 802.11n WLAN Adapter 00e04c000001)
  1-2:1.0         (IF) ff:ff:ff 4EPs (Vendor Specific) rtl8192cu net/wlan0
|__usb2          1d6b:0002:0310 09  2.00  480MBit/s 0mA 1IF  (ehci_hcd 0000:00:1d.7) hub
  |__2-1         090c:1000:1100 00  2.00  480MBit/s 100mA 1IF  (SMI Corporation USB DISK AA04012700008091)
  2-1:1.0         (IF) 08:06:50 2EPs () usb-storage host6 (sdu)
  |__2-2         0bda:8153:3000 00  2.10  480MBit/s 200mA 2IFs (Realtek USB 10/100/1000 LAN 000002)
  2-2:2.0         (IF) 02:06:00 1EP  ()
  2-2:2.1         (IF) 0a:00:00 0EPs ()
  |__2-3         0b95:1790:0100 ff  2.10  480MBit/s 248mA 1IF  (ASIX Elec. Corp. AX88179 008CAE4CF4D53B)
  2-3:1.0         (IF) ff:ff:00 3EPs () ax88179_178a net/eth2
|__usb3          1d6b:0001:0310 09  1.10   12MBit/s 0mA 1IF  (uhci_hcd 0000:00:1a.0) hub
|__usb4          1d6b:0001:0310 09  1.10   12MBit/s 0mA 1IF  (uhci_hcd 0000:00:1a.1) hub
|__usb5          1d6b:0001:0310 09  1.10   12MBit/s 0mA 1IF  (uhci_hcd 0000:00:1a.2) hub
|__usb6          1d6b:0001:0310 09  1.10   12MBit/s 0mA 1IF  (uhci_hcd 0000:00:1d.0) hub
|__usb7          1d6b:0001:0310 09  1.10   12MBit/s 0mA 1IF  (uhci_hcd 0000:00:1d.1) hub
|__usb8          1d6b:0001:0310 09  1.10   12MBit/s 0mA 1IF  (uhci_hcd 0000:00:1d.2) hub

Quote

# ifconfig

eth0      Link encap:Ethernet  HWaddr 00:11:32:2C:A6:03
          inet addr:192.168.1.116  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16526 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5176 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4621108 (4.4 MiB)  TX bytes:1100838 (1.0 MiB)
          Interrupt:16

eth1      Link encap:Ethernet  HWaddr 00:1F:33:EA:E7:49
          inet addr:169.254.149.16  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17

eth2      Link encap:Ethernet  HWaddr 8C:AE:4C:F4:D5:3B
          inet addr:192.168.1.115  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:610539 errors:440 dropped:0 overruns:0 frame:440
          TX packets:1254403 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:608629314 (580.4 MiB)  TX bytes:1417131631 (1.3 GiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:7290 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7290 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:957977 (935.5 KiB)  TX bytes:957977 (935.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 24:05:0F:19:BC:12
          inet addr:192.168.1.114  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15752 errors:0 dropped:1211 overruns:0 frame:0
          TX packets:11156 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4485041 (4.2 MiB)  TX bytes:8054167 (7.6 MiB)

 

Ich denke ja, dass das Treiberprobleme sind, allerdings bin ich nicht in der Lage bei dieser komischen Linux-Distribution auch nur 1 Treiber zu kompilieren.

 

Kann mir hier wer helfen?

 

Gruß

Nico

Share this post


Link to post
Share on other sites

hallo,

 

dann hast du vermutlich nicht meine extra.lzma verwendet da ist ein r8152 treibe rmit dabei

 

zum deinem jdownloader problem kann ich aber nichts sagen das ist ziemlich speziell und eigentlich sollte netzwerktreiber bei netzwerkzugriffen von java programmen nicht abrauchen, da liegen mehrere lagen api's/schichten dazwischen

 

 

Edited by IG-88

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now