alfaCapo

Members
  • Content count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About alfaCapo

  • Rank
    Newbie
  1. alfaCapo

    High Availability su macchine Vmware

    Buone notizie qui: viewtopic.php?f=2&t=1998&p=45964#p45964 Ciao
  2. alfaCapo

    XpEnology High Availability

    Good News... With last active Xpenoboot 5.2.5592.2 on 2 different Pc (Old Dell 745) with 1 disk 200Gb,2Gb ram and 2 network interface (one integrated ad one Intel pro100 desktop adapter), the process of creating cluster terminated correctly!!... I notice that the network adapter added is essential for completing the process.. With normal oem adapter the process gave error durig first phase... The configuration is really simple... Create 2 usb key from img file for xpenoboot, modify on second key the cfg file changing the serial number (last digit is 3 i changed to 5).. Install normally the synology system on either systems.. On the first network adapter configure a static ip address... The second adapter (for the heartbeat) on dhcp... Connect directly the second adapter (the heartbeat) of either systems with a crossover cable (do not pass throught switch because the process change the MTU value to 9000)... Create a volume on every system with standard mode (Synology raid mode SR isn't supported), in my case i have only one disk without raid protection. Launch HA procedure adding the second ip, user and password.. The process terminated succesfully... I notice that the slot disk marked as occupied is this case (with this Dell PC) is the number1.. But on other hardware where i try to install xpenology is the number3.. MAybe this difference can be important for terminating correctly the procedure... Bye.
  3. alfaCapo

    XpEnology High Availability

    i think that the volumes are incompatible... Try to create a cluster without any volumes configured... the process goes well... But after.. you can't create a new volumes.. for me the disks "virtually" mapped to phisical (that i don't know start from disk 3..) are incompatible in cluster configuration...
  4. alfaCapo

    XpEnology High Availability

    Any news or fix on newer version? I try with 2 vm xpenology on same esxi.. With volume configured process finish with error "unable configure ha"... If i try to create cluster without volumes configured the process finish with success... but after i can't configure any volumes.. "configuration process said that it can't configure slave nas because don't respond"..
  5. alfaCapo

    Changing Serial Number when using ISO Xpenoboot

    Yes extract ISO and modify file isolinux.cfg with a new serial. Then recreate the ISO with any programs like WinISO...
  6. alfaCapo

    High Availability su macchine Vmware

    Alla prima occasione proverò... Grazie...
  7. alfaCapo

    High Availability su macchine Vmware

    La configurazione dell'Ha al termine da un errore e si chiude.. pare sia durante la gestione dello storage della macchina slave... Io avevo configurato un volume con un singolo disco da 100Gb per ogni macchina... In Raid0 (dato che il raid synology dicono non essere supportato..). Poi ho provato a cancellare i volumi creati su entrambe le macchine ho configurato invece che uno due dischi per ogni macchina virtuale (che vede come dischi 3 e 4).. Non ho però creato nessun volume... Ho provato a rifare la procedura e viene portata regolarmente in fondo.. Il cluster HA dice essere configurato, vedo i due host attivi, i servizi attivabili..ecc.ecc... Al momento però che vado a creare un nuovo volume a partire dai due dischi configurati... Il sistema dice che non riesce a farlo perchè non può contattare lo slave.. (eppure lo da in linea)... A questo punto mi sembra che ci sia qualche altra incompatibilità che non capisco...
  8. alfaCapo

    High Availability su macchine Vmware

    La tua valutazione è giusta.. Certamente non mettevo le due macchine sullo stesso hypervisor ma su due hypervisor diversi.. Questo la dove magari ho una licenza vmware essential base o free dove non ho il vmotion... Comunque la mia perplessità più che altro sta nelle performances generali che nel riporto tra hypervisor e Xpenlogy ho paura che vengano a scendere notevolmente (cercherò di fare prove a riguardo)... Comunque più che altro volevo provarlo per test per poi magari proporre un cluster Synology tra macchine reali.... Comunque confermo la problematica dell'MTU su workstation, dato che su ESXi va avanti tranquillamente (anche se non ha ancora finito...)...
  9. alfaCapo

    High Availability su macchine Vmware

    Allora, sono riuscito a modificare il seriale della macchina virtuale estranedo il file ISO in locale, modificando il file isolinux.cfg ho modificato il seriale dove veniva proposto e poi con WinISO ho ricreato il file ISO da dare al boot.... Ho impostato le reti come specificato.. ma non funziona lo stesso... Ho notato che al NAS secondario ci arriva ma poi non riesce a configurare la rete di Heartbeat.. Controllando le impostazioni di rete (come in effetti avevo letto le specifiche) sui l'heartbeat lo vuole con un cavo diretto collegato tra le porte e non su uno switch.. Ma le porte hostonly del workstation comunque è come se fossero collegate ad uno switch "virtuale"... Tra le cose infatti che imposta durante la procedura è la modifica del valore dell'MTU delle schede portandole dal default 1500 a 9000 (generalmente utilizzato per il traffico di pacchetti iSCSI o NFS)... Quindi secondo me al momento che lui modifica l'MTU delle schede, loro non riescono più a parlarsi tra di loro perchè lo "switch virtuale" del vmware workstation non ha l'MTU modificabile dal valore standard di 1500 (o almeno io non ho trovato come si possa fare su vmware workstation)... L'unica cosa che posso fare è montare un ESXi dove ha le schede con gli switch virtuali con MTU modificabile e vedere se così funziona.... Se riesco a provare vi faccio sapere.... La mia idea finale era di montare due XpEnology su due ambienti virtuali separati e collegarli in cluster tra di loro....
  10. alfaCapo

    High Availability su macchine Vmware

    Purtroppo non sono riuscito a capire come fare a cambiare il seriale.. Le guide che ho trovato parlano di modificare dei file ma fanno tutte riferimento alle versioni installate con boot da usb.. Io su vmware workstation ho fatto il boot con un file ISO....
  11. Salve, qualcuno ha mai provato ad implementare la funzione High Availability tra due installazioni in ambiente virtuale con vmware? Ho provato a montare due xpenology su un vmware workstation, ognuno con due schede lan, purtroppo quando eseguo la procedura di creazione del cluster ottengo il messaggio che non è riuscito a contattare la macchina slave.. Non ho trovato molto sul forum... Qualcuno ha fatto qualche test? Funziona in ambiente vmware? E tra due macchine fisiche (che personalmente non ho ancora provato)? Grazie.