• Announcements

    • Polanskiman

      DSM 6.2-23739 - WARNING   05/23/2018

      This is a MAJOR update of DSM. DO NOT UPDATE TO DSM 6.2 with Jun's loader 1.02b or earlier. Your box will be bricked.  You have been warned.   https://www.synology.com/en-global/releaseNote/DS3615xs
    • Polanskiman

      Email server issues - FIXED   06/14/2018

      We have been experiencing email server issues. We are working on it. Bear with us. Thank you. ------------- Problem has been fixed. You might receive duplicate emails. Sorry for that.

Mfox

New Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Mfox

  • Rank
    Newbie
  1. Hi, that argument is not entirely correct. assuming that dsm software include gpl code (gnu gpl license), synology is obliged to publish source code and to distribute such code under the terms od gnu gpl license to EVERYONE. Not only to person, who had purchased a DSM from synology. This rules applies not only to orginal code but also to the code modified by synology (as well as work based on a gnu-gpl program) . generally there are two ways to meet this requirement: 1. accompany program distributed in executable form with the complete source code (i.e offering access to copy the source code from the same place as executable form program) 2. accompany it with a written offer, valid for at least three years, to give any third party (..) source code, details are in point 3 gnu gpl license (http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt -I'm not sure on which version od gnu gpl is distributed DSM). if synlogy does not meet these requirements, they violate the terms of gpl license and they are not allowed to use this program (work based on program -DSM) (p. 4 gnu gpl license) Martin