robert36

Transition Members
  • Content Count

    13
  • Joined

  • Last visited

Everything posted by robert36

  1. I have one more question about UPS...as i would like to buy UPS that when power if gone send to synology signal that does synology power off (like you do in synology browser clicking on upper right icon of your username and choose Shut Down). This way is elegant because HDD will save all activity and power off all server. So what interface need to UPS have? USB is good to comunicate to synology and is there synology kernel driver or module that communicate with ups so that i can do programatically set when power is off (we are running on UPS battery), shut down synology. When power
  2. Here i found about NVIDIA driver to add to docker to be able to use hardware acceleration (try on jellyfin its free) Figured it out eventually (reddit to the rescue). This is what I did, for future reference: #ADDING NVIDIA TO DOCKER: nano /etc/modprobe.d/blacklist-nouveau.conf #Add these lines: blacklist nouveau options nouveau modeset=0 REBOOT update-initramfs -u apt-get install gcc apt-get install binutils apt-get install make apt-get install linux-source mkdir /opt/nvidia && cd /opt/nvidia curl -s -L https://nvidia.github.io/nvidia-docker/gpgkey 15 | \ sudo apt-
  3. Yes, you are right...it drops in dmesg error about: failed to load module iwlmvm (error 256), is dynamic loading enabled? So we need new kernel from Synology that have dynamic loading enabled....otherwise we are stuck here without support. Next thing i will do is to try to compile NVIDIA drivers for my GTX 1050 TI 4GB OC gpu to be able to transcode x.265 on that GPU (savings on HDD because i have 1080p x265). I download from NVIDIA WebSite NVIDIA-Linux-x86_64-450.80.02.run and extraced the /kernel folder to /root/linux-4.4.x/drivers/nvidia and now i
  4. Thanks..i need to learn how to compile kernel driver. Do you have maybe compiled iwlmvm.ko? I try using your compiled attachmend above and i get this: root@synology:~# dmesg | grep iwlwifi [ 516.800573] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7260-17.ucode failed with error -2 [ 516.800575] iwlwifi 0000:03:00.0: Falling back to user helper [ 516.802454] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7260-16.ucode failed with error -2 [ 516.802456] iwlwifi 0000:03:00.0: Falling back to user helper [ 516.804140] iwlwifi 0000:03:00.0: Direct firm
  5. I have Intel(R) Dual Band Wireless-AC 7260 miniPCI on GA-H97N-WIFI and would like to compile kernel driver to make it work...so using terminal: lspci -v 0000:03:00.0 Class 0280: Device 8086:08b1 (rev 73) Subsystem: Device 8086:4070 Flags: fast devsel, IRQ 11 Memory at f7c00000 (64-bit, non-prefetchable) [disabled] [size=8K] Capabilities: [c8] Power Management version 3 Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+ Capabilities: [40] Express Endpoint, MSI 00 Capabilities: [100] Advanced Error Reporting Capa
  6. I im very happy with my gigabyte board and i5-4460, because when i work in Diskstation CPU usage is 0-6% so CPU is more powerfull that i need. My concentration is on GPU, as my MBO have 6xSATA and 2xGbE Ethernel LAN Cards integrated, i don't need to go to new version of CPU because of IGPU. Question is i have pat file from DVA3221 and DVA3219 that use NVIDIA GeForce GTX 1650 and NVIDIA GeForce GTX 1050 Ti, so where can i find in pat file what device id is supported? Because i need to know before i buy new NVIDIA card...i have GTX 1050, 1060, 1070 and 1080 cards to buy (
  7. After reading log file that CUDA is not initialized: 2621840-Dec 15, 2020 16:13:19.454 [0x7f455a840700] ERROR - [FFMPEG] - cu->cuInit(0) failed 2621923-Dec 15, 2020 16:13:19.454 [0x7f455a840700] ERROR - [FFMPEG] - -> CUDA_ERROR_UNKNOWN: unknown error 2622023-Dec 15, 2020 16:13:19.454 [0x7f455a840700] ERROR - [FFMPEG] - 2621840-Dec 15, 2020 16:13:19.454 [0x7f455a840700] ERROR - [FFMPEG] - cu->cuInit(0) failed 2621923-Dec 15, 2020 16:13:19.454 [0x7f455a840700] ERROR - [FFMPEG] - -> CUDA_ERROR_UNKNOWN: unknown error 2622023-Dec 15, 2020 16:13:19.454 [0x7f455a840700] E
  8. I figure out what is the problem....i try x264 1080p to play and it is using HW Transcoding (i see ffmpeg uses /dev/dri/renderD128) and CPU usage is 0% so it works. Then i try x265 1080p and CPU usage is between 34-39% and because of little research of CPU i have i5-4460 i im using Intel HD 4600 iGPU (Haswell CPU Code Name) and from Hardware Decoding And Decoding page: https://en.wikipedia.org/wiki/Intel_Quick_Sync_Video#Hardware_decoding_and_encoding I see that GPU built in CPU have HW Support for MPEG-2 and AVC (x.264) so this is reason why when i play x265 i get high
  9. root@Synology:~# cat /sys/kernel/debug/dri/0/i915_frequency_info Video Turbo Mode: yes HW control enabled: yes SW control enabled: no PM IER=0x00000470 IMR=0xffffff8f ISR=0x00000000 IIR=0x00000000, MASK=0x0000002a pm_intrmsk_mbz: 0x00000004 GT_PERF_STATUS: 0x00001677 Render p-state ratio: 22 Render p-state VID: 119 Render p-state limit: 255 RPSTAT1: 0x00048b00 RPMODECTL: 0x00000d92 RPINCLIMIT: 0x000019fa RPDECLIMIT: 0x00003a98 RPNSWREQ: 1100MHz CAGF: 1100MHz RP CUR UP EI: 6747 (8636us) RP CUR UP: 4607 (5896us) RP PREV UP: 0 (0us) Up threshold: 85% RP CUR DOWN EI: 13307 (17032us) RP CUR DOWN: 4
  10. And another from SSH terminal: so last 11 items have Unknown header type so kernel driver is not loaded...how to fix that? I set only UEFI in MBO UEFI settings sto i see that i im missing some drivers..any help where to find drivers if is compiled or any tutorial how to compile it so that i can try to compile. I im attaching dmesg where i power on xpenolgoy so that you can see if there is some errors about drivers....thanks. root@Synology:~# lspci -v 0000:00:00.0 Class 0600: Device 8086:0c00 (rev 06) Subsystem: Device 1458:5000 Flags: bus master, fast devsel,
  11. I have put x265 to x264 High Profile..and i see in Synology 39% CPU usage (this seems to high to me)...so i run htop in SSH and see that ffmpeg is using /dev/dri/renderD128 to transcode video...im im not sure if this is OK CPU usage (as i expect GPU to transcode and CPU to stay around 2-3% while it is doing only transcode in DS VideoStation)... This is commands that i put in terminal using SSH and return... ls /dev/dri card0 renderD128 cat /usr/syno/etc/codec/activation.conf {"success":true,"activated_codec":["hevc_dec","h264_dec","h264_enc"],"token":"5695bd565998486974465
  12. Thanks..that info i need to know...so using XEON is waste of money because motherboard does not support ECC RAM...my goal using XEON was to fix restart issues on DSM6.2.3 and to get lower TDP (35W)...but eather MBO does not support ECC (so restart won't work), nor iGPU in XEON is same as in i7 (it is different name but performance is same). So you suggest me to buy i7-5775C, lower CPU to 2.2GHz and get nice 37W TDP (like xeon), it supports non ECC RAM that my MBO have (2x8GB DDR3 @ 1600MHz CL9), and iGPU device id: 8086:1622 is supported in DSM918+ model so HW transcoding should wo
  13. I im having Gigabyte GA-H97N-WIFI mini-itx board and i5-4460 (LGA1150) that is 84W of TDP so i would like to upgrade to 4c/8threads CPU and get lower TDP and temperature inside my case. On website supported CPU list is here: https://www.gigabyte.com/Motherboard/GA-H97N-WIFI-rev-10/support#support-cpu And i get two very interesting CPU and comparation table: CPU Core i7-5775C | Xeon E3-1265L V4 ------------------------------------------------------ TDP 65W | 35W CLOCKSPEED