roysbike

DSM 6 на Proxmox 5

Recommended Posts

Установка DSM 6 на Proxmox

Создаем VM   со следующими параметрами

Номер VM 101

DISK raw 

 

5a6f222e4697f_2018-01-2916_30_37.thumb.png.f833039b3004ba9ab66e2eafc45c6dee.png5a6f222942125_2018-01-2916_30_47.thumb.png.60bcb1d51144c4cd9d8b31cc634e6310.png

Получаем начало блока EFI : fdisk -lu synoboot.img
Монтируем : mount -t auto -o loop,offset=[начало_блока  * 512] synoboot.img /mnt/tmp
рекадктируем файл grub
Заменяем данные VM диска  : dd if=synoboot.img of=/dev/pve/vm-100-disk-1

Запускаем find.synology.com и устанавливаем  DAT

Share this post


Link to post
Share on other sites

Хранилище на виртуальной машине не привязанное к железу. Я на работе юзаю Proxmox (серверы мощные по 24 и выше ядер) аппаратный RAID массивы. 

Share this post


Link to post
Share on other sites

Не видел ветку, почти не чем. Парень пробрасывает USB порты в гостевую VM и настройки делает через qm , а не через gui

Share this post


Link to post
Share on other sites

а на какие параметры ID ставить, если мы эмулируем образ ? %) 

Share this post


Link to post
Share on other sites

всем спасибо вопрос закрыт, завел все кастомным extra.lzma 

 тут брал 

Share this post


Link to post
Share on other sites
В 29.01.2018 в 16:31, roysbike сказал:

Монтируем : mount -t auto -o loop,offset=[начало_блока  * 512] synoboot.img /mnt/tmp

Вот никак не могу въехать в тему. Как выполнить монтирование этого устройства? При попытке выполнить команду впрямую выдает ошибку что не найден путь в Fstab. Автомонтирование если я правильно понял ключ -auto предполагает запись в этот команды в этот файл, но как это сделать мне не понятно. Я понимаю что скорее всего вопрос чайника, но уж больно хочется разобраться в теме. 

Share this post


Link to post
Share on other sites
Posted (edited)

Все, вопрос снялся. :) Путем долгих поисков и размышлений. 

Однако возник другой. Что править в Grab файле? Боюсь что тут без помощи уже никак. :(

Edited by Валерий

Share this post


Link to post
Share on other sites
Posted (edited)
6 часов назад, Валерий сказал:

Все, вопрос снялся. :) Путем долгих поисков и размышлений. 

Однако возник другой. Что править в Grab файле? Боюсь что тут без помощи уже никак. :(

 

6 часов назад, Валерий сказал:

Все, вопрос снялся. :) Путем долгих поисков и размышлений. 

Однако возник другой. Что править в Grab файле? Боюсь что тут без помощи уже никак. :(

Все просто. Боятся нечего, вы же правите img виртуалки.  Вы когда примонтировали img  , то увидите файл и что править. Указываете mac адрес тот который будет в Proxmox. Генерите S/N. Пришлите скриншот grub, я покажу что изменить 

Edited by roysbike

Share this post


Link to post
Share on other sites
Posted (edited)

То где нужно править я уже догадался, в остальном пока темный лес. 

Скрины прилагаю. Мак адрес сетевухи E6:35:1A:3B:B9:27 

скрин 2.jpg

скрин 3.jpg

Скрин1.jpg

Edited by Валерий

Share this post


Link to post
Share on other sites
Posted (edited)

Попробовал подставить значения в поля которые там ссылаются на МАК адрес и серийный номер (SET mac1= и SET sn=), скопировал диск (как указано в инструкции), но при запуске почему то не находит загрузчик. :( Пишет что ничего не находит, как будто пустой диск. 

boot.jpg

Edited by Валерий

Share this post


Link to post
Share on other sites

Так, с этим вопросом тоже разобрался. :)  Я бестолковка не тот диск переписывал.

Но вот теперь начались проблемы. После загрузки последней версии происходит хрень. Инсталляция проходит, после перезагрузки почему то опять загружается загрузчик с инсталлятором и доступ по сети я уже не имею. Скрин шот консоли VM. Может это быть из-за серийного номера, или может требуется ДВЕ сетевые карты как прописано у вас? Я пока прописал только одну.  

после установки.jpg

Share this post


Link to post
Share on other sites

Небольшая поправка. При выборе пункта меню при старте VM настройка то все становится доступно по сети как и при инсталляции, но после восстановления опять доступ пропадает, как будто в сети машины просто нет, хотя консоль показывает картинку что ядро загружено (см скриншот выше). 

Share this post


Link to post
Share on other sites

А может кто-нибудь присоветовать какую пару лучше брать загрузчика и PAT, версию процессора я так понимаю лучше брать 3615 , поскольку она уже имеет кучу приблуд, или все таки по новее что-нибудь?

Share this post


Link to post
Share on other sites

Все вопросы снимаются. Решение найдено, железяка побеждена. Спасибо. :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now