Sign in to follow this  
down_shift

DSM5 nanoboot black screen after grub screen

Recommended Posts

Nanoboot (5.0.3.2) DSM 5.0-4528

 

been running solid for over two years. 

Last week we had a power outage and it never came back online. 

 

Connected monitor and keyboard to troubleshoot. 

 

Box ox will boot into the loader. Once it goes through selecting dsm5 it will show 

 

“booting nanoboot (5.0.3.2) DSM 5.0-4528”

 

root (hd0,0)

filesystem type is fat. Partition type 0xb

kernal /zimage ihd_num=8 netif_num=4 syno_hw_version=DS3612xs 

 

etc etc

(Linux-bzimage, setup=0x3c00, size=0xc54220)

 

 

 

 

 

 

Then it will be a completely blank screen. 

I’ve never had this issue before with previous reboots. 

I checked my bios settings. They are all still the same profile. 

 

 

Open to suggestions 

is there a troubleshoot guide?

 

 

thanks

 

 

 

Share this post


Link to post
Share on other sites

That us an old loader so there is limited support

 

I would test as follows;

Disconnect your raid drives

Use a live Ubuntu boot disk to check your hardware, network etc

If thats ok

Test your boot usb drive on another PC to see if it boots/appears on the network as

Reflash the usb boot drive with the same boot image

 

Boot the NAS with the reflashed boot image and see if it appears on the lan, if yes then power off and reconnect drives etc

 

You should consider upgrading/migrating to XPE5.2/DSM 5.2 and then to 6.x (if your hardware supports it)

 

Share this post


Link to post
Share on other sites

I just tried the boot image on my laptop. 

It is doing the same thing except it goes into a reboot loop. 

 

Will i lose my hard drive data if I load a fresh copy of the usb ? It should just rebuild my array?

 

i will update to latest once this is resolved. I just never wanted to upgrade due to the system being stable for such a long time. 

Share this post


Link to post
Share on other sites

I have flashed a new boot usb drive. 

Not sure if it’s the exact same image but it’s the closest I can get. 

 

Now. If I were to reconnect my array. Will it format all my data or pick up that it was an array previously and offer to rebuild ?

image.jpg

Share this post


Link to post
Share on other sites

Ok so it looks like your hardware is ok.

 

If you look at the Loader archive, you should be able to find the exact one that matched your install, flash with that and retest

 

If its all ok with that loader, then you can reconnect your drives and it should work.

 

If you continue with the loader you have, then make sure you have the correct version of DSM to match it, you will be prompted to 'migrate', if its a higher version.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this