Jump to content
XPEnology Community

Help with satamap and LSI Card with Disk Shelf


Recommended Posts

Posted (edited)

Hello all,

I tried looking through past topics to understand how satamap worked, but I seem to be going in circles. I have tinycore set up in a VM on proxmox. I only want xpenology to see the 24 disks attached in my diskshelf which is attached with an SAS2008 card. The internal sata ports are not being used and can be ignored by xpenology. I already changed the max disks to 24 in the user_config.json as shown below and confirmed that my bios has SATA running in AHCI mode and that global c states are disabled.

 

{
  "extra_cmdline": {
    "pid": "0xa4a5",
    "vid": "0x0525",
    "sn": "2040SQRMWYV0J",
    "mac1": "001132192ED2",
    "SataPortMap": "11",
    "DiskIdxMap": "1818"
  },
  "synoinfo": {
    "internalportcfg": "0xffff",
    "maxdisks": "24",
    "support_bde_internal_10g": "no",
    "support_disk_compatibility": "no",
    "support_memory_compatibility": "no"
  },
  "ramdisk_copy": {}

 

When I run "./rploader.sh satamap now", here is what I see

 

tc@box:~$ sudo ./rploader.sh satamap now
Machine is VIRTUAL Hypervisor=KVM
Found SCSI HBAs, We need to install the SCSI modules
Don't run this as root.
Succesfully installed SCSI modules

Found "00:1f.2 Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] (rev 02)"
Detected 6 ports/0 drives. Mapping KVM q35 bogus controller after maxdisks

Found "06:07.0 Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] (rev 02)"
Detected 6 ports/2 drives. Mapping SATABOOT drive after maxdisks
WARNING: Other drives are connected that will not be accessible!

Found SCSI/HBA "01:00.0 LSI Logic / Symbios Logic SAS2008 PCI-Express Fusion-MPT SAS-2 [Falcon] (rev 03)" (24 drives)

Computed settings:
SataPortMap=11
DiskIdxMap=1818


 

However, when I complete the build and reboot, it stops at "Booting the Kernel", but xpenology is never found with the Synology assistant or find.synology.com. I think this is due to the satamap being incorrect and trying to use the motherboard sata ports. Any assistance in getting this working is greatly appreciated.  

 

Edited by jrac86
Link to comment
Share on other sites

Was able to perform additional troubleshooting and found that xpenology was going into junior mode with this reason:

Exit on error [12] No raid status in path /sys/block/md0/md/array_state

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...