singet

pb de reconnaissance de dsm et clignotant orange

Recommended Posts

salut, et bonen année à tous

 

suite à une tentative de modif du fichier de configuration système, jeme retrouve coincé avec un clignotant à l'orange permanent j'ai contacté le fabricant qui m'a confirmé que cela venait de la mémoire flash de l'appareil (DS 409+) tout en me précisant qu'il ne pouvait régler mon pb :smile:

 

en fait lors du redemarage avec un reset (avec et sans disque dur) si je passe par l'assitant de configuration de synology, il reconnait mon nas comme un DS410. le pb survient lorsque je charge un dsm:

dsm version 409+ -> fichier non compatible

dsm 410 vers 4.3 inf ou sup -> la mise a jour se lance mais....bloque lors de l'installation pour afficher un "fichier non comptabile ou pb de reseau..."

 

 

j'ai cherché à intervenir sur la carte flash de la carte mère de mon DS409+ pour intervenir sur le fichier systeme qui doit se trouver la je pense: impossible.

 

du coup je me rabats sur les fichiers DSM et une eventuel manip des fichiers qui ferait passer mon dsm pour ce qu'il est (ds409+) à partir d'un dsm de ds 410... :shock:

bon j'avoue j'ai du mal a voir comment m'y prendre...

je viens donc quemander aupres d'ames charitables pour resoudre ce pb :???:

 

auriez vous des conseils ou des astuces ?

merci d'avance

J :smile:

Share this post


Link to post
Share on other sites

Bonjour,

 

Question bete mais ne serait il pas plus judicieux d'aller voir sur le forum officiel de Synology ? :grin:

Share this post


Link to post
Share on other sites

hmm je tente plusieurs approches :wink:

pour l'instant ca ne donne rien sur le forum synology (ou alors les messages sont effacés ? :???::lol: )

je suis preneur de toutes solutions :idea:

Share this post


Link to post
Share on other sites

A tout hasard et à titre d' essais pour voir si cela ne vient pas du contenu des disques eux-mèmes

 

Monter un disque qui ne provient pas du boitier Synology et tenter l'installation du DSM car j' ai remarqué que parfois c' était la seule solution en repartant avec un disque "neuf".

 

Si cela fonctionne le boitier n'est pas en cause et il faudra essayer de sauvegarder les données des disque durs à partir d'une machine Linux, de les formater et réinstaller comme si c' était du neuf

 

Il est possible ( peut-être sans perte de données ) de brancher les disques sur une machine Linux et de supprimer les petites partitions qui contiennent le DSM ainsi que le swap, de les rebrancher

et de réinstaller le DSM.

 

Note 1 : Le DSM ne peut s'installer que s'il y a au moins un disque dur donc sans disque rien n'est possible

 

Note 2 : Il y a un recovery possible :

https://www.synology.com/fr-fr/knowledg ... orials/493

 

La même panne est décrite ici :

https://www.synology.com/en-us/knowledgebase/faq/379

Edited by Guest

Share this post


Link to post
Share on other sites

Si vraiment cela vient de la mémoire flash il y a quelques indications ici :

http://forum.synology.com/enu/viewtopic ... 39&t=84141

 

Voir un test avec une console branchée sur le port série :

http://forum.synology.com/enu/viewtopic ... 27&t=40224

Il avait fait la même chose mais de DS209+II flashée avec un firmware DS210+ ...

 

Il reste quand même la solution de demander à Synology s'il est possible de vous fournir une eeprom flash programmée en leur indiquant le modèle , le numéro de série et l' adresse MAC du boitier

Share this post


Link to post
Share on other sites

ok, je vais prendre le temps de lire tout ca et voir comment l'appliquer.

je suis passé par l'assistance de synology qui n'a pu faire les reparations a distance. :sad:

cdt

j

Share this post


Link to post
Share on other sites

Si vraiment le u-boot a été détruit comme indiqué dans les articles c' est assez compliqué et le mieux serait de leur demander une eeprom.

 

Ce n'est pas trop difficile à dessouder et en ressouder une nouvelle car il n'y a que 8 pins ( 2 * 4 ) .

 

J' ai déjà fait cela pas mal de fois avec des portables qui avaient la mémoire flash HS car à la reprogrammation avec un programmateur des zones étaient inaccessible et donc il n'était pas étonnant qu' à la mise à jour du BIOS cela ait fooiré ...

Share this post


Link to post
Share on other sites

hmm la memoire flash n'est pas sur une puce de 40*48 sur le 409+ ? il me semblait..;

ceci dit je vais deja essayer le log par le port serie de la carte mere meme si j'ai un peu de mal encore à voir comment acceder à tout ca (mode cmd ? ) apres je verrai pour faire de la soudure si necessaire

:smile:

Share this post


Link to post
Share on other sites

Je viens de regarder dans un de mes DS209j et effectivement ce n'est pas une eeprom à 8 pins mais un 28F... donc c'est surement pour du matériel plus récent

Sinon je viens de connecter une interface TTL sur le port série

Dans les descriptions c'était pin 1, 2 , 5 , 6 et ici ce n'est pas cela c'est :

1 - 3Volts

2 - GND

4 - TTL

6 - TTL

J'ai bien accès au log du firmware en 115000 bauds 8 bits sans parité

 

Pour le compte root il y a un password

Ici cela n'a pas été difficile à calculer car depuis le DSM j'ai changé la date en 1 janvier et dans ce cas le mot de passe est : 101-0101

 

Pour une date différente il faut se référer au log qui donne une date par défaut et calculer le mot de passe à partir des infos trouvées ici :

https://wrgms.com/synologys-secret-telnet-password/

 

Je ne sais pas si on peut éditer quelque chose ( rom protégée ? )

 

Infos ici pour la panne :

http://www.nas-forum.com/forum/topic/43 ... us-dacces/

 

En cherchant DS409+ bricked vous trouverez sans doute des informations intéressantes

Share this post


Link to post
Share on other sites