Link für Dateifreigabe ist falsch


Recommended Posts

Hallo,

ich mochte einen link für einen Ordner freigeben. Wenn ich ihn erstellen lasse, hat er die Form https://meinName:5001/share/5345345345/.

Das funktioniert aber logischerweise nicht. Erst wenn ich den Link auf https://meinName.dns.org:5001/share/5345345345/ funktioniert er. Kann ich es irgenwo einstellen, dass der Link automatisch so generiert wird? 

Unter Systemsteuerung > Anwendungsportal > Anwendungen > file station  bearbeiten habe ich "meinName.dns.org" schon eingegeben. es brachte aber keine Erfolg.

mfg

Dirk

 

 

Edited by Doerk32
Link to post
Share on other sites

Unter Systemsteuerung > Anwendungsportal > Anwendungen > file station kannst du einen Link und Alias pflegen, wenn du jemandem Zugriff direkt auf die FileStation geben möchtest.
In meinem Beispiel wäre das z.B. https://cloud.medrow.com:5001/file/, weil ich "file" als Alias gepflegt habe.

Die generierten Links zum Sharen einzelner Dateien oder Ordner haben damit nichts zu tun.
Der generierte Link nutzt die Domain, die verwendet wurde beim Generieren des Links.
Rufst du das DSM über die IP auf, enthält auch der generierte Link die IP.

 

Wobei - ich hab's jetzt nicht ausprobiert - du den Domain-Teil vor dem "/share" austauschen können solltest.
 

 

Edited by Chili
Link to post
Share on other sites
On 4/9/2021 at 11:23 AM, Doerk32 said:

 Ich habe externen Zugriff unter Systemsteuerung - Externer Zugriff, Reiter "Erweitert" ausgefüllt. dann ging es perfekt

Das alleine kann es nicht sein.
Diese Felder sind bei mir z.B. alle leer und es funktioniert auch ohne.

 

Zudem die Beschreibung auch etwas "speziell" ist.
Was genau die Auswirkungen dieser Einträge für diese "Internetdienste" sind, weiss ich nicht.

 

Mach doch mal den Test:
Rufe dein DSM aus dem LAN mit der IP auf (statt der Domain) und generiere einen Freigabe-Link.

Link to post
Share on other sites

Wenn du zufrieden bist, dann ist es doch okay.

 

Mich macht es immer etwas nervös, wenn etwas funktioniert (oder nicht) und ich nicht genau weiss, warum eigentlich.
Wie gesagt: die Felder sind bei mir default leer und meine generierten Links tragen immer die Domain, mit der das DSM aufgerufen wurde.
Möglich, dass die Einträge das overrulen - das geht aber aus den Beschreibungen leider nicht wirklich hervor.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.