JFrost

XPEnoboot install trouble on Hyper-V

Recommended Posts

Hello all,

 

Been using Synologys for a while so fairly familiar with DSM but very very new to xpenology project so be gentle please :smile:

 

Tried setting this up on a hyper-v vm (2012, not R2), and it *seems* to go well. I've had to fiddle around a bit to get a "successful" install and I'll detail my settings at the end. My main problem is that after installing the .pat file Syno assistant says install ok, but when I try access DSM I get promted to install DSM again. Refreshing Syno Assistant says 'configuration lost' and I can go round this loop endlessly.

 

Any ideas what is going on?

Thanks.

 

 

Details -

  • Host server is Win 2k12 Standard on DL360 G5 hardware - 16GB RAM, 2x Xeon 5460
  • Hyper-v Guest has:
    • 2048 RAM
    • 1x virtual proc
    • IDE controller 1:0 - DVD drive (default drive) with XPEnoboot_DS3615_5.1-5022.0.iso
    • IDE 0:0 - 1 GB .vhdx (for Syno system/boot vol)
    • SCSI 1 - 10GB .vhdx (Syno data)

 

My first run through, on boot, I choose the 3rd option (install/upgrade). When it gets to the "Diskstation Login" prompt I go to Syno Assistant (on another machine), upload the .pat file, select password, name and network (seems to work better w/ static IP assigned) and go.

After that completes, try to access the DSM page (no reboot other than the one Syno Assistant install does) and I get the reinstall dsm web page.

Thanks for any help.

Share this post


Link to post
Share on other sites

I've semi-solved this.

 

While twiddling, installed nanoboot 5.0.something, which worked out well. Then I tried upgrading to XPEnoboot for 5.1 and that worked too!

 

So.. Now have xpe running on hyper-v.

 

Maybe that helps someone.

J.

Share this post


Link to post
Share on other sites

Hi JFrost,

 

Did you manage to install update 2 on top of 5.1?? I'm able to upgrade to 5.1 but update 2 fails.

The difference I see between your and my setup is that you boot from IDE while I boot from SCSI.

 

Thanks and regards, Kees.

Share this post


Link to post
Share on other sites