Jump to content
XPEnology Community

DS-918+ Reset adapter unexpectedly


Recommended Posts


I have a setup a DS-918+  (DSM 6.2.2-24922 Update 4)
Board: Z270 Gaming Pro with onboard INTEL NIC
CPU: intel core i7-7700k kaby lake
Menmory: 16 GB


My problem is that when i send or copy some big files to or from my NAS the network card in my NAS resets and then the only way to connect to it again is to reboot the NAS, it get a lot of these errors when that happens.

2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035] e1000e 0000:00:1f.6 eth0: Detected Hardware Unit Hang:
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   TDH                  <0>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   TDT                  <1>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   next_to_use          <1>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   next_to_clean        <0>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035] buffer_info[next_to_clean]:
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   time_stamp           <109709654>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   next_to_watch        <0>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   jiffies              <10970a6e0>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035]   next_to_watch.status <0>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035] MAC Status             <40080083>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035] PHY Status             <796d>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035] PHY 1000BASE-T Status  <3800>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035] PHY Extended Status    <3000>
2020-01-13T16:22:56+01:00 synology2 kernel: [158681.377035] PCI Status             <10>
2020-01-13T16:22:57+01:00 synology2 kernel: [158682.384859] e1000e 0000:00:1f.6 eth0: Reset adapter unexpectedly
2020-01-13T16:23:01+01:00 synology2 kernel: [158686.158975] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
2020-01-13T16:23:03+01:00 synology2 kernel: [158688.378512] e1000e 0000:00:1f.6 eth0: Detected Hardware Unit Hang: 

I have tried to copy the extra/extra2.lzma files from here


to my usb 2nd partition and overwrite the existing files (extra/extra2)

That didn't help anything.

When i look i kern.log i can see that the driver for my NIC is loaded:

2020-01-13T16:24:01+01:00 synology2 kernel: [   15.225886] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.225887] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.226029] e1000e 0000:00:1f.6: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.518273] e1000e 0000:00:1f.6 eth0: registered PHC clock
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.518277] e1000e 0000:00:1f.6 eth0: (PCI Express:2.5GT/s:Width x1) 4c:cc:6a:cf:51:c6
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.518279] e1000e 0000:00:1f.6 eth0: Intel(R) PRO/1000 Network Connection
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.518308] e1000e 0000:00:1f.6 eth0: MAC: 12, PHY: 12, PBA No: FFFFFF-0FF
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.530759] igb: Intel(R) Gigabit Ethernet Network Driver - version 5.3.0-k
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.530760] igb: Copyright (c) 2007-2014 Intel Corporation.
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.533014] ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 4.2.1-k
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.533015] ixgbe: Copyright (c) 1999-2015 Intel Corporation.
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.964138] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.964139] e1000: Copyright (c) 1999-2006 Intel Corporation.
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.997416] 2020-1-13 15:24:1 UTC
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.997420] Brand: Synology
2020-01-13T16:24:01+01:00 synology2 kernel: [   15.997421] Model: DS-918+

I haven't tried with a different NIC yet.

I hope someone can help me :-)

Edited by Polanskiman
Please use code tags when posting command lines, code or logs.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...