dMajo

Members
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

0 Neutral

About dMajo

  • Rank
    Newbie
  1. There was no 5.1.30 since this will be newer (later) than 5.0.40. For previous versions click on expand under history under the latest version description.
  2. I think you need to download the guest additions from the VB official site. Perhaps sources and you will need to build them. For linux system on which DSM is based over. This thread discusses the VB installation under DSM not the opposite. You can try other xpenology forums where the argument is running xpenology in a VM. Perhaps there they have already compiled guest additions.
  3. You can install VB from here Once finshed you will find the right guest additions iso in the vb folder in @appstore
  4. It works on mine DS1815+ and RS2414RP+ but I can confirm also DS1515+ DS415+ which is obvious being all on the same architecture.
  5. If you are using win client you can use the in-built remote desktop connection client with: ip.of.the.nas:9000 Look for the port range in the vm settings. Be sure that on the nas firewall these ports are open at least for the local lan.
  6. I think that DTech meant that he updated the package without uninstalling the previous version. Since version 5.0.4 this is working, Dodo-dk has done a great job, tha package gets updated and preserves all the settings and VMs. Regarding the auto update I think you do not want the package center update automatically virtualbox shutting down the running VMs in an uncontrolled fashion.
  7. In the application installation folder volume/@appstore/virtualbox there is a iso for the guest additions
  8. In the package center settings you need to allow installation from untrusted sources, ie any publisher.
  9. Regarding the index.html I don't know. At first I updated the previous version through the package center update function. Then after the gui was not working I added the execution rights (744) to the index file. There wasn't any VM in execution during the upgrade, but the vb service was started. After the change anything worked fine. I suspected that maybe you have not handled/foreseen the upgrade process so later I uninstalled the package, checked if there was any pending folder that needs manual deletion and re-installed the latest package. Again I needed to apply the change to the index fi
  10. Dodo, I've added your packages to our repository. Since the info in the packages are pretty the same I had to modify the xpenology build: I've renamed the package's internal name from "package=virtualbox" to "package=virtualbox-xpe" I've added to the description (of both): "Release made for Synology"/"Release made for XPEnology" I've changed the displayname to "VirtualBox Syno Edition"/"VirtualBox XPE Edition" I've added the beta information: packages that are actually in beta and/or require higher user's skills are published under the beta channel thus you need to enable it in the
  11. Dodo, I've added your packages to our repository. Since the info in the packages are pretty the same I had to modify the xpenology build: I've renamed the package's internal name from "package=virtualbox" to "package=virtualbox-xpe" I've added to the description (of both): "Release made for Synology"/"Release made for XPEnology" I've changed the displayname to "VirtualBox Syno Edition"/"VirtualBox XPE Edition" This was needed to show both the packages on syno and xpenology units that identifies itself to the repo with the same architecture but actually needs different binaries. Fr