bchuter

[SOLVED] Link aggregation on VM server

Recommended Posts

HI Guys

 

I have just reconfigured my VM server to have 1 vm switch for management

and 1 vm switch for all the server. The server switch i have have added in 2x 1gig NIC's in etherchannel.

all my other VM's are working perfectly fine with this.

However my DSM wont see network at all.

 

I created a test VM with just the synoboot image and it too will not get an IP.

does not matter if i choose VMXNET or e1000 NIC.

 

Has anyone got the DSM working on a VM server using link aggregation (nic teaming) ?

 

Any help will be greatly appreciated.

This is on my work box so my storage for work is down....grrrrr

Edited by Guest

Share this post


Link to post
Share on other sites

OK i got this working!!!! after an entire day of trying all sorts of things.

 

DO NOT add any additional vSwitches......no mater how you configure them, the Synoboot will not get IP or see the network...... PERIOD!

does not matter which vSwitch you add it to it or which way you configure it (trust me i tried all variants) will not work.

 

I eventually got my link aggregation working by removing all vSwitches and leaving just one with my management kernel nic added to the same vSwitch and adding in all 4 NIC's to the same vSwitch. Also dont forget if you adding port-channels from the same network switch you have have to setup the NIC teaming to use "Route based on IP Hash" or it will not work!!!.

I have 4x 1GIG NIC's aggregated with no issues after doing this.

 

WOW what a frustration!!!

 

but at least i was able to save my storage!! whoooohoooo

Share this post


Link to post
Share on other sites

LAG is issue for VMM, was kinda stated in help file at one time.

Share this post


Link to post
Share on other sites

Ok the box was completely trashed the next morning.

Synology cannot find the page you are looking for.

I tried everything to get it back, to no luck.

 

Steer clear of LAG on VM.

 

I have had to used another server at work with single link for my NAS box now.

Share this post


Link to post
Share on other sites

So a further update on this.

 

It seems DS3615xs works perfectly fine on VMware 6.5 with LAG.

All my previous tests above were with the latest loader and DS3617xs.

 

I can confirm however that the DS3615xs loader and DSM work just fine and have been fully upgraded to the latest update (update 4)

This has been running stable for over 5 days now.

 

There must be a trigger in the DS3617xs that kills it after a few hours when using LAG. (The countdown bomb)

 

Anyways just an update that the older loader with DS3615xs works great with VM and LAG enabled.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now