Jump to content
XPEnology Community

DSM 6.2.4 DS918+_25556 is working with ARPL i18n - how it worked for me


jimmehK

Recommended Posts

Hi, 
since I spend some time on getting this to work, I would like to share my journey - if you need (want) DSM 6.2.4 update7 running on custom hardware (with DS918+) this might be interesting for you to read - if not -> move on.
If you want to advocate "only use latest/my version" or start a discussion about why DSM 6.2.4 in general please be kind and do this elsewhere. This topic and discussion in ONLY FOR THOSE WHO WANT 6.2.4 - all others skip this and save each others time. Even when it is tempting, please really I mean what I say: don't troll me - this is about the how, not the why.

The initial fails:

While some documents and forum posts still indicate TCRP could on one time in the past build loaders for 6.2.4 I spend a geed weeks sparetime to find a way, search old repositories and other forums for downloadable stuff it did not work out (version 0.4.6 and 0.8.0 where/are mentioned - but I could not find a working copy). I tried forks, old versions, even started fiddling with docker to find a way....

 

The fist light of hope:

In a kind of last try I found this very recent posting from user "blinddspot" pointing to ARPL-i18n

 

The setup:
- download of recent version(arpl-i18n-23.9.7.img) was easy, no need to do any prep, just use usbot/winimage what ever to get on USB stick
- start and use the menu (http://<ip>:7681 or cosole and keyboard)

- select model and version: DS918+, 6.2 version)
- dont build, first configue some details in the advanced options

- set dhcp IP timeout to 30 seconds 

-go to modules selection and deselect all, only add very basic modules (acpi, keyboard, bitcopy,..) avoid loading your image with "all nic" or all "sata/sas" controlers at all cost

- only select the one NIC driver you need - I will post a list of my modules when I have a chance to extract it from my backup usb image

- change kernel load to kexec

- change redpill lkm branch to test

- download the pat file (DSM_DS918+_25556.pat) to your computer and double check the integrity

- build the module in menu

- exit and reboot (dont use reboot in the menu, do a clean power cycle)

- not let DSM boot and access web gui of the booted dsm

- install pat file DSM_DS918+_25556.pat

- if that fails on the first try, try again (check if file is not corrupt)

- from now on follow other guides (don't use any synology online service, no metrics, no find-my-device,no licensed (pay) stuff from the package center)

 

 

Troubleshooting, check if your hardware will work at all:

only do this steps when you failed and retry
- have a disk (or two) at hand that contain no data you need

- use the advanced menu to format those disks (sda/sdb directly, no partitions)

- repeat the rest

 

Whats not working as expected:
- there is a random MAC defined, I can even see it on the bootloader string on the console, but that is happily ignored and the realmac is used

- during a normal boot to dsm the bootloader boot part gets no IP from DHCP (timeout is set to 30 seconds, but hey we dont need IP connectivity here if it works later)
- if I don't format the disks (sda sdb .. the real disk, not a partion) in the advanced menu it wont work, pat file got rejected (checksum was checked, PAT file is not broken) -> if you want to migrate that looks like a migration over network, I will test and report if moving disks works one my system is tested and I risk the migration

- I assume I will be installing dsm to spare disk, then add the old disks and hope DSM will allow me to absorb the old disks into a running system w/o reinstalll

 

My setup is now as follows:
Asrock N100DC-ITX board with Intel N100 4xE-Core Cpu (no HT)

r8169 onboard GBit NIC

32 GB Ram (from the compatibility list of Asrock!)
2x SATA on board with 500GB and 1TB disks (for testing)
DS 918+ DSM 6.2.4-update7 25556u7
 

Whats next:
- getting NVME cache to work with M2.M onboard slot

- performance and burn in test (will it crash, can it encrypt at line speed, do I need 10GB Nic-card?)
- add very funny M2.E/A key 4-port Sata expansion adapter (yes, WiFi M2 to 4x SATA... my chances are 30% that will work)

- add PCIe1x NVME dual (M2.M and M2.SATA) adapter (yes, one card with 2 different M2 SSD options working in parallel, I don't expect that to work either - got the adapter for 2$...)

- add PCIe4x Dual 2.5GB or 10GB Nic (need to dig into which driver is stable...)

- migrate 3x10TB from old physical DSM that's old and slow without requiring backup and restore via USB

 

  • Like 2
Link to comment
Share on other sites

I did not do 6.2.4 compatibility testing for some addons and discarded them directly.

You also know that I am just one person without team support, and my hardware is very limited, so it is difficult for me to do a lot of testing work.

Edited by wjz304
Link to comment
Share on other sites

Thanks for you effort - many thanks, I will check what is possible and test what I can test and report. 


If there is a common small set of working options for 6.2.4 it could help some people when migrating to 7.x DSM:
That was my motivation, I can not move to DSM 7 directly, I have to upgrade my current setup and keep it stable for some more month. During that time I will prepare migration to 7.x.

 


 

Link to comment
Share on other sites

Hi. This is great news for me also, because I've tested on some hardware and I wasn't able to figure out why it worked on some and why not on other. I did thought it has something to do with the modules, so please tell me which modules you kept before building the loader.

I will retest with what hardware I have at work following your steps. Thank you.

Link to comment
Share on other sites

  • 2 months later...

Hi, sorry for the long time.

I was traveling for business.

 

Here my feedback after 2 month of running ARPL-i18n v23.9.7 DS918+ 6.2(25556u7)  (yes, latest u7) on IntelN100 with ASM1166 PCIx4 add-on

The system is rock stable and fast responding, I could load config export from a DS415play (x86/32bit Intel Atom)

The setup of the disks was at first trick, the documentation is a bit thin, had to read and try some time until it works.

Also working the PCIe-NVMe "hack" for M2.E+B slot SSD as read cache - BUT only when patching manually, the script does not work ( xpenology.com/forum/topic/13342-nvme-cache-support/page/3/#comment-126807)
But I did switch to use 2x SATA-SSD as read and write cache, the write performance on small files improved from 6mb/s to 38mb/s (using small file test from Microsoft disk benchmark tool)

In 5 weeks I did run multiple 4-5 day CPU burn in tests, also I transferred 35TB+ files to and from the NAS via the onboard 1GBit nic.

 

Update from my todo list in post #1:

My 3x10TB disks where moved successful from my legacy Syno-Hardware, including encrypted folders
The M2.WiFi Sata Adapter did not work. the Board/Chipset only supports Intel CNVi WiFi Adapter (but all of them, not only latest gen)

My current Hardware:
Asrock N100DC-ITX board with Intel N100 4xE-Core Cpu (no HT) - powered by 19V Laptop PSU

r8169 onboard GBit NIC

32 GB Ram (Samsung, from the compatibility list of Asrock!)
2x SATA on board with 256GB Sata-SSD for Read/Write cache

PCIx4 Sata-Card 6-ports with ASM1166 chip
3x 10TB Exos Seagate disks on  Sata Add-In Controler (4k/512n sectors)
DS 918+ DSM 6.2.4-update7 25556u7

 

An finally a dump of my config:

Model: DSM918+

Version: 6.2
Addons: nvmecache:  hdddb codecpatch misc addincards acpid storagepanel reboottoarpl
Modules: mii r8169 

                 -> Modules setting: Priority use of official drivers: true

User Commandline: SataPortMap: 26

Model inherent cmdline: HddHotplug: 0  syno_hdd_detect: 0  syno_hdd_powerup_seq: 0  vender_format_version: 2  elevator: elevator

Sysinfo entries: usbportcfg: 0x0000003F00 │ maxdisks: 14 │ netif_seq: 0 1 2 3 4 5 6 7 │ support_disk_compatibility: no │support_memory_compatibility: no │ support_syno_hybrid_raid:  │supportraidgroup:  │ internalportcfg: 0x000000003F  │ support_led_brightness_adjustment: no │ buzzeroffen: 0xffff │ maxlanport: 8  | esataportcfg: 0x00000000C0  │ support_leds_lp3943:

(to get sysinfo entries for disk mapping use the sheet with macros, if you can not find it send me PM, my setup is for 2xSata on-board controller 1, 6xSata on controller 2, 6x USB disks)

 

Advanced Options:

 Switch LKM version: prod  │ Switch direct boot: false │ Timeout of get ip in boot: 30 │   Timeout of boot wait: 10   │   kernel switching method: kexec     

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...