mystycs

ipkg update wont work, tried everything

Recommended Posts

Hey there, i installed ipkg bootstrap on my Synology but it wont work, i tried everything.

 

I keep getting and ipkg update error below which i read has to do with wget?

 

DSM> ipkg update
Downloading http://ipkg.nslu2-linux.org/feeds/optware/syno-i686/cross/unstable/Packages.gz
Inflating http://ipkg.nslu2-linux.org/feeds/optware/syno-i686/cross/unstable/Packages.gz
Updated list of available packages in /opt/lib/ipkg/lists/cross
Successfully terminated.
DSM>

 

Installed this one (running a 64 bit intel) (http://ipkg.nslu2-linux.org/feeds/optwa ... 7_i686.xsh)

 

And changed my path to the correct form,

DSM> echo $PATH
/opt/bin:/opt/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin

 

Below is my wget version and path

 

DSM> wget -V
GNU Wget 1.12 built on linux-gnu.

+digest +ipv6 -nls -ntlm +opie +md5/builtin -https -gnutls -openssl
-iri

Wgetrc:
   /opt/etc/wgetrc (system)
Compile:
   /home/slug/optware/syno-i686/toolchain/gcc-4.2.1-glibc-2.3.6/i686-linux-gnu/bin/i686-linux-gnu-gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/opt/etc/wgetrc" -DLOCALEDIR="/opt/share/locale" -I. -I../lib -I ../md5 -O2 -O2 -pipe -I/home/slug/optware/syno-i686/staging/opt/include -O2 -Wall
Link:
   /home/slug/optware/syno-i686/toolchain/gcc-4.2.1-glibc-2.3.6/i686-linux-gnu/bin/i686-linux-gnu-gcc -O2 -Wall -L/home/slug/optware/syno-i686/staging/opt/lib -Wl,-rpath,/opt/lib -Wl,-rpath-link,/home/slug/optware/syno-i686/staging/opt/lib -lrt ftp-opie.o gen-md5.o ../lib/libgnu.a ../md5/libmd5.a

Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Originally written by Hrvoje Niksic .
Currently maintained by Micah Cowan .
Please send bug reports and questions to .

 

DSM> which wget
/opt/bin/wget

 

Any ideas?

 

Thanks!

Share this post


Link to post
Share on other sites