Lynxai

6.2 Volumen crashed ¿llamo a Synology?

Recommended Posts

Hola a tod@s,

 

Acabo de mover los discos de un Synology DS411j con dsm5.2 y varios años a sus espaldas a una node 304. He aprovechado el tutorial de polanskiman para actualizar a la 6.0.2 y todo fue a la primera, o eso pensaba. Tras instalar el pat de actualización, apagué y volví a encender, el nas no era accesible desde web, me puse nervioso y apagué la caja con el botón. Tras arrancar de nuevo me indica que se recuperó un apagado repentino y el volumen está averiado con 0mb, el log dice que ha borrado todos los share folders y luego se crasheó. A través de ssh puedo entrar en el volumen1, hago un dir y no hay nada, supongo que he perdido los datos ¿es cierto? ¿puedo ir de perdido al río y contactar al servicio de synology y que me confirmen al menos si los datos están borrados, aunque sea pagando? ¿o hay algo que se pueda hacer?

Share this post


Link to post
Share on other sites

Actualizo: He seguido las indicaciones de este post https://forum.synology.com/enu/viewtopic.php?t=101159

 

En concreto (y cambiando vg1 por vg1000 en mi caso):

mount /dev/vg1 /volume1 # does it mount?

ll /volume1 # lv -> /dev/mapper/vg1-lv

 

umount /volume1 # causes beeps

mount /dev/vg1/lv /volume1 # appears to fail (mount: mounting /dev/vg1/lv on /volume1 failed: No such device)

tail /var/log/messages # I think these are the lines he was looking for

# Jun 11 06:50:54 DiskStation kernel: [13008.925928] JBD2: journal transaction 28430572 on dm-0-8 is corrupt.

# Jun 11 06:50:54 DiskStation kernel: [13008.932286] EXT4-fs (dm-0): error loading journal

 

 

mount -o ro,noload /dev/vg1/lv /volume1/ # remount it read only, without loading the journal. Genius!!

df -h # Confirm its mounted

synospace --map_file -d # returned "Success to dump space info into '/etc/space,/tmp/space' " but not really sure what that means

synocheckshare # Ran some diags I guess

grep volume1 /usr/syno/etc/smb.conf #my share names pop up, not sure why he was grepping for this.

 

Y ahora puedo acceder por ftp y descargar los datos. Dejo esto aquí para futuros "googlers" por si sirve de ayuda. Ahora tengo otro problema:

DONDE CARAJO DESCARGO 8TB!

Share this post


Link to post
Share on other sites

Yo te ponía una chincheta.

[THUMBS UP SIGN]

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Mientras la chincheta sea al post y no a mí :smile:

 

Actualización 2: Ahora mismo estoy sacando los datos por ftp a mi nuevo bebé de 8tb, mi mujer está que trina por la compra pero ha sido causa de fuerza mayor. Ese post, literalmente, me ha salvado la vida, amén de estar perfectamente explicado y ser bastante ilustrativo de lo que estás haciendo en cada momento (si no fuera porque estaban en juego 15 años de descargas, diría que hasta lo he disfrutado). Me he impreso estos comandos en un papel y lo tengo guardado por si algún día me hacen falta y no encuentro el post. Por cierto, si apago la node y enciendo hay que volver a montar el volumen.

 

Y ahora un poco de chapa de abuelo. Empecé con un Readynas NV+ de Infrant sacado de ebay cuando el cambio estaba a 1,60$, antes de que los comprara Netgear, ya ha llovido. El servicio técnico que tenía con los indios de Infrant no lo ha tenido Synology en la vida y por eso me he cambiado a xpenology, por eso y porque me da verguenza pagar 700€ por un nas que no es capaz de trascodificar una mísera película con Plex.

 

Edito para un detalle obvio pero clave: Si vas a salvar por ftp 8tb, lo mejor es conectar el nas por ethernet directo al ordenador, lo buscas por synology assitant y duplicas la tasa de trasferencia. Así tu mujer en lugar de darte la brasa durante 12 días (cálculo estimado) con que cuándo va a poder ver la cuarta temporada de Criadas y Malvadas, sólo te la dará durante 6 días! (cálculo estimado).

Share this post


Link to post
Share on other sites

Una al post porque es muy buen trabajo. Y otra a ti porque así con la sangre de la chincheta no te fijas en la de los oídos....

(Hace 6 meses perdí 4 tb de forma parecida . Yo no los recupere. Osea que imagina el disgusto y la chapa )

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Puedo entenderte, créeme. Quizás alguien lea esto y diga: "menudo flipado", pero cuando llevas 15 años descargando anime, series, pelis, ordenando una biblioteca de calibre para comics, otra para libros, recopilando fotos, almacenando trabajos... llega un momento en el que el NAS se convierte, salvando las distancias, en tu árbol plantado, tu libro escrito, algo así como una suerte de legado que dejas para que alguien lo vea y diga: "así era él" o "esto es lo que le gustaba". Bueno, ya desvarío. Dejémoslo en que estoy contento de haber salvado todo.

 

Ya no a este post, porque tampoco es tan completo, pero sí le ponía la chincheta a uno bien organizado con comandos paso a paso para volver a montar un volumen averiado, tabla de partición dañada, comandos de diagnóstico, etc. Sería un trabajo digno de ver si alguien con conocimientos se lo propone y no entiendo como no se ha hecho antes, lo veo imprescindible. Sé que cada caso es un mundo, pero daría norte a mucha gente que se ve en estas situaciones y se pasa horas buceando en foros para terminar en desastre al final.

 

Por cierto, 2 problemas que me están surgiendo mientras se copia todo: Primero se me ha creado una carpeta@eaDir dentro de cada directorio, lo cual son muchos directorios, pero nada que no se pueda borrar. El segundo problema más importante es que me ha cambiado la codificación de todos los nombres de archivos y carpetas. Así, Lluvia de Albóndigas ahora es Lluvia de Albóndigas y Mulán (1998) es Mulán (1998). ¿Alguna forma de arreglar esto automágicamente?

Share this post


Link to post
Share on other sites

Te entiendo amigo. Yo recupere algo. Pero perdí más y me dolió en el alma.

La biblioteca de calibre entre las que no

En cuanto a la codificación de los nombres de los ficheros. Ten cuidado porque si los cambias a pelo desde un Windows. Puede que se le valla la pinza y luego no abran.

Sickrage es tu amigo. En la parte de postprocesado manual. Y forzando ficheros ya procesados. Y si no. hay herramientas que te cambian el idioma del utf. (Lo tienes en inglés)

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Vale, esto es lo que ha pasado: Cuando WinSCP copia los archivos del NAS por ftp cambia aparentemente la codificación, así la á se convierte en á y la ñ en ñ, etc. PERO, cuando vuelve a copiarlos al NAS corrige la codificación. Llevo casi un día renombrando con reglas del Advanced Renamer todos los datos, prestándome a una tarea titánica a la par que estúpida, por desconocer este hecho. Es más, si copias de vuelta por ftp archivos renombrados te los pone mal y con las carpetas es peor, te crea en destino unas carpetas vacias sin nombre :-S Me he salvado por el hecho de que al corregir el volumen, y tener de nuevo acceso por windows, copio los archivos por el explorador y me respeta lo renombrado. Pero he perdido un día tontamente. Vuelvo a dejar esto por si a alguien le sirve.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now