Jump to content
XPEnology Community

[SOLVED] USB-UPS in virtualbox with Xpenology4.2 3202


Recommended Posts

Hi folks,


for testing purposes I got an XPenology release installed in a virtual box, curently it is DSM4.2-3202 upgraded from 2668.


I have an old UPS standing arround here, a Mustek PowerMust 800 USB. I tried it under Windows - works quite good. I'd like to connect it to the NAS server. Unfortunatly there are several issues, that hinder me from doing so:

- only protocol usbhid-ups is supported, Blazer_usb is not. Checked the NUT sources, installed toolschain and optware-devel to recompile and install release 2.4.2. Solved

- I realized, that there is only one device available in /proc/bus/usb/devices. It is an EHCI hub device (AFAIK). No further connected devices are listed. Yes, I have made them available to VirtualBox. I tried with openSuse 12.3 in virtualbox, lsusb shows correct list of devices, /proc/bus/usb is not available at all. I tried with debian 7 life CD, /proc/bus/usb is an empty directory. Is it a kernel setting during build phase?

- The UPS gets not shown in the list of devices. If it would get shown, do I need a further kernel module like usbserial?


Of course, this is a bit of effort for a test environment, but I will install it later on a N54L, so it would be good to have a testbench in the backyard.


EDIT: I've read that it might depend on 2.6.x Kernel. Any ideas? In the meantime I've reinstalled usbutils. lsusb gives no further information: Newly connected devices will not be detected in virtual box.


Thanks a lot in advance for comments and hints!

Link to comment
Share on other sites

It is just a matter of underlying virtualization in combination with the release to be used.


I've found a hint that you have to have EHCI support for UPSes. This is available 3211, but not in 3202. So I dropped virtualbox as virtualizer for XPenology: Current releases do not support neither e1000 NIC nor AMD stuff. VMWare Player 6 officially also has only e1000 NIC, but you can patch the vmx file and enter vmxnet3 instead of e1000. And vmxnet3 is supported in 3211.


After that I created a bootable ISO image (http://xpenology.com/forum/viewtopic.php?f=2&t=1306#p6294) so I will have some kind of "removable boot device" instead of the annoying vmdk, which always gets corrupt during the installation process.


I installed. I made lots of mistakes:

- keep in mind, that vmxnet3 will have to have the MAC address set as a kernel parameter! I decided to do it in menu.lst and it works like a charme.

- when you get IPAPI address (169.254.some.thing) and you have a system with multiple NICs (Laptop with LAN and WLAN), check your bridge connection!!


and finally it ran ...


I put the usb cable into the connector - made it available to the VM - checked "hardware - UPS" in DSM - and the system showed me, that UPS has been recognized! For my UPS the current release contains a version of NUT that is capable of supporting UPSes running Blazer_usb protocol. And I checked: I disconnected power plug on UPS and got correct messages.


It's that simple, when you do things right ... okay, to be honest: many, many, many thanks to trantor, who did a phenomenal job!

Link to comment
Share on other sites

  • Create New...