Sign in to follow this  
alexvd

5.2 5592 upgrade/migrate fail-- SOLVED

Recommended Posts

Hello I was running xpenology 4.3 via gnoboot on ASROCK C27540DL OctaCore beautifully for over 1 year. This was an upgrade from an original synology rackmount.

 

I tried to upgrade to 5.2 5592 doing the same process of creating a usb boot disk XPEnoboot_DS3615xs 5.2 5592.2.img rebooted the server and booted from the usb stick than used synology assistant to manually install the DSM_3615xs_5592.pat file. It performed the install and than rebooted the server into DSM. Synology assistant said it was preparing the Synology server and it would take 10 minutes. However it never returned to the DSM web login. If I try to login via web interface it says connecting and than just hangs at white blank screen. Synology assistant no longer can find the synology server. I can login to server and see that all my files and data are intact. It appears I just have an incomplete upgrade/migration.

 

Any help would be greatly appreciated.

Edited by Guest

Share this post


Link to post
Share on other sites

Please help!!! I use this server for my plex to watch TV and my whole family cannot watch shows!!!

 

I have tried several workarounds. The ipv4 configuration and setting the address to manual.

 

I saw that my motherboard has known issues with upgrades to 5.1 and beyond with the SATA. So i changed it to IDE.

 

Nothing works.

 

I see one message in the boot screen that says

 

Partition Version=0

Partition Layout is not Diskstation style.

 

Aside from that I see the last message is ===== trigger device plug event========

login:

 

When i try to access via webbrowser it just hangs at connecting

Share this post


Link to post
Share on other sites

You need to connect your PC to a monitor and log in as root. Try your old password. If that doesn't work, you can try the default password that is generated by Synology. You will have to look on the web since you need to generate this password. I do think it's specific to date.

Once you get into your box, you can try to troubleshoot what doesn't work and why.

 

If all else fails, the priority is to get access to your data. Install a clean Ubuntu on another PC. Once that's done and you have installed the dm-raid tools as well, try hooking up your DSM drives IN ADDITION TO your ubuntu drive and see if ubuntu wants to see the data on it.

 

Do NOT reinstall, initialize, basically everything that wants to do something permanent to your drives.

If you have PLENTY storage on another PC, make disk dumps (dd and ddrescue) which you can use to mount your drives.

 

Sorry I can't help you more than this, but it will give you a starting point.

Share this post


Link to post
Share on other sites

Hi thanks for the reply.

 

Yes I already connected directly to the server with a monitor and keyboard and can login successfully.

 

I can login with no issues using my admin credentails. I can also see all my data and shares.

 

I believe my issue could have been related to a degraded disk previous to the upgrade. I saw on the synology forums that the white screen login issue happened with degraded volumes. Replacing the disk and than allowing it to rebuild seemed to fix the problem. I bought new hard drives and replaced them in the NAS one by one but it didnt seem to rebuild the SHI.

 

Unfortunately I cannot copy all of my data out to another machine as its 6TB. I dont have anywhere near that storage on any other machines. I would have to buy more drives or copy off to a cloud backup somewhere.

 

The issue I would like to solve is how to do a manual reinstall of DSM without Synology Assistant. How can I reinstall the .pat manually via cli The box is on the network.

Share this post


Link to post
Share on other sites

All after reading through some posts. I followed the process of removing all hard drives than reboot which allowed me to reinstall DSM from the web interface. I than removed the failed drives and was able to reinstall/upgrade to 5.2. I did lose my configuration ( I could have restored but I chose not to) but all my data was intact.

Share this post


Link to post
Share on other sites

Hi,

 

Hope I'm not hijacking your thread, but I've been looking at this for ages and cannot find a definitive way to upgrade from 4 to 5. Can you tell me what you did? I really dont want to risk losing the data.

 

Any help much appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites
Sign in to follow this