Обновился до DSM 6.2.4-25556 и что-то пошло не так


Recommended Posts

Если Вы обновились до 6.2.4-25556 (в теории можно откатываться и с других версий) и поняли что перестала работать сеть. То скорее всего единственное что поможет - откатиться на прошлую версию.

 

Сделать это можно вот так.

 

1) На флешке в разделе который сразу монтируется, удалить все кроме extra.lzma. Залить туда zImage и rd.gz из  DSM_DS3615xs_25426.pat (если у Вас DS3615xs)

2) Скачать последнюю ubuntu и залить ее на usb (инструкция даже на официальном сайте есть)

 

В загрузившейся ОС (в терминале)

 

sudo -i

 

apt-get install mdadm lvm2

 

mdadm -Asf && vgchange -ay

 

mount /dev/md0 /mnt

 

rm -rf /mnt/SynoUpgradePackages
rm -f /mnt/SynoUpgrade.tar
rm -f /mnt/SynoUpgradeindex.txz
rm -f /mnt/SynoUpgradeSynohdpackImg.txz
rm -f /mnt/checksum.syno
rm -f /mnt/.syno/patch/*
rm -f /mnt/etc/VERSION
rm -f /mnt/etc.defaults/VERSION

 

shutdown -h now

 

После загрузки - восстановить с DSM_DS3615xs_25426.pat (если у Вас DS3615xs)

 

 

Немного подробнее есть еще тут:

 

 

 

 

Edited by ADMiNZ
  • Thanks 2
Link to post
Share on other sites

Человек тут всего лишь выложил краткую инструкцию, поделился способом восстановления работоспособности после допущенной ошибки. И за это ему спасибо.

А не ошибаются только те, кто ничего не делает ....)))

Link to post
Share on other sites
19 часов назад, i926 сказал:

Человек тут всего лишь выложил краткую инструкцию, поделился способом восстановления работоспособности после допущенной ошибки. И за это ему спасибо.

А не ошибаются только те, кто ничего не делает ....)))

Значит такие темы надо в FAQ поднимать

Link to post
Share on other sites
3 часа назад, sir.ali сказал:

Значит такие темы надо в FAQ поднимать

Согласен полностью. Но увы, нет у простого пользователя инструментов по перемещению в FAQ, есть только у Админов. А у них своё понимание что есть FAQ, а что нет.

Вроде бы злободневная тема, вроде бы её и надо выделить, но.... Так они, темы эти и будут по форуму гулять

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 1 month later...

Всем добрый день.

Как и все нетерпеливые имел удовольствие обновиться до 25556 (((((

В тот момент еще не было каких-либо решений и было принято решение для начала удалить первые сектора с дисков (RAID 5 на 5х2Т), но что-то пошло не так и были удалены еще и вторые..... Попытка восстановить данные с помощью разных утилит не удалась.

Воспользовавшись инструкцией из поста Ошибочное обновление на версию 6.2.4. Откат на раннюю версию DSM. Восстановление после утери пароля. узнал что при обновлении был включен кэш SSD (вроде RAID1 2x110G) и имеем следующее состояние как на скрине. SSD диски подключить не дает, висят просто как инициализированные((((

 

Возможно ли восстановить информацию и в какую сторону копать. 

Буду благодарен за подсказки.

 

Synology SSD кэш.JPG

Synology SSD кэш2.JPG

Edited by Alexss
Link to post
Share on other sites
1 час назад, Alexss сказал:

и было принято решение для начала удалить первые сектора с дисков

Не удалить, а Форматировать. Это и есть ошибка ваша

 

Link to post
Share on other sites
32 минуты назад, i926 сказал:

Не удалить, а Форматировать. Это и есть ошибка ваша

 

Сори - не корректно написал, физически было форматирование. Но вся засада в том что не отключил кэш на ssd - вот на его отсутствие сейчас система и ругается, а автоматом не подхватывает подключенные диски SSD. Запуск восстановления настроек из ранее сохраненных тоже не проходит корректно - так как не может получить доступ к Разделу(((((

Link to post
Share on other sites

А по сети файлы не видны ?

У меня как то сбой системного раздела был, система не грузилась, но по сети видны были файлы. Так и скопировал их

А вот по Кэшу не скажу....

Link to post
Share on other sites
8 минут назад, i926 сказал:

А по сети файлы не видны ?

У меня как то сбой системного раздела был, система не грузилась, но по сети видны были файлы. Так и скопировал их

А вот по Кэшу не скажу....

До такого простого способа не додумался - вечером попробую ))))

 

Link to post
Share on other sites
  • 2 weeks later...
On 4/24/2021 at 7:37 AM, ADMiNZ said:

mount /dev/md0 /mnt

 


rm -rf /mnt/SynoUpgradePackages
rm -f /mnt/SynoUpgrade.tar
rm -f /mnt/SynoUpgradeindex.txz
rm -f /mnt/SynoUpgradeSynohdpackImg.txz
rm -f /mnt/checksum.syno
rm -f /mnt/.syno/patch/*
rm -f /mnt/etc/VERSION
rm -f /mnt/etc.defaults/VERSION

для начала только надо собрать системный раздел md0 из /dev/sda1 и /dev/sdb1 (очевидно, что для случая массива из дисков), а только потом монтировать. В общем читайте англ первоисточник, по этой инструкции не восстановите :) 

Link to post
Share on other sites
для начала только надо собрать системный раздел md0 из /dev/sda1 и /dev/sdb1 (очевидно, что для случая массива из дисков), а только потом монтировать. В общем читайте англ первоисточник, по этой инструкции не восстановите  

Если массив не поврежден

mdadm -Asf && vgchange -ay

Соберёт все что надо. Если он поврежден - эта инструкция не для Вас.
Link to post
Share on other sites

Главное не форматировать не каких разделов. Особенно первого раздела кеш дисков - он там всего один :)))

Link to post
Share on other sites
Не удалить, а Форматировать. Это и есть ошибка ваша
 

Самое страшное будет когда отформатировать кеш диск или диски - первый раздел там единственный.
Link to post
Share on other sites
Posted (edited)
1 hour ago, ADMiNZ said:


Если массив не поврежден

mdadm -Asf && vgchange -ay

Соберёт все что надо. Если он поврежден - эта инструкция не для Вас.

Эта команда собрала лишь третий раздел md2.  Системный раздел md0 собрался только руками mdadm -AU byteorder /dev/md0 /dev/sda1 /dev/sdb1. Повреждений не было.

Да и тут написано, 

что команда выше лишь  раздел с данными добавляет. Что собственно и произошло.

Edited by mikhan
Link to post
Share on other sites
Posted (edited)

Нужно пробовать. У меня все смонтировал. Если не появляется тогда да руками. Это же обычный линукс. Я по этому и оставил ссылки на мануалы более полные :)  Можно и в GUI войти и там мышкой тыкнуть.

 

Главное не форматировать нечего и не стирать ни каких партиций. А то инструкция с стиранием уже много кому помогла потерять все данные полностью...

Edited by ADMiNZ
Link to post
Share on other sites
  • 3 weeks later...

Добрый день. Прошу помощи. После обновления на 6.2.4 получил кирпич и решил воспользоваться инструкцией (с форматированием первых разделов). 
У меня в хранилище был один диск на 1tb и два диска по 4tb в raid 1. 
Так вот, когда я подключил один из рэйдовых дисков к другому компу (win7 64) через usb-бокс, то диск оказался неинициализированным и на нём не было никаких разделов. Потом я диск перецепил к этому же компу, но уже по sata. Ничего не изменилось. Программой oamei partition assistant произвёл поиск разделов для восстановления. Она искала всю ночь и нашла их штук 30. Причём действительно больших среди них нет.

Остальные диски подключать опасаюсь. Подскажите плиз, что предпринять. Спасибо

Edited by Alien999
Link to post
Share on other sites
18 минут назад, Alien999 сказал:

Добрый день. Прошу помощи. После обновления на 6.2.4 получил кирпич и решил воспользоваться инструкцией (с форматированием первых разделов). 
У меня в хранилище был один диск на 1tb и два диска по 4tb в raid 1. 
Так вот, когда я подключил один из рэйдовых дисков к другому компу (win7 64) через usb-бокс, то диск оказался неинициализированным и на нём не было никаких разделов. Потом я диск перецепил к этому же компу, но уже по sata. Ничего не изменилось. Программой oamei partition assistant произвёл поиск разделов для восстановления. Она искала всю ночь и нашла их штук 30. Причём действительно больших среди них нет.

Остальные диски подключать опасаюсь. Подскажите плиз, что предпринять. Спасибо

 

  Для начала - верни все диски на место (в той же последовательности как стояли. И пробуй инструкцию которая выше (можно даже английскую).

Link to post
Share on other sites
6 часов назад, ADMiNZ сказал:

 

  Для начала - верни все диски на место (в той же последовательности как стояли. И пробуй инструкцию которая выше (можно даже английскую).

Следую по этой инструкции и сразу не получается с первым пунктом: На флешке в разделе который сразу монтируется.

Никакие разделы не монтируются. Их видно через управление дисками, но активировать их для просмотра/редактирования нельзя (букву не присвоить).

Флешку я уже создал заново следуя другой инструкции. Нужно обязательно ту, с которой произошло обновление? У меня есть её образ.

upd. С неё тоже ничего не монтируется

upd2. загрузился на NAS с ubuntu - флешка смонтировалась.

Диски тоже показались с правильным количеством разделов. Но тот, который я первым подключал к винде - по прежнему неинициализированный и без разделов. Он был в raid 1. Со вторым зеркальным диском вроде всё норм. Как мне дальше действовать, чтоб данные не потерять и raid сохранить?

Edited by Alien999
Link to post
Share on other sites
7 часов назад, Alien999 сказал:

Так вот, когда я подключил один из рэйдовых дисков к другому компу (win7 64) через usb-бокс, то диск оказался неинициализированным и на нём не было никаких разделов

 В большинстве своём, по умолчанию, Windows не имеет поддержки для чтения или доступа к разделам Ext3 или Ext4. Необходимо установить Драйвер поддержки Ext2Fsd:

Загрузить: https://sourceforge.net/projects/ext2fsd/files/Ext2fsd/0.69/

Почитать: https://linuxinsider.ru/podklyuchenie-ext4-v-windows/

Ну а по возврату в исходное состояние, то тут уже выбор за вами. По той или иной инструкции.

Link to post
Share on other sites
22 минуты назад, i926 сказал:

 В большинстве своём, по умолчанию, Windows не имеет поддержки для чтения или доступа к разделам Ext3 или Ext4. Необходимо установить Драйвер поддержки Ext2Fsd:

Загрузить: https://sourceforge.net/projects/ext2fsd/files/Ext2fsd/0.69/

Почитать: https://linuxinsider.ru/podklyuchenie-ext4-v-windows/

Ну а по возврату в исходное состояние, то тут уже выбор за вами. По той или иной инструкции.

Спасибо. Про драйвер учту. Сейчас вопрос как инфу сохранить с диска, который был в рейде и не показывает разделы нигде...

Есть ли средства восстановления разделов диска после ошибочной инициализации в другой среде?

 

Или прокатит такая штука: я по инструкции восстанавливаю хрень, но без ошибочного диска. Второй из зеркала то жив. Можно будет потом уже средствами хрень восстановить рейд из второго диска?

Edited by Alien999
Link to post
Share on other sites

Начните с Драйвера, ну а далее... Попробуйте по инструкции:

В качестве примера. Очередное удачное восстановление по этой инструкции

 

Link to post
Share on other sites
15 минут назад, i926 сказал:

Начните с Драйвера, ну а далее... Попробуйте по инструкции:

В качестве примера. Очередное удачное восстановление по этой инструкции

 

Мне драйвер уже неактуален. Я все разделы увидел под убунтой. У меня есть три диска, на двух из которых я вижу разделы. А на третьем - нет. Вот в чём проблема. Я его походу испортил тем, что проинициализировал под виндой без соответствующих драйверов. 
Нечего на третьем диске форматировать

Edited by Alien999
Link to post
Share on other sites

Короч отчитываюсь

В убунте (загрузился с флешки прямо на NAS) отформатировал первые разделы у дисков (у которых они были)

Вставил флешку с новым загрузчиком и далее по инструкции

После загрузки системы массив рейд был повреждён и предложил его восстановить за счёт пустого диска

Всё

Всем спасибо за помощь)))

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.