MrBrightside

[SOLVED] Help editing isolinux.cfg in XPEnology iso on OSX

Recommended Posts

Hi Everyone,

 

I'm running XPEnology in a Hyper-V virtual machine very successfully and I'm trying to update to the latest bootloader.

 

I'm trying to update the XPEnoboot_DS3615xs_5.2-5592.2.iso file to modify the isolinux.cfg to include rmmod=ata_piix.

I'm using OSX and have spent four hours this afternoon trying to rebuild the ISO after making this simple change. The most success that I've had is with this guide http://sloblog.io/~epirat/5ZU-qNy8_To/m ... age-mac-os but I get an isolinux checksum error on boot.

 

I've also tried editing the IMG file and converting that to an ISO but it gets recognised as a corrupted volume on boot.

 

Any assistance would be greatly appreciated.

 

Thanks.

 

Update: as a last hail-mary, I looked around on some mkisofs mailing lists and constructed the following command which actually worked!

mkisofs -o XPEnoboot_DS3615xs_5.2-5592.2_diskpatch.iso -b isolinux.bin -c boot.catalog -no-emul-boot -boot-load-size 4 -joliet-long -boot-info-table image_folder

Hope this helps someone!

Share this post


Link to post
Share on other sites