Cannot Not Load DSM in Browser After Power Cycle (DSM 6.1.7 Bootloader 1.2b on ESXI 6.0)


Recommended Posts

I'm having a very similar problem to that from this topic.  I responded to that thread but was directed to start a new one, I hope this is the right place for this.

 

I have a custom built NAS box that I built a few years back using ESXI 6.0 and DSM 5.x.  Ran fine, but the Plex package for it no longer supports DSM5.x so I needed to upgrade.  I tried using the DSM6.2 and Jun's bootloader 1.3 and could never get the virtual machine to boot properly.  In the WebSphere console window, I'd see the splash screen and nothing would happen after that.  So I went to DSM6.1.7 and bootloader 1.2b and this seemed to work.  This was on a new VM, nothing from the DSM5 was reused except that my raid card is set to PCI passthrough so that my storage disks were the same.  But the virtual disk that DSM runs in is completely new.  Everything worked fine, I could browse into DSM, I installed the latest Plex server, installed the Ubiqiti package, and all looked good... until the first power outage.  When the unit came back up, all of the shares appeared correctly, Plex loaded properly, I can SSH into the box just fine, but I cannot access DSM via the browser.   I try starting nginx manually, and it fails as well.

 

This site can’t be reached192.168.254.120 refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

 

Here's my DSM VERSION file.

 

root@WormNAS:~# more /etc.defaults/VERSION 
majorversion="6" 
minorversion="1" 
productversion="6.1.7" 
buildphase="GM" 
buildnumber="15284" 
smallfixnumber="3" 
builddate="2018/12/26" 
buildtime="08:39:07"

 

I can try starting nginx manually, but it does not, and I see the error below in the error log.

 

2020/11/06 09:05:00 [emerg] 17636#17636: socket() [::]:5000 failed (97: Address family not supported by protocol)

Everything I can find about this error says that IPV6 is either not enabled or not working.  I can't find where to fix IPV6, or better yet since I'm not using it, disable it, so that whichever script keeps putting the...

listen [::]:5000 default_server;

... lines into /etc/nginx/nginx.conf would stop doing that.  

 

You can edit that line out of the various server sections, but as soon as you try to restart nginx, it comes back and nginx fails to start again.  Very frustrating.

If anyone has any idea of how I can recover this, using just SSH I'd appreciate it.  I could always reinstall everything from scratch in a new VM if I needed to, but I'd also like to be able to ensure it wouldn't happen again on the next power cycle.

 

Alternatively, if anyone has tips on DSM6.2 and bootloader 1.3, I could try that route again.  I spent four hours trying last time with no luck, when 6.1.7 and 1.2b worked in about five minutes, but if that config is preferred, I'd like to know how to make it work as well.

 

If I haven't provided enough info, let me know.

 

Thanks,

  Jeff

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.