Recommended Posts

Hello guys, 

recently i had problems expanding the storage so I thought i would share the steps how i solved it. For some it might be too detailed but for noobs like me it might be usefull :1_grinning:

 

machine:

HP Gen8 Pentium G1610T, baremetal. Originaly 3x 2TB drives (WD Red), SHR single array with single volume

 

I was really running out of space and with only 2% free left i figured I would just drop in another 4TB disk. I know that according the syno raid calculator there will be 2TB wasted, but in future i will echange one 2TB for 4TB and use all the space... Anyway, after inserting the new disk and booting the machine I expanded the raid group with no problem. Here i thought the hard part is over, but boy how i was mistaken. Even though raid array expanded to 5,5TB, the volume refused to expand with "Volume failed to expand" message and no better info in the logs, staying at 3,5TB. I thought there might be problem with only 20GB of free space, so I erased some stuff and made cca 500GB of free space, but no improvment and still unable to expand the volume. Turning the services in gui and restarting also didn't help.

 

Long story short here are the steps how I solved it:

1) Login to machine and turn off all the services in GUI except SSH

 

2) Login to SSH as an admin user (you can’t really use root on DSM6 anymore!)

sudo syno_poweroff_task -d

-d flag is important as it will keep the SSH enabled. It ussualy terminated my ssh session (even thou many guides says it doesn't), so after that just open new one and login as admin.

 

3) If you run mount or df now, you will see the volume is still mounted, this is because your SSH login is holding it open

example:

Quote

admin@karkulka:~$ df
Filesystem      1K-blocks       Used  Available Use% Mounted on
/dev/md0          2385528    2083240     183504  92% /
none              2002732          0    2002732   0% /dev
/tmp              2008004        580    2007424   1% /tmp
/run              2008004       3092    2004912   1% /run
/dev/shm          2008004          8    2007996   1% /dev/shm
none                    4          0          4   0% /sys/fs/cgroup
cgmfs                 100          0        100   0% /run/cgmanager/fs
/dev/vg1000/lv 5754154560 3327282084 2426753692  58% /volume1

note the /dev/vg1000/lv adress is the /volume1, I will use it in a moment

 

4) So lets unmount the volume. 

sudo umount --lazy /volume1

NOTE: the volume location/adress might be different depending on your machine/setup, just check your df output

 

5) Close your SSH session – this will allow the lazy unmount to take place

6) Login to SSH as an admin user again – it will complain it can’t mount your user home folder – which is fine, we don’t need it

7) Check vgdisplay - it will show you everything regarding the volumes (physical / logical)

sudo vgdisplay -v

In my case the LV was already enlarged to 5,44TB and VG was also 5,44TB. Therefore expanding the storage through GUI made it this far. Only thing I need is to resize the filesystem on top of those.

 

8) Check the fs for errors

sudo e2fsck -f /dev/vg1000/lv

note: I am not sure if that is mandatory, but it doesn't hurt to check. It takes some time to execute so don't be alarmed

note2: the adress /dev/vg1000/lv - is that output from df in step 3). It might be different for you

 

9) Resize the fs

sudo resize2fs /dev/vg1000/lv

Again it will take some time, but once completed i had finaly expanded the volume.

 

10) Final step is to reboot

sudo reboot

Now you just have to turn on all the services in the GUI you turned off in step 1) 

 

 

Its a pitty that GUI doesn't tell you what is wrong so i hope this will help somebody in the same situation and save him long hours on research.

I have noticed similar guides here on forum, but all of them were for VM like ESXI and i am not sure how much different from baremetal that is.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.