Jump to content
XPEnology Community

Atheros Alt1c.ko


tomkoval
 Share

Recommended Posts

Hi All

 

Been here a while but first time I need help with Xpenology.

Got already Netgear and Asus DiskStation converted to xpenology with Loader 6.2 and they work perfect.

 

But I have issue with something not really NAS area.

I got damaged Asus AspireONE Laptop and since got one 2TB 2.5 inch drive lying around decided to give it a try.

I got loader from https://xpenology.com/forum/topic/7848-links-to-loaders/

Jun's loader v1.02b DS3615xs

Laptop boots from usb fine but that's all no network connection.

 

No led activity on NIC, router can't see any connection on port connected.

 

I know that was discussion about Atheros Alt1c.ko before and it is included in above loader, so all looks ok but still no connection what so ever.

Ubuntu boots fine and with network access, here is ifconfig output:

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

3:00.0 Ethernet controller: Qualcomm Atheros AR8132 Fast Ethernet (rev c0)
    Subsystem: Acer Incorporated [ALI] Device 022f
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 29
    Region 0: Memory at 95000000 (64-bit, non-prefetchable)
    Region 2: I/O ports at 2000
    Capabilities: [40] Power Management version 3
        Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
        Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [48] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Address: 00000000fee0300c  Data: 4162
    Capabilities: [58] Express (v1) Endpoint, MSI 00
        DevCap:    MaxPayload 4096 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
            ExtTag- AttnBtn+ AttnInd+ PwrInd+ RBE+ FLReset- SlotPowerLimit 6.500W
        DevCtl:    Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
            RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
            MaxPayload 128 bytes, MaxReadReq 512 bytes
        DevSta:    CorrErr+ UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
        LnkCap:    Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 unlimited
            ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp-
        LnkCtl:    ASPM L1 Enabled; RCB 64 bytes Disabled- CommClk+
            ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
        LnkSta:    Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    Capabilities: [6c] Vital Product Data
pcilib: sysfs_read_vpd: read failed: Input/output error
        Not readable
    Capabilities: [100 v1] Advanced Error Reporting
        UESta:    DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
        UEMsk:    DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
        UESvrt:    DLP- SDES+ TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
        CESta:    RxErr- BadTLP- BadDLLP+ Rollover- Timeout- NonFatalErr-
        CEMsk:    RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
        AERCap:    First Error Pointer: 14, GenCap+ CGenEn- ChkCap+ ChkEn-
    Capabilities: [180 v1] Device Serial Number ff-13-c2-07-00-26-22-ff
    Kernel driver in use: atl1c
    Kernel modules: atl1c


eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:26:22:13:c2:07  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

In GRUB shows both cards as well:

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

01:00.0 168c:001c  Ethernet controller 

03:00.0 1969:1062  Ethernet controller 

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

So in theory all good and it should work.

Tried different usb sticks and usb ports but still the same.

I tried adding extra.lzma file but first of all that drive is already included and no difference.

 

Any help welcome.

 

Tom

 

Edited by tomkoval
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...