Jump to content
XPEnology Community

FFMPEG issue


Recommended Posts


I installed gnoboot 10.5 and dsm 5 update 2, all works great but I have 1 problem, I cannot convert video with ffmpeg in command line. With dsm 4.2 conversion worked great.


nas> ffmpeg -i test.avi test.mp4

ffmpeg version 2.0.2 Copyright © 2000-2013 the FFmpeg developers

built on Feb 22 2014 02:33:33 with gcc 4.6.3 (crosstool-NG 1.17.0)

configuration: --prefix=/usr/syno --incdir='${prefix}/include/ffmpeg' --arch=i686 --target-os=linux --cross-prefix=/usr/local/i686-pc-linux-gnu/bin/i686-pc-linux-gnu- --enable-cross-compile --enable-optimizations --enable-pic --enable-gpl --enable-shared --disable-static --enable-version3 --enable-nonfree --enable-libfaac --enable-encoders --enable-pthreads --disable-bzlib --disable-protocol=rtp --disable-muxer=image2 --disable-muxer=image2pipe --disable-swscale-alpha --disable-ffserver --disable-ffplay --disable-devices --disable-bzlib --disable-altivec --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libmp3lame --disable-decoder=amrnb --disable-encoder=zmbv --disable-encoder=dca --disable-encoder=ac3 --disable-encoder=ac3_fixed --disable-encoder=eac3 --disable-decoder=dca --disable-decoder=eac3 --disable-decoder=truehd --cc=/usr/local/i686-pc-linux-gnu/bin/i686-pc-linux-gnu-ccache-gcc --enable-yasm --enable-libx264 --enable-encoder=libx264


Stream #0:0 -> #0:0 (mpeg4 -> libx264)


Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height



So when I want to watch a video in video station with mpeg4 format, it doesn't play 'cause DSM can't transcode it. Do you have the same problem ?


Thanks for your help

Link to comment
Share on other sites

  • 2 weeks later...
  • 10 months later...
  • Create New...