d0x7

AMD SVM Module and USV Support?

Recommended Posts

So hello there,

 

tl;dr; AMD Box, successfully upgraded to DSM 6.1 using v1.02b. Can't use VMM because AMD SVM isn't supported by synology kernel. How do I recompile with the corresponding module? Also, how's the USV support in 6.1 on AMD? I heard USV's are not supported or not working as the should? Can you confirm this? If so, is there a fix available?

 

I've been running my custom build Xpenology NAS for around 8 months now. 

Everything worked pretty well as of now.

 

Specs:

 

AMD 5350

16 GB DDR3

Some ASUS Motherboard (don't know the exact name, probably the AM1M-A)

Four HGST 4 TB Drives in RAID6, one Intenso 120 GB SSD as a cache and one old WD Blue 1 TB in RAID0 for movies and tv shows

Syba PCIe SATA Controller with four Ports

 

The problem(s) begun around a week ago. First of all my usb drive got somehow damaged by a power outage (don't ask me how I managed that, really. I didn't do anything, well expect for the power outage and after that my nas felt somehow pretty dead. Not booting or anything else). So yeah, I replaced the usb drive and dedicided to upgrade to DSM 6.1 because I'd like to use moments and VMM (prior I had DSM 6.0.2 or so?). I was pretty exited when everything worked complety "out of the box". I thought I had to reinstall and migrate to DSM 6.1, but no, nothing. Just plugged it in and I could instantly went to DSM Desktop and yeah.

 

So, everything worked pretty well expect for a few things which are broken now.

 

GitLab don't like me anymore. It does not start, the log says "configuring database" and after that it stops. Obviously there's an issue with the database but I'm going to fix that by myself.

 

I also only had 2 GB of RAM to use, the other 14 gigs were reserved but I solved it by adding 'disable_mtrr_trim' to the grub.cfg.

 

As I said earlier I want to use VMM but I have an AMD box. From what I heard the synology kernel does not come with AMD SVM compiled, so I can't use VMM with AMD. I don't know how to recompile the kernel with that module and I also didn't find anything useful on the forums. Any advice, clue or idea?

 

I'm also planning on buying a USV, more exactly an APC USV, the one with 700VA and I guess 480 watts. From my calculation it'll be enough power to power the NAS at 50 watts consumption for around 30 minutes, is that right? But from I read is that the current version of the loader does not support USV for AMD boxes, is that right or is there any way to fix that?

 

Kind regards,

Dorian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now