Recommended Posts

Установка DSM 6 на Proxmox

Создаем VM   со следующими параметрами

Номер VM 101

DISK raw 

 

5a6f222e4697f_2018-01-2916_30_37.thumb.png.f833039b3004ba9ab66e2eafc45c6dee.png5a6f222942125_2018-01-2916_30_47.thumb.png.60bcb1d51144c4cd9d8b31cc634e6310.png

Получаем начало блока EFI : fdisk -lu synoboot.img
Монтируем : mount -t auto -o loop,offset=[начало_блока  * 512] synoboot.img /mnt/tmp
рекадктируем файл grub
Заменяем данные VM диска  : dd if=synoboot.img of=/dev/pve/vm-100-disk-1

Запускаем find.synology.com и устанавливаем  DAT

Link to post
Share on other sites
  • 1 month later...
  • 9 months later...
В 29.01.2018 в 16:31, roysbike сказал:

Монтируем : mount -t auto -o loop,offset=[начало_блока  * 512] synoboot.img /mnt/tmp

Вот никак не могу въехать в тему. Как выполнить монтирование этого устройства? При попытке выполнить команду впрямую выдает ошибку что не найден путь в Fstab. Автомонтирование если я правильно понял ключ -auto предполагает запись в этот команды в этот файл, но как это сделать мне не понятно. Я понимаю что скорее всего вопрос чайника, но уж больно хочется разобраться в теме. 

Link to post
Share on other sites

Все, вопрос снялся. :) Путем долгих поисков и размышлений. 

Однако возник другой. Что править в Grab файле? Боюсь что тут без помощи уже никак. :(

Edited by Валерий
Link to post
Share on other sites
6 часов назад, Валерий сказал:

Все, вопрос снялся. :) Путем долгих поисков и размышлений. 

Однако возник другой. Что править в Grab файле? Боюсь что тут без помощи уже никак. :(

 

6 часов назад, Валерий сказал:

Все, вопрос снялся. :) Путем долгих поисков и размышлений. 

Однако возник другой. Что править в Grab файле? Боюсь что тут без помощи уже никак. :(

Все просто. Боятся нечего, вы же правите img виртуалки.  Вы когда примонтировали img  , то увидите файл и что править. Указываете mac адрес тот который будет в Proxmox. Генерите S/N. Пришлите скриншот grub, я покажу что изменить 

Edited by roysbike
Link to post
Share on other sites

Попробовал подставить значения в поля которые там ссылаются на МАК адрес и серийный номер (SET mac1= и SET sn=), скопировал диск (как указано в инструкции), но при запуске почему то не находит загрузчик. :( Пишет что ничего не находит, как будто пустой диск. 

boot.jpg

Edited by Валерий
Link to post
Share on other sites

Так, с этим вопросом тоже разобрался. :)  Я бестолковка не тот диск переписывал.

Но вот теперь начались проблемы. После загрузки последней версии происходит хрень. Инсталляция проходит, после перезагрузки почему то опять загружается загрузчик с инсталлятором и доступ по сети я уже не имею. Скрин шот консоли VM. Может это быть из-за серийного номера, или может требуется ДВЕ сетевые карты как прописано у вас? Я пока прописал только одну.  

после установки.jpg

Link to post
Share on other sites

Небольшая поправка. При выборе пункта меню при старте VM настройка то все становится доступно по сети как и при инсталляции, но после восстановления опять доступ пропадает, как будто в сети машины просто нет, хотя консоль показывает картинку что ядро загружено (см скриншот выше). 

Link to post
Share on other sites

А может кто-нибудь присоветовать какую пару лучше брать загрузчика и PAT, версию процессора я так понимаю лучше брать 3615 , поскольку она уже имеет кучу приблуд, или все таки по новее что-нибудь?

Link to post
Share on other sites
  • 2 months later...

Кто знает, почему в биосе не сохраняются изменения? 

Вторая проблема, выбираю Install в момент загрузки с qemu usb, но машина моментально выключается.

Делал по этой инструкции https://www.uxora.com/other/virtualization/53-install-xpenology-dsm-6-1-x-on-proxmox

Link to post
Share on other sites
  • 1 month later...

Есть Proxmox 5.4, пробую ставить по инструкции с загрузчиком Jun's Loader v1.03b DS3615xs

При первой загрузке  могу найти сервер в системе, предлагает установить DSM, при этом удалит все с дисков 1 и 2, соглашаюсь, он скачивает устанавливает образ, при перезагрузке сервера в сети нет (загрузочный диск затерся, как и предупреждал установщик)

 

Настраиваю заново, при первой загрузке в меню загрузчика выбираю 3й пункт, сервер виден в сети, но при попытке установки DSM, не может найти диск, куда ставить систему.

 

Ставлю впервые, форум весь перечитал, не понимаю, что не так делаю. Помогите советом.

grub.png

vm.png

setup.png

Link to post
Share on other sites

Пробую также Jun's Loader v1.04b DS918+

в этом случае он видит диски, но в обоих случаях (1й пункт grub или 3й пункт) предлагает перед установкой удалить данные с дисков 1 и 2.

Я так понимаю, т.к. ставлю на виртуалку, необходимо выбирать 3й пункт (DS918+ 6.2./6.2 VMWare/ESXI with Jun's Mod v1.04b) даже если гипервизор Proxmox, верно?

Что делать ума не приложу. Очень прошу вашей помощи.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.