Asus H87I-PLUS WOL


Recommended Posts

I use a Asus H87I-PLUS Mainboard and the last xpenology 4.3

I have a problem if i use the WOL function

After shutdown from WebInterface the system goes down and after 1-2 second it start again.

Any people see the same ?

Is this a driver problem ?

thanks for feedback

 

Jordanie

Edited by Guest
Link to post
Share on other sites
  • 4 weeks later...

I have the same hardware and the same problem. In order to support WOL, the Asus H87I-Plus requires an option set in the BIOS (Onboard>APM>Power on by PCIE). When I have this enabled, I can indeed start the machine using the wol magic packet, but there is an undesired side-effect: when I shutdown the machine, it stays shut off for about 5 sec and then turns back on all by itself. If I disable the option in the BIOS, this does not happen... but I am unable to use wol.

 

Can you post the output of ethtool eth0 for me? Here is the output of my command:

% sudo ethtool eno1
Settings for eno1:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 2
Transceiver: internal
Auto-negotiation: on
MDI-X: on (auto)
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000007 (7)
		       drv probe link
Link detected: yes

Link to post
Share on other sites

here my output:

 

Settings for eth0:
       Supported ports: [ TP ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Full
       Supports auto-negotiation: Yes
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Full
       Advertised auto-negotiation: Yes
       Speed: 1000Mb/s
       Duplex: Full
       Port: Twisted Pair
       PHYAD: 2
       Transceiver: internal
       Auto-negotiation: on
       Supports Wake-on: pumbg
       Wake-on: g
       Current message level: 0x00000007 (7)
       Link detected: yes

 

In moment i test it by the XPE Beta 5.0 without any changes .....only set the right MAC adress in the vendor file and WOL is working

My first posting was tested with XPE 4.3

Link to post
Share on other sites

Wish I had some insights into the lack of functionality on my box. I am not running XPEnology... the OS is Linux and my distro is Arch. I can confirm this behavior if I boot to the latest Ubuntu 13.10 live media and shutdown from there so I'm thinking it is not OS-related.

Link to post
Share on other sites
  • 3 weeks later...

That board uses the i217 lan controller...

 

not sure if those drivers are in any version here.

 

for drivers that do work

 

the way to get WOL working is

 

edit the following files

 

/volume/USB1/usbshare/boot/grub/grub.conf

 

change like so

 

#serial --unit=0 --speed=115200

#terminal serial

default 0

timeout 3

fallback 0

 

title DSM 4.3-3810 - v1.1 Beta 5

root (hd0,0)

# vender /vender show

# hw_model

kernel /zImage root=/dev/md0 ihd_num=0 netif_num=3 syno_hw_version=DS3612xs mac1=001F295521AE mac2=001F295521AF mac3=28924A2B052A sn=B3J4N11333

initrd /rd.gz

 

that is, change the number of lan interfaces to the number you have and change the MAC Addresses to your REAL MAC Addresses

 

then

 

edit these two files

 

/etc.defaults/synoinfo.conf

/etc/synoinfo.conf

 

Change any lines relating to your REAL lan interfaces (in my example above I change 3 interfaces (eth0 eth1 eth2) and also the WOL setting

 

from

eth0_wol_options="d"

eth1_wol_options="d"

eth2_wol_options="d"

wol_enabled_options="g"

 

to

 

eth0_wol_options="g"

eth1_wol_options="g"

eth2_wol_options="g"

wol_enabled_options=""

 

and reboot

 

see how that goes

Link to post
Share on other sites

Hello stanza,

I use the Asus H87I-Plus too and I am happy about this discussion. I edited already your suggested grub.conf

1) but can't find any syninfo.conf. Where should I look for??

2) how can I use the ethtool in a xpnology world??

 

Thanx in advance for any advice

Joachim

Link to post
Share on other sites

stanza wrote:

edit the following files

 

/volume/USB1/usbshare/boot/grub/grub.conf

 

change like so

 

#serial --unit=0 --speed=115200

#terminal serial

default 0

timeout 3

fallback 0

 

title DSM 4.3-3810 - v1.1 Beta 5

root (hd0,0)

# vender /vender show

# hw_model

kernel /zImage root=/dev/md0 ihd_num=0 netif_num=3 syno_hw_version=DS3612xs mac1=001F295521AE mac2=001F295521AF mac3=28924A2B052A sn=B3J4N11333

initrd /rd.gz

 

that is, change the number of lan interfaces to the number you have and change the MAC Addresses to your REAL MAC Addresses

 

then

 

edit these two files

 

/etc.defaults/synoinfo.conf

/etc/synoinfo.conf

 

Change any lines relating to your REAL lan interfaces (in my example above I change 3 interfaces (eth0 eth1 eth2) and also the WOL setting

 

from

eth0_wol_options="d"

eth1_wol_options="d"

eth2_wol_options="d"

wol_enabled_options="g"

 

to

 

eth0_wol_options="g"

eth1_wol_options="g"

eth2_wol_options="g"

wol_enabled_options=""

 

and reboot

 

see how that goes

 

Hello stanza,

I use the Asus H87I-Plus too and I am happy about this discussion. I edited already your suggested grub.conf

1) but can't find any syninfo.conf. Where should I look for??

2) how can I use the ethtool in a xpnology world??

 

An addition to the above questions I realize,

3) that my NAS always gets another MAC adress in the Synology Assistant after new booting and

4) the NAS starts by its own at 1:00 a.m. without any scheduled start up (at first I thought it starts, when my other NAS got Power Off - both are connected to the same switch- but it is still 1:00 a.m. Power On when I change the Power Off in the other NAS)

5) the scheduled Power Off is working but no scheduled Power On

 

Thanx in advance for any advice

Joachim

Edited by Guest
Link to post
Share on other sites
Hi, I have the same motherboard of you.

I had installed xpenology into virtualbox.

Do you have the SMART status working?

I have the same mobo, but don't use virtualbox.

I can confirm the SMART status working.

Link to post
Share on other sites
  • 2 weeks later...
stanza wrote:
edit the following files

 

/volume/USB1/usbshare/boot/grub/grub.conf and two others

 

Hello,

 

1) Unfortunately nobody reacted on my questions so far.

2) Meanwhile I made the WOL functioning with Magic Packet (I added the suggestions from Stanza for the two other files - which I could not found anywhere - into the grub.conf file.

3) Meanwhile I get a stable MAC adress from my NAS

4) I have still the problem with the power-on/off schedule: System shuts down but do not start on a scheduled time.XXXX At this moment, I got the system starting by a scheduled time..... So the point should be solved....

5) the NAS starts by its own at 1:00 a.m. without any scheduled start up (I can't find any time schedule in the BIOS either) This phenomenon is vanished after deactivating RTC in the BIOS

 

6) I can't get Internet access to the fileserver. If I enter the specific Internet adress in Firefox (which I have noted in the DSM) I get my older Synology-DiskStation. In the port forwarding in my router I noted "intern = 80, 5000" and "extern = 80,5000" for my 1st Synology-NAS and for the new SynNAS I note "intern = 81,5001" and "extern = 81,5001" (I can not enter the same ports for both different NAS) The Internet access on my old SynNAS (a DS211j) works perfectly (as file and as web server).

This problem is solved too. I get the Internet access to all of my 3 NAS!

7) I bought a 3rd SynNAS (DS214+), which is waiting for installation (as web and file server). I hope, that I get the 2nd device going before.

 

 

Thanx in advance for any advice

Joachim

 

I uploaded the grub.conf file for any check up But the extension TXT and CONF is not allowed. What is allowed????

(motherboard = ASUS H87I-Plus with Intel i217 Gigabit-LAN onboard and

XPNology Version 5.0-4418 with the Hardware definition DS3612xs and SN B3J4N00310

Router = EasyBox 903 from Vodafone/Firmware Version 30.05.714)

Edited by Guest
Link to post
Share on other sites

 

Hello stanza,

I use the Asus H87I-Plus too and I am happy about this discussion. I edited already your suggested grub.conf

1) but can't find any syninfo.conf. Where should I look for??

 

An addition to the above questions I realize,

3) that my NAS always gets another MAC adress in the Synology Assistant after new booting and

 

Thanx in advance for any advice

Joachim

 

/etc.defaults/synoinfo.conf is the location

 

as for 3/

 

Gets a new Mac Address ?? do you mean a new IP Address every boot?

Link to post
Share on other sites

Hello stanza,

many thanx for your reply.

I am pretty successful meanwhile: See my post from yesterday above.

 

ad 1) I could not find any syninfo.conf on my boot-stick, so I integrated your proposal in the grub.conf and it worked too.

ad 3) I have no longer different MAC adresses in response opening the Synology Assistant Search

 

At least I am fighting with the Internet access to my new NAS (see post from yesterday)

1) I operate a Synology DS211j NAS successfully with Internet access (file -and webserver)

2) The router does not allow the same ports for different IP-adresses (so I use 80,5000 for the 1st NAS and 81,5001 for the 2nd NAS)

3) In the DSM/Systemcontrol for the 2nd NAS I am not allowed to enter another figure than 5000 for the http job

Link to post
Share on other sites

My nas is working on mobo Asus H87I-Plus just fine. But as you know, setup of the "scheduled Power Off" is working but it NEVER works on "scheduled Power On" even the Nas is now working on its REAL mac address. :sad:

Can you guys please provide any possible/ potential solutions? Thank you.

I much appreciate it.

Link to post
Share on other sites
  • 1 year later...

An update: this is a BIOS bug but there is a work-around. I have been testing several systems (Z77 and H97-based) after I disabled all references to 'xHCI' as it pertains to USB settings[1]. I also enabled wake on keyboard[2]. And finally, I disabled EuP 2013 which affects wattage in power off mode. For over 2 months now, I haven't observed an unintentional wake-up with 'wake on PCIe' enabled in the BIOS.

 

1a. https://communities.intel.com/message/168708

1b. https://github.com/torvalds/linux/commit/0adf7a085fae52b18202a95722fc05d644fa7a42

2. http://serverfault.com/questions/349898/wake-on-lan-with-ubuntu-causing-constant-reboots

Link to post
Share on other sites