Jump to content
XPEnology Community

Can't upgrade from DSM 5.X to DSM 6.X


Recommended Posts

Hi,

 

I need some help !

 

I've been trying tutorials on the forum here but I cannot get my Xpenology upgraded from DSM 5.2-5967 to DSM 6.X.  The only thing I can do is get a better version of DSM 5 and I can do that via control Panel on the diskStation.

 

The bootloader I am using seems to be a discontinued one - the XPEnoboot 5.2-5967.1.  Its great for getting DSM 5 installed on a Hard drive with little effort.  There seems to be the new bootloader - Jun's loader - but it doesn't boot up on my machine while the older boot loader does.  Is there an XPEnoboot for DSM 6?

 

I've tried installing DSM 6.X via control panel (and XPEnoboot 5 ). it actually installs but then get an Execution error.  I've  all the usual like correct PID/VID/Mac Address/Serial Number correct and started in debug mode but get stuck.    Synology Assistant either says suitable for migration or recoverable but I have to wipe the HD and start again.  

 

Why does the loaders not boot ? Is there not something like XPEnoboot for DSM 6?  What are your suggestions

 

 

 

Link to comment
Share on other sites

4 minutes ago, Dfds said:

For DSM 6 Most people use jun's loader, however as you have discovered it does not contain as many drivers as the 5.2 loader. In order for you to get some assistance please list the hardware you are using i.e. motherboard, network card etc.

Thanks for your reply!  I didn't know about the drivers.  I'm using an old laptop before I move to NAS hardware I'm getting.

 

Brand    HP
Item model number    DV6-6053ea
Processor Brand    Intel
Processor Type    Core i7
Processor Speed    2 GHz
Processor Count    4
RAM     8 GB
Computer Memory Type    DDR3 SDRAM
Hard Drive 100GB 
Hard Disk Technology    HDD
Additional Drives    DVD+-RW
Graphics Card Description    AMD Radeon HD 6490M

Network Card Integrated 10/100/1000 Gigabit Ethernet LAN
Wireless Type    802.11bgn, Bluetooth
Hardware Platform    PC
Operating System    Windows 10 Premium 64bit

https://support.hp.com/us-en/product/hp-pavilion-dv6-6000-entertainment-notebook-pc-series/5048664/model/5081030/document/c02800831

Link to comment
Share on other sites

41 minutes ago, sbv3000 said:

Check the bios sata mode is correctly set to ahci.

also make sure you are using a matching boot loader to the DSM - check the tutorials

 

I can't make any changes to the AHCI in the BIOS on this HP OEM laptop.  There are no options to change bar boot order, date time etc.

 

I was making sure that I had matching Bootloader and DSM but I couldn't even get the laptop to boot up, No text on screen, nothing.

 

I thought XPEnoboot 5.2 would be less advanced than Jun's loader.  

Link to comment
Share on other sites

  • 2 years later...

I have a similar issue with a Dell Laptop. Dell XPS 14Z.

I have been able to instal DSM 5.2 using XPEnoboot without any issue.

But when tried to install DSM 6 using Jun's bootloader I had no luck. Bios Sata is set to AHCI. And I really tried all the bootloaders with the matching DSM versions and the different hardware versions as well (3615xs and 3617xs). Every time I tested, I reinitialize the USB pen drive, and the laptop hard drive to make sure the installation was clean. Also tried different usb pen drives, with different capacities.

The more I could progress was to get the loader to boot, be able to see the maching with find.synology.com and start the manual installation process of the DSM with the matching .pat file. But after the first reboot, I see the same bootloader menu in the laptop screen (install, reinstall, etc) nothing new, and when I allow to boot again, the machine would never be connected to the network again. Not really sure what it is doing since Jun's loader doesn't show nothing else on the screen of the laptop.

Any clue where the issue might be?

DSM 5.2 works great, but I would like to have the option to run DSM6.x

 

Thank you!

 

Dell XPS 14Z

Intel Core i5-2430M (dual-core 2.40-3.00GHz, 35W)

8GB (2x4GB DDR-1333 CL9)

GraphicsIntel HD 3000 Graphics

Display14.0” WLED Glossy 16:9 768p (1366x768)
Gigabit Ethernet (Atheros AR8151)
750GB 7200RPM HDD

Mobile Intel HM67 Express

 

https://www.cnet.com/products/dell-xps-14z/specs/

Link to comment
Share on other sites

you should make a new thread instead of reviving a over two year old non related one

 

dsm 6.x is to unspecific to help you anyway it can be 6.0, 6.1,6.2 and every one needs a different loader

i'd assume you did not read faq and turorial or you would know that its normal to not see anything after the initial boot message

 

so please read at least the minimum

(hint. 916+/918+ is no option for you as the cpu is to old and loader 1.03b/dsm6.2 needs old bios mode aka csm/legacy mode)

 

https://xpenology.com/forum/forum/83-faq-start-here/

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...