bvw103

32 bit instead of 64

Recommended Posts

Hello all, is there a 32 bit build too, i want to try and run it on a P4 ?

Anyone got that working ?

Share this post


Link to post
Share on other sites

Most, quite possibly all of the userspace of DS 4.2 is 32-bit and only the kernel is 64-bit (which is strange). Like this:

$ file bin/busybox
bin/busybox: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), statically linked, for GNU/Linux 2.4.3, stripped
$ file lib/libc.so.6
lib/libc.so.6: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.4.3, stripped

 

So by compiling the opensource kernel as i686 it could be possible to run the whole thing in 32-bit computer. Synobios is the only binary module that is 64-bit but it's possible overcome that.

 

But sorry, I don't have such a build...

Share this post


Link to post
Share on other sites
Recent DSM are 64bit only, but some older release of DSM were 32 bits initially.

There is a DS411+ 1167_x86-Repack (DSM 2.3-1167) that will work under x86

Source: http://forum.qnap.com/viewtopic.php?p=309634

. http://Download URL1: https://www.asuswebstorage.com/navigate ... A8B1F7574Y

. http://Download URL2: http://cht.tw/h/dd7pr

 

 

Those links are not working anymore . I'm trying to get a 32bit version of DSM.

Please help me, I can't find a 32 bit version anywere

Share this post


Link to post
Share on other sites

I've an issue on the synology assistant process. In the first step upon system installation I receive an error message:

It is not possible to establish a connection.

 

which is the problem ?

Share this post


Link to post
Share on other sites
Recent DSM are 64bit only, but some older release of DSM were 32 bits initially.

There is a DS411+ 1167_x86-Repack (DSM 2.3-1167) that will work under x86

Source: http://forum.qnap.com/viewtopic.php?p=309634

. http://Download URL1: https://www.asuswebstorage.com/navigate ... A8B1F7574Y

. http://Download URL2: http://cht.tw/h/dd7pr

 

very thx

my P4 cpu can be used

Share this post


Link to post
Share on other sites

I can't dl the file (first link is KO and second one seems NOK also - but all in chinese)

Did someone can upload and make available the file for x32 proc please.

Share this post


Link to post
Share on other sites

+1 . Even if it is an old DSM , i wish to use it on a P4 .

Thanks if someone can upload it somewehre ...

Share this post


Link to post
Share on other sites
I can't dl the file (first link is KO and second one seems NOK also - but all in chinese)

Did someone can upload and make available the file for x32 proc please.

 

Hi, in French forum we have retrieved the file : viewtopic.php?f=13&t=723&p=2443#p2443

My first try seems to show that this is the correct file because synology assistant detect it well , but my configuration (Asus motherboard with a P4 3.Ghz) doesn't seem to work... I'l have to give a try with other hardware...

Hope you'll get more success than me ... let's keep in touch !

 

Edit : Ide cable changed : Now block on Step 5 : write configurations files --> it loops without end ...

Share this post


Link to post
Share on other sites

I had success upgrade my Intel Pentium P3-866mhz with 384MB RAM old computer to DSM 3.2 x86 build. :wink:

 

8730022072_2773c0942f_b.jpg

Share this post


Link to post
Share on other sites

Cool ! Can you give us the ref of the mother board and how you process to upgrade from DSM2.3 to DSM3.2 ....

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

odie82544 can you please send me the links for the 3.2 and how did you install it.

I have a 32bit pc that I want to try it on, I will appreciate any help as i totally new to the DSM.

 

Thanks so much

Share this post


Link to post
Share on other sites

I already tried it, the problem was file corrupted when I did upload dsm 5.pat.

I did re-download the dsm5.pat from synology.com, but the problem is same.

Share this post


Link to post
Share on other sites

What do you mean by update?

dsm4 to dsm5 or dsm5 to last update like 5.4482 to 5.4493 or 5.4493 to 5.4493 update 2

 

to be sure that you have a correct pat , dowload it directly from synology website:

 

http://ukdl.synology.com/download/DSM/5.0/4493/

 

don't forget it is the ds214play to take and you will need the correct nonaboot, it means Nanoboot-5.0.2.4 DSM 5.0-4493 X86 for dsm 5.4493

 

to be simple take :

 

http://ukdl.synology.com/download/DSM/5.0/4493/DSM_DS214play_4493.pat

https://drive.google.com/file/d/0B8bHHUWAxe2kTFItM3o1M09GdUk/edit?usp=sharing

 

for me it works, take a look here to for more than 2 HD

 

http://xpenology.com/forum/viewtopic.php?f=13&t=3378

 

i hope it will help you

Share this post


Link to post
Share on other sites
I already tried it, the problem was file corrupted when I did upload dsm 5.pat.

I did re-download the dsm5.pat from synology.com, but the problem is same.

 

 

with regards to x86 dsm 5 install failure.

 

hiya, did you manage to get past this, i had dsm 4.3 working and decided to clean install dsm 5.

 

have downloaded the NB [nanoboot] images from all over and the pat file multiple times.

 

i keep getting the same file corrupt message.

 

if i can find the boot image i used with 4.3 i am going to re-install that and try to upgrade to dsm5.

 

wish me luck.

 

regards

 

sal

 

ps, i should add thanks to sancome, trantor, gnoboot peeps and the xpenology community in general pushing this project forward, i've been lurking on this forum for over a year now and just registered myself today on this forum.

 

sal.

Share this post


Link to post
Share on other sites

Hi All.

 

someone give me a loaded gun, i need to shoot my stoopid self.

 

Just an update. I got x86 DSM5 installed and am running parity check on 2 disks so i thought i'd better give some feed back to my original issue.

 

"File probably corrupted" message when trying to install DSM5 on x86.

 

I feel so stupid because its everywhere that the ds214play will only support max 2 internal disks.

 

The problem i had created was populating the P4 old dell machine with 3 disks (sata0, sata1, and sata2.)

 

baiscally ds214play.pat will get its knickers in a twist because it is expecting to only see 2 disks.

 

d'Oh .....

 

i've been trying to get this install since thursday evening and only got past the install of dsm pat file now. (on friday i got vexed and i did give up for the entire weekend)

 

by the way... would anyone have suggestions for bios optimisations? ie) ACHI over ATA, hyperthreading (on or off), and hdd performance (bypass or performance). its a dell bios and these are the only 3 items that seem worth experimenting with.

 

i found found this thread that may explain how to get more disks recognised in ds214play

 

https://translate.google.com/translate? ... edit-text=

 

the above link is from the french section of this forum.

 

Again. Much, Muchos, Tres love and appreciation for the contributors to xpenology and this forum.

Share this post


Link to post
Share on other sites